Results 1 to 10 of 10

Thread: Domain Problem

  1. #1
    csyperski is offline Member
    Join Date
    Oct 2005
    Posts
    13
    Rep Power
    9

    Default Domain Problem

    I must preface this question by saying other then the problem I am having now, I love zimbra. The interface is very clean and it runs pretty well. So here is my problem. I have a the server setup on FC3 and under my server settings when I have "DNS Lookup enabled" I can not receive any email, but I can send to all domains. So, when I disable "DNS Lookup enabled" I can recieve all email and I can send to most domain's but I can't send to hotmail.com for example. In the zimbra.log I get the following error....

    07C388B4238: to=<xxxxxxxx@hotmail.com>, relay=none, delay=33809, status=deferred (connect to hotmail.com[64.4.33.7]: Connection timed out)

    So it looks like I am resolving the domain name, but I don't know if I am looking the their mx record correctly. This error is not caused by a busy server on their end because when I am setup like this I can never get through.

    When I have "DNS Lookup enabled" I get the following error...

    Oct 13 06:38:20 mail1 postfix/lmtp[11677]: D059D8B4223: to=<xxxxxx@grassyassamoeba.com>, relay=none, delay=190, status=deferred (connect to mail1.grassyassamoeba.com[68.76.xxx.142]: Connection timed out)

    Any help would be greatly appreciated. Thanks
    Last edited by csyperski; 10-13-2005 at 07:15 AM.

  2. #2
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Seems like you have an incorrect Mx or DNS rocord for your domain. Does DNS (not just your /etc/hosts) have the correct IP pointing to your Zimbra box.

    My guess on hotmail not working when you disable DNS is that you send the internal IP of your server rather than the internet IP. So Hotmail drops your connection(or don't reply) when they try to do the reverse DNS on you SMTP chat. I think Yahoo and AOL also do reverse DNS on SMTP chat so you could try sending to one of them to validate or disprove my theory.

  3. #3
    csyperski is offline Member
    Join Date
    Oct 2005
    Posts
    13
    Rep Power
    9

    Default Rundown of my setup

    When I send an email to any of those domains it never gets through. Here is a little more info. Maybe I have something set up wrong, but I used to run postfix with squirrelmail as a frontend without any problem. For DNS I am using a third party called domain direct and my setup is as follows....

    A record
    grassyassamoeba.com
    68.76.252.142
    *.grassyassamoeba.com
    68.76.252.142
    mail1.grassyassamoeba.com
    68.76.252.142

    Mail Exchanges (MX Records)
    mail exchange ---- hostname ---- Preference
    grassyassamoeba.com ---- grassyassamoeba.com ----- 10
    mail1.grassyassamoeba.com ----- grassyassamoeba.com ----- 20

    Under zimbra
    -------------
    servers
    mail1.grassyassamoeba.com

    service hostname
    mail1.grassyassamoeba.com

    webmail mta
    mail1.grassyassamoeba.com

    enable dns lookup - disabled

    domains
    grassyassamoeba.com

    Once again thanks for any help.
    Last edited by csyperski; 10-13-2005 at 01:49 PM.

  4. #4
    csyperski is offline Member
    Join Date
    Oct 2005
    Posts
    13
    Rep Power
    9

    Default Update

    From what I have found the problem either has to do with a PTR record or SPF, has anyone ever set up either of these that could give me a little help. It looks like this is AOL's attempt to block spam.

    Thanks

  5. #5
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Quote Originally Posted by csyperski
    From what I have found the problem either has to do with a PTR record or SPF, has anyone ever set up either of these that could give me a little help. It looks like this is AOL's attempt to block spam.

    Thanks
    Does your maildomain have a valid DNS record that can be reversed in DNS? Is there any error in the logs that provides more detail?

  6. #6
    csyperski is offline Member
    Join Date
    Oct 2005
    Posts
    13
    Rep Power
    9

    Default zimbra.log

    attached is the output that I get from my zimbra.log when sending an email to yahoo, hotmail, msn, or aol.
    Attached Files Attached Files

  7. #7
    csyperski is offline Member
    Join Date
    Oct 2005
    Posts
    13
    Rep Power
    9

    Default Could This be my problem?

    Could this be my problem?

    when I do a dig here is what I get....


    [root@mail1 ~]# dig mx mail1.grassyassamoeba.com

    ; <<>> DiG 9.2.5 <<>> mx mail1.grassyassamoeba.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 43438
    ;; flags: qr rd; QUERY: 1, ANSWER: 1, AUTHORITY: 3, ADDITIONAL: 4

    ;; QUESTION SECTION:
    ;mail1.grassyassamoeba.com. IN MX

    ;; ANSWER SECTION:
    mail1.grassyassamoeba.com. 600 IN MX 20 grassyassamoeba.com.

    ;; AUTHORITY SECTION:
    grassyassamoeba.com. 600 IN NS ns1.domaindirect.com.
    grassyassamoeba.com. 600 IN NS ns2.domaindirect.com.
    grassyassamoeba.com. 600 IN NS ns3.domaindirect.com.

    ;; ADDITIONAL SECTION:
    grassyassamoeba.com. 600 IN A 68.76.252.142
    ns1.domaindirect.com. 152011 IN A 216.40.33.21
    ns2.domaindirect.com. 152011 IN A 216.40.33.22
    ns3.domaindirect.com. 152011 IN A 204.50.180.58

    ;; Query time: 69 msec
    ;; SERVER: 192.168.0.1#53(192.168.0.1)
    ;; WHEN: Sun Oct 16 10:33:04 2005
    ;; MSG SIZE rcvd: 190


    Where I do a reverse lookup here is what I get and I think this is where the problem lies.....

    [root@mail1 ~]# dig -x 68.76.252.142

    ; <<>> DiG 9.2.5 <<>> -x 68.76.252.142
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20592
    ;; flags: qr rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;142.252.76.68.in-addr.arpa. IN PTR

    ;; ANSWER SECTION:
    142.252.76.68.in-addr.arpa. 7040 IN PTR adsl-68-76-252-142.dsl.chcgil.ameritech.net. <---------- is this my problem because it is not resolving to my domain name?

    ;; AUTHORITY SECTION:
    252.76.68.in-addr.arpa. 172640 IN NS ns2.ameritech.net.
    252.76.68.in-addr.arpa. 172640 IN NS ns1.ameritech.net.

    ;; ADDITIONAL SECTION:
    ns1.ameritech.net. 145866 IN A 206.141.251.2
    ns2.ameritech.net. 145866 IN A 206.141.193.168

    ;; Query time: 26 msec
    ;; SERVER: 192.168.0.1#53(192.168.0.1)
    ;; WHEN: Sun Oct 16 10:33:55 2005
    ;; MSG SIZE rcvd: 169

  8. #8
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Quote Originally Posted by csyperski
    Could this be my problem?
    ;; ANSWER SECTION:
    142.252.76.68.in-addr.arpa. 7040 IN PTR adsl-68-76-252-142.dsl.chcgil.ameritech.net. <---------- is this my problem because it is not resolving to my domain name?
    I think so, since if those mail servers try to validate your domain they can't. Is your DNS local or are you really publishing that record some where like with dyndns?

  9. #9
    csyperski is offline Member
    Join Date
    Oct 2005
    Posts
    13
    Rep Power
    9

    Default Dns

    I believe that this record is being published by my isp. I am not sure how to manage a PTR record.

  10. #10
    csyperski is offline Member
    Join Date
    Oct 2005
    Posts
    13
    Rep Power
    9

    Default More info

    I have found another piece of information. When I have DNS lookups enabled unchecked it seems that I am doing a dns lookup on the A record and not the mx record. Here what I found in my log....

    :40:26 mail1 postfix/smtp[5949]: connect to hotmail.com[64.4.32.7]: Connection timed out

    this IP doesn't have a mx record

    [root@zmail ~]# dig mx hotmail.com

    ; <<>> DiG 9.2.5 <<>> mx hotmail.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 1763
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 5, ADDITIONAL: 19

    ;; QUESTION SECTION:
    ;hotmail.com. IN MX

    ;; ANSWER SECTION:
    hotmail.com. 2119 IN MX 5 mx4.hotmail.com.
    hotmail.com. 2119 IN MX 5 mx1.hotmail.com.
    hotmail.com. 2119 IN MX 5 mx2.hotmail.com.
    hotmail.com. 2119 IN MX 5 mx3.hotmail.com.

    ;; AUTHORITY SECTION:
    hotmail.com. 71297 IN NS ns1.msft.net.
    hotmail.com. 71297 IN NS ns2.msft.net.
    hotmail.com. 71297 IN NS ns3.msft.net.
    hotmail.com. 71297 IN NS ns4.msft.net.
    hotmail.com. 71297 IN NS ns5.msft.net.

    ;; ADDITIONAL SECTION:
    mx4.hotmail.com. 2127 IN A 65.54.190.179
    mx4.hotmail.com. 2127 IN A 65.54.253.230
    mx4.hotmail.com. 2127 IN A 65.54.190.230
    mx4.hotmail.com. 2127 IN A 65.54.167.230
    mx1.hotmail.com. 2127 IN A 64.4.50.50
    mx1.hotmail.com. 2127 IN A 65.54.252.99
    mx1.hotmail.com. 2127 IN A 64.4.50.99
    mx1.hotmail.com. 2127 IN A 65.54.166.99
    mx2.hotmail.com. 2127 IN A 65.54.190.7
    mx2.hotmail.com. 2127 IN A 65.54.166.230
    mx2.hotmail.com. 2127 IN A 65.54.190.50
    mx2.hotmail.com. 2127 IN A 65.54.252.230
    mx3.hotmail.com. 2127 IN A 64.4.50.239
    mx3.hotmail.com. 2127 IN A 64.4.50.179
    mx3.hotmail.com. 2127 IN A 65.54.253.99
    mx3.hotmail.com. 2127 IN A 65.54.167.5
    ns1.msft.net. 31 IN A 207.46.245.230
    ns2.msft.net. 31 IN A 64.4.25.30
    ns3.msft.net. 111280 IN A 213.199.144.151

    ;; Query time: 3 msec
    ;; SERVER: 1.1.2.38#53(1.1.2.38)
    ;; WHEN: Tue Oct 18 08:21:21 2005
    ;; MSG SIZE rcvd: 511


    Here is their a record listing....

    [root@zmail ~]# dig a hotmail.com

    ; <<>> DiG 9.2.5 <<>> a hotmail.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20507
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 5, ADDITIONAL: 5

    ;; QUESTION SECTION:
    ;hotmail.com. IN A

    ;; ANSWER SECTION:
    hotmail.com. 1620 IN A 64.4.33.7
    hotmail.com. 1620 IN A 64.4.32.7

    ;; AUTHORITY SECTION:
    hotmail.com. 71267 IN NS ns1.msft.net.
    hotmail.com. 71267 IN NS ns2.msft.net.
    hotmail.com. 71267 IN NS ns3.msft.net.
    hotmail.com. 71267 IN NS ns4.msft.net.
    hotmail.com. 71267 IN NS ns5.msft.net.

    ;; ADDITIONAL SECTION:
    ns1.msft.net. 1 IN A 207.46.245.230
    ns2.msft.net. 1 IN A 64.4.25.30
    ns3.msft.net. 111250 IN A 213.199.144.151
    ns4.msft.net. 1 IN A 207.46.66.75
    ns5.msft.net. 1 IN A 207.46.138.20

    ;; Query time: 1 msec
    ;; SERVER: 1.1.2.38#53(1.1.2.38)
    ;; WHEN: Tue Oct 18 08:21:52 2005
    ;; MSG SIZE rcvd: 239


    Is this something I have setup wrong?

    Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem setting default theme for a domain
    By iain in forum Administrators
    Replies: 8
    Last Post: 09-19-2007, 12:14 AM
  2. virtual domain login problem
    By wkruchas in forum Installation
    Replies: 0
    Last Post: 05-02-2007, 07:52 PM
  3. Domain Alias / User Alias problem after upgrading.
    By Bingo in forum Administrators
    Replies: 1
    Last Post: 04-20-2007, 03:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •