I ran into the following on both of our store servers this morning when i re-enabled HSM.

An error occurred: com.zimbra.common.service.ServiceException: system failure: Unable to copy MailboxBlob: {mailbox=2092, message=17269, path=/opt/zimbra/store/0/2092/msg/4/17269-32951.msg} to volume 3 ExceptionId:BlobMover:1265200522687:5f7e38e707feb3 b1 Code:service.FAILURE

I found some documention in a thread on these forums, that suggests this is an issue that reindexing the mailbox may solve.

The problem is, i'm not able to find anything which tells me what mailbox it failed on.

Here is the error from mailbox.log.

2010-02-03 07:35:22,904 ERROR [BlobMover] [] hsm - An error occurred while running BlobMover
com.zimbra.common.service.ServiceException: system failure: Unable to copy MailboxBlob: {mailbox=2092, message=17269, path=/opt/zimbra/store/0/2092/msg/4/17269-32951.msg} to volume 3
ExceptionId:BlobMover:1265200522687:5f7e38e707feb3 b1
Code:service.FAILURE
at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:253)
at com.zimbra.cs.hsm.BlobMover.moveBlobsInternal(Blob Mover.java:265)
at com.zimbra.cs.hsm.BlobMover.safeMoveBlobsInternal( BlobMover.java:204)
at com.zimbra.cs.hsm.BlobMover.moveBlobs(BlobMover.ja va:121)
at com.zimbra.cs.hsm.BlobMoverThread.run(BlobMoverThr ead.java:81)
at java.lang.Thread.run(Thread.java:595)
Caused by: java.io.FileNotFoundException: link(/opt/zimbra/hsm/0/3274/msg/1/6124-25429.msg, /opt/zimbra/hsm/0/2092/msg/4/17269-32951.msg): No such file or directory
at com.zimbra.znative.IO.link0(Native Method)
at com.zimbra.znative.IO.link(IO.java:88)
at com.zimbra.cs.store.FileBlobStore.link(FileBlobSto re.java:266)
at com.zimbra.cs.hsm.BlobMover.moveBlobsInternal(Blob Mover.java:258)
... 4 more

Thanks!