Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 34

Thread: ClamAV not identifying viruses

  1. #11
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Saves on backscatter would also confirm that the account was active aswell.

  2. #12
    blessendor is offline Active Member
    Join Date
    Dec 2009
    Posts
    46
    Rep Power
    5

    Default

    I don't tell about NDR as is, but for local users alert only, when my user trying to send e-mail with virus - I want he know about what happened.

    When we are using exim+clamav smtp relay (configured in email clients for out messages), our relay say to user which message was blocked bu antivirus and can't be sent - and SMTP connection closes.

  3. #13
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    You could add $warnvirussender = 1 into /opt/zimbra/conf/amavisd.conf.in and then
    Code:
    su - zimbra
    zmamavisdctl restart
    Have not tried that though.

  4. #14
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

  5. #15
    blessendor is offline Active Member
    Join Date
    Dec 2009
    Posts
    46
    Rep Power
    5

    Default

    Quote Originally Posted by uxbod View Post
    You could add $warnvirussender = 1 into /opt/zimbra/conf/amavisd.conf.in and then
    Code:
    su - zimbra
    zmamavisdctl restart
    Have not tried that though.
    In wich section of config?
    I place it after
    use strict;

    # COMMONLY ADJUSTED SETTINGS:

    $warnvirussender = 1;

    And now I have not any alerts - to sender or to receiver ))

  6. #16
    blessendor is offline Active Member
    Join Date
    Dec 2009
    Posts
    46
    Rep Power
    5

    Default

    Quote Originally Posted by uxbod View Post
    Ok, I registered and already pressed Vote, but no effect

  7. #17
    blessendor is offline Active Member
    Join Date
    Dec 2009
    Posts
    46
    Rep Power
    5

    Default

    Quote Originally Posted by blessendor View Post
    In wich section of config?
    I place it after
    use strict;

    # COMMONLY ADJUSTED SETTINGS:

    $warnvirussender = 1;

    And now I have not any alerts - to sender or to receiver ))
    I find that I place same string twice (at the end of config too). Now removed duplicate - and receiver got alert. Sender - didn't.

  8. #18
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    I think you will need to set in /opt/zimbra/conf/amavisd.conf.in under the following section
    Code:
    $policy_bank{'MYNETS'} = {
      originating                 => 1,
      warnvirussender         => 1,
      allow_disclaimers           => %%binary VAR:zimbraDomainMandatoryMailSignatureEnabled%%,
      log_level                   => 1,
    };
    In theory this means only local users who sent the message should receive the notification.

  9. #19
    blessendor is offline Active Member
    Join Date
    Dec 2009
    Posts
    46
    Rep Power
    5

    Default

    By default I have not var $warnvirussender

    Also interesting settings in the /opt/zimbra/conf/amavisd.conf.in:

    $virus_admin = '@@av_notify_user@@'; # notifications recip.

    $mailfrom_notify_admin = '@@av_notify_user@@'; # notifications sender
    $mailfrom_notify_recip = '@@av_notify_user@@'; # notifications sender
    $mailfrom_notify_spamadmin = '@@av_notify_user@@'; # notifications sender
    $mailfrom_to_quarantine = ''; # null return path; uses original sender if undef

  10. #20
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Quote Originally Posted by blessendor View Post
    By default I have not var $warnvirussender
    Correct; as it is not defined as standard within the Zimbra configuration. Hence filing the RFE.

Page 2 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clamav
    By physikal in forum Administrators
    Replies: 10
    Last Post: 05-18-2009, 09:48 AM
  2. [SOLVED] Howto: Update ClamAV
    By unilogic in forum Administrators
    Replies: 9
    Last Post: 12-12-2007, 05:28 AM
  3. [SOLVED] Clamav expiration notification
    By artimus in forum Administrators
    Replies: 8
    Last Post: 11-19-2007, 10:34 AM
  4. help for clamav outdated
    By newvision in forum Administrators
    Replies: 3
    Last Post: 02-16-2007, 09:14 PM
  5. Replies: 2
    Last Post: 03-15-2006, 09:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •