Results 1 to 6 of 6

Thread: mailbox stopped, zmmailboxdctl is not running = no happy

  1. #1
    antikx is offline Active Member
    Join Date
    Dec 2008
    Posts
    34
    Rep Power
    6

    Default mailbox stopped, zmmailboxdctl is not running = no happy

    hello,

    I have been running ver5 for a year on OS X now.
    Been working great.
    yesterday I stopped being able to access Zimbra (VIA URL in browser). In firefox, I immediately get a:
    Unable to connect
    Firefox can't establish a connection to the server at MyDomain | Domain Names, Web Hosting, and Free Domain Services

    A "zmcontrol status" gives me this:
    Host MyDomain | Domain Names, Web Hosting, and Free Domain Services
    antispam Running
    antivirus Running
    archiving Running
    ldap Running
    logger Running
    mailbox Stopped
    zmmailboxdctl is not running.
    mta Running
    snmp Running
    spell Running
    stats Running

    One thing that may have caused it was that I believe I did a Java update around that time.
    When I started trying to figure out what was wrong I was in a terminal and logged in as the zimbra user... I was constantly getting the error that it could find Java VIA the environment variable
    I recreated the java symbolic link in /opt/zimbra and pointed it to: /System/Library/Frameworks/JavaVM.framework/Home
    That seems to have fixed that error message, but hasn't made my Zimbra work.
    When I cat zmmailboxd.out I see some interesting stuff, but I'm not sure if it's anything to worry about:
    Code:
    CompilerOracle: exclude com/zimbra/cs/session/SessionMap putAndPrune
    CompilerOracle: exclude com/zimbra/cs/mailbox/MailItem delete
    0    INFO  [main] log - Logging to org.slf4j.impl.Log4jLoggerAdapter(org.mortbay.log) via org.mortbay.log.Slf4jLog
    Zimbra server reserving server socket port=110 bindaddr=null ssl=false
    Zimbra server reserving server socket port=995 bindaddr=null ssl=true
    Fatal error: exception while binding to ports
    java.net.SocketException: Unbound server sockets not implemented
    	at javax.net.ServerSocketFactory.createServerSocket(ServerSocketFactory.java:80)
    	at com.zimbra.common.util.NetUtil.newBoundServerSocket(NetUtil.java:97)
    	at com.zimbra.common.util.NetUtil.bindServerSocket(NetUtil.java:165)
    	at com.zimbra.common.util.NetUtil.bindSslTcpServerSocket(NetUtil.java:56)
    	at com.zimbra.common.handlers.PrivilegedHandler.openPorts(PrivilegedHandler.java:93)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    	at java.lang.reflect.Method.invoke(Method.java:592)
    	at org.mortbay.xml.XmlConfiguration.call(XmlConfiguration.java:534)
    	at org.mortbay.xml.XmlConfiguration.configure(XmlConfiguration.java:244)
    	at org.mortbay.xml.XmlConfiguration.configure(XmlConfiguration.java:206)
    	at org.mortbay.xml.XmlConfiguration.main(XmlConfiguration.java:968)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    	at java.lang.reflect.Method.invoke(Method.java:592)
    	at org.mortbay.start.Main.invokeMain(Main.java:183)
    	at org.mortbay.start.Main.start(Main.java:497)
    	at org.mortbay.start.Main.main(Main.java:115)
    Any suggestions or advice please?
    Do you want more info?

  2. #2
    bdial's Avatar
    bdial is offline Moderator
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    10

    Default

    zimbra comes with it's own java. on 5.0.21 the symlink is

    Code:
    lrwxrwxrwx 1 root root 23 2009-12-26 22:16 java -> /opt/zimbra/jdk1.5.0_20
    you should not be linking to your sysetm java

  3. #3
    antikx is offline Active Member
    Join Date
    Dec 2008
    Posts
    34
    Rep Power
    6

    Default

    thanks for the quick reply.
    in my /opt/zimbra directory I only have the following directories starting with "j":
    java/ jetty/ jetty-6.1.5/

    On a side note when I checked this morning, the orig java directory was linked to /usr

  4. #4
    antikx is offline Active Member
    Join Date
    Dec 2008
    Posts
    34
    Rep Power
    6

    Default

    Here is what /var/log/zimbra.log says when I try to start Zimbra:
    (see attachment)

    Any suggestions?
    Attached Files Attached Files

  5. #5
    antikx is offline Active Member
    Join Date
    Dec 2008
    Posts
    34
    Rep Power
    6

    Default bad to worse

    today when I do a "zmcontrol status" I now see this:
    Code:
    antispam                Stopped
    		zmamavisdctl is not running
    	antivirus               Stopped
    		zmamavisdctl is not running
    	archiving               Stopped
    		zmmtaconfig is running.
    		amavisd is not running.
    		zmamavisdctl is not running
    	ldap                    Running
    	logger                  Running
    	mailbox                 Stopped
    		zmmailboxdctl is not running.
    	mta                     Running
    	snmp                    Running
    	spell                   Running
    	stats                   Running
    Things are going from bad to worse.
    I feel like I'm missing something here.

  6. #6
    antikx is offline Active Member
    Join Date
    Dec 2008
    Posts
    34
    Rep Power
    6

    Default nmap

    I should also add that nmap shows me this:
    Code:
    PORT      STATE SERVICE      VERSION
    25/tcp    open  smtp         Postfix smtpd
    |_ SMTPcommands: EHLO amr06.sa.umanitoba.ca, PIPELINING, SIZE 10240000, VRFY, ETRN, STARTTLS, ENHANCEDSTATUSCODES, 8BITMIME, 250 DSN
    88/tcp    open  kerberos-sec Mac OS X kerberos-sec
    389/tcp   open  ldap         OpenLDAP 2.2.X
    465/tcp   open  ssl/smtp     Postfix smtpd
    631/tcp   open  ipp          CUPS 1.3.11
    5900/tcp  open  vnc          Apple remote desktop vnc
    10024/tcp open  smtp         amavisd smtpd

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. mailbox & mysql.server not running
    By ozlivingstone in forum Administrators
    Replies: 3
    Last Post: 12-24-2008, 01:41 PM
  2. zmmailboxdctl is not running
    By gargola in forum Installation
    Replies: 15
    Last Post: 04-12-2008, 02:02 AM
  3. Replies: 14
    Last Post: 01-09-2008, 04:07 AM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •