Results 1 to 4 of 4

Thread: Cleaning up backups and we get TO_DELETE- folders instead.

  1. #1
    BenG is offline Intermediate Member
    Join Date
    Mar 2007
    Posts
    18
    Rep Power
    8

    Default Cleaning up backups and we get TO_DELETE- folders instead.

    G'day All,
    After finally making it through an upgrade of 5.0.20 to 6.0.4.
    The new monitor started alerting us that our backup volume was getting a bit low (93%).
    Since we had it (the entire volume) backed up elsewhere, I surmised it was because of all the 3 or 4 "Full" backups I had done prior to the upgrade.

    So I went in as Zimbra, and issued zmbackup -del 25d and saw the available space increase slightly, as it deleted a few old Incrementals.
    My plan was to decrease 25d until I got below the magic 85%.

    However it stopped freeing up space after about 20d.

    So, since I had a full volume backup anyway, I decided to clear all the backups, still had 90% used....

    I then investigated the /backup/sessions/ folder and found a bunch of subfolders with "TO_DELETE-" prepended to them.
    These were "current" backups too.....

    Nothing in the docs for zmbackup mentions that there is a delay in purging the entries so what gives?

    In the end I used rm -rf to trash everything in the /backup directory and started again.

    Rgds Ben

  2. #2
    y@w's Avatar
    y@w
    y@w is offline Moderator
    Join Date
    Jan 2008
    Posts
    658
    Rep Power
    8

    Default

    We're seeing this same thing. Instead of actually deleting backups, we get TO_DELETE- prepended to the old backup volumes. We have two mailbox servers setup running the same cron job for backup deletes - one works as expected (deletes those sessions) and the other does this.

  3. #3
    y@w's Avatar
    y@w
    y@w is offline Moderator
    Join Date
    Jan 2008
    Posts
    658
    Rep Power
    8

    Default

    I've tried mv'ing the directories back to their original names and running zmbackup -del against the label name and it just prepends the name again..

    Anyone else seeing this or have any ideas?

  4. #4
    BenG is offline Intermediate Member
    Join Date
    Mar 2007
    Posts
    18
    Rep Power
    8

    Default

    G'day y@w,
    I've noticed that it "eventually" does remove them. I'd speculate it's doing a mv, then rm. Still be nice if it was confirmed.

    I'm also getting pretty nervous about -del.
    We ran out of space on the disk again. So manually went through and deleted a few backups.
    I did this by going into /sessions and running zmbackup -del and pressing "tab" to ensure I got the name right.
    It worked fine for the first few (oldest) incrementals, but then I got to the first "Full". Ran the -del and it deleted ALL of the backups, emptied the sessions completely.
    Luckily I do backup the entire server (it's a VM) with Diffs each night, so I'm not dead in the water, but not too happy about losing all of the backups, as restoration is a pain.....

    Rgds Ben

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •