Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Now I find why the attachment chinese filename is display error code

  1. #1
    crossany is offline Senior Member
    Join Date
    Mar 2006
    Posts
    59
    Rep Power
    9

    Post Now I find why the attachment chinese filename is display error code

    I compare with other mail server. I find the MIME like this:

    Content-Type: image/gif;
    name="=?gb2312?B?yP3Wu7LKx/IuZ2lm?="
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment;
    filename="=?gb2312?B?yP3Wu7LKx/IuZ2lm?="

    but Zimbra mail server sent mail MIME like this:
    Content-Type: image/pjpeg
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment; filename="& .jpg"
    that the zimbra mail server not appoint the attachment filename use which coding , I guess If you
    appoint the filename use the ISO8859-1 , like this:
    filename="=?ISO8859-1?yP3Wu7LKx/IuZ2lm?=". I think it's will be not problem with the chinese attachment filename.
    Last edited by crossany; 07-07-2006 at 01:52 AM.

  2. #2
    crossany is offline Senior Member
    Join Date
    Mar 2006
    Posts
    59
    Rep Power
    9

    Post I hope the problem will resolve quickly before 3.2

    Quote Originally Posted by crossany
    I compare with other mail server. I find the MIME like this:

    Content-Type: image/gif;
    name="=?gb2312?B?yP3Wu7LKx/IuZ2lm?="
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment;
    filename="=?gb2312?B?yP3Wu7LKx/IuZ2lm?="

    but Zimbra mail server sent mail MIME like this:
    Content-Type: image/pjpeg
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment; filename="& .jpg"
    that the zimbra mail server not appoint the attachment filename use which coding , I guess If you
    appoint the filename use the ISO8859-1 , like this:
    filename="=?ISO8859-1?yP3Wu7LKx/IuZ2lm?=". I think it's will be not problem with the chinese attachment filename.
    Zimbra is very good webmail I hope the Developer can quickly resolve the attachment chinese filename problem before 3.2 I think the 3.1.5 if resolve this problem the will very suit for the Asia market.

  3. #3
    dkarp is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    11

    Default bug 7361

    I'm pretty sure this is bug 7361. It's on the list of bugs we're trying to fix for 3.2.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  4. #4
    crossany is offline Senior Member
    Join Date
    Mar 2006
    Posts
    59
    Rep Power
    9

    Talking can you give a patch for me still to use 3.1.1

    Quote Originally Posted by dkarp
    I'm pretty sure this is bug 7361. It's on the list of bugs we're trying to fix for 3.2.
    I used 3.1.1 it's very good for me I don't want to update to 3.2
    so I hope when the 3.2 appear. I think it's just so java serlet problem .
    Thank you very much!!

  5. #5
    dkarp is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    11

    Default No patch to 3.1.1

    We don't generate patches for old versions of the software, I'm afraid. 3.1.4 is the current version; any bugfixes to it would come in the form of a 3.1.5 release. But 3.2 will have lots of new features, performance improvements, and bugfixes (including this one!) -- I'd strongly recommend it when it goes GA.

    Incidentally, it seems unlikely that this bug will make it into the 3.1.5 release (if such a release is needed) because nobody has voted for it in Bugzilla.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  6. #6
    crossany is offline Senior Member
    Join Date
    Mar 2006
    Posts
    59
    Rep Power
    9

    Talking this is a bug that no many people find but it's very important

    Quote Originally Posted by dkarp
    We don't generate patches for old versions of the software, I'm afraid. 3.1.4 is the current version; any bugfixes to it would come in the form of a 3.1.5 release. But 3.2 will have lots of new features, performance improvements, and bugfixes (including this one!) -- I'd strongly recommend it when it goes GA.

    Incidentally, it seems unlikely that this bug will make it into the 3.1.5 release (if such a release is needed) because nobody has voted for it in Bugzilla.
    I know not many people voted this bug I think now not many Asia people have
    study Zimbra . I just study before them. I think many Zimbra will popular in the world soon. So this bug will voted by many people.

  7. #7
    crossany is offline Senior Member
    Join Date
    Mar 2006
    Posts
    59
    Rep Power
    9

    Talking I waiting for 3.1.5 with no 8443 bug

    Quote Originally Posted by crossany
    I know not many people voted this bug I think now not many Asia people have
    study Zimbra . I just study before them. I think many Zimbra will popular in the world soon. So this bug will voted by many people.
    I wait for the Zimbra 3.1.5 and I hope the 8443 bug will be resolved.
    Hope a !!!

  8. #8
    dkarp is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    11

    Default no votes in bugzilla = fix probably not in patch release

    Quote Originally Posted by crossany
    I wait for the Zimbra 3.1.5 and I hope the 8443 bug will be resolved.
    Hope a !!!
    Voting would also help get it into 3.1.5 (if there is a 3.1.5). Otherwise, it will definitely be in 3.2.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  9. #9
    crossany is offline Senior Member
    Join Date
    Mar 2006
    Posts
    59
    Rep Power
    9

    Unhappy I just test the 3.2.0_M1_134 I find this error still at there

    Quote Originally Posted by dkarp
    Voting would also help get it into 3.1.5 (if there is a 3.1.5). Otherwise, it will definitely be in 3.2.
    I install the 3.2.0_M1_134 today, I find the zimbra UI become good, but my problem still at there that I have some sad. this is the MIME:
    Message-ID: <15856458.61152946304574.JavaMail.root@mail.sina.c n>
    Date: Sat, 15 Jul 2006 14:51:44 +0800 (CST)
    From: admin@cross.cn
    To: crossany@gmail.cn
    Subject: =?utf-8?Q?Fwd:_=E4=BE=83=E4=BE=83=E4=B8=AD=E6=96=87?=
    In-Reply-To: <28868898.31152946249304.JavaMail.root@mail.cross. cn>
    MIME-Version: 1.0
    Content-Type: multipart/mixed;
    boundary="----=_Part_3_16405758.1152946304509"

    ------=_Part_3_16405758.1152946304509
    Content-Type: multipart/alternative;
    boundary="----=_Part_4_14814968.1152946304510"

    ------=_Part_4_14814968.1152946304510
    Content-Type: text/plain; charset=utf-8
    Content-Transfer-Encoding: quoted-printable


    ----- Forwarded Message -----=20
    From: admin@cross.cn=20
    To: crossany@gmail.com=20
    Sent: 2006=E5=B9=B47=E6=9C=8815=E6=97=A5 =E6=98=9F=E6=9C=9F=E5=85=AD =E4=B8=
    =8B=E5=8D=8802=E6=97=B650=E5=88=8649=E7=A7=92 GMT-0200=20
    Subject: =E4=BE=83=E4=BE=83=E4=B8=AD=E6=96=87=20


    =E4=BE=83=E4=BE=83=E4=B8=AD=E6=96=87
    ------=_Part_4_14814968.1152946304510
    Content-Type: text/html; charset=utf-8
    Content-Transfer-Encoding: quoted-printable

    <html><head></head><body><div style=3D'font-family:Times New Roman, Times, =
    serif;font-size:12pt;color:#000000;'><br>----- Forwarded Message -----<br>F=
    rom: admin@cross.cn<br>To: crossany@gmail.com<br>Sent: 2006=E5=B9=B47=E6=9C=
    =8815=E6=97=A5 =E6=98=9F=E6=9C=9F=E5=85=AD =E4=B8=8B=E5=8D=8802=E6=97=B650=
    =E5=88=8649=E7=A7=92 GMT-0200<br>Subject: =E4=BE=83=E4=BE=83=E4=B8=AD=E6=96=
    =87<br><br><div style=3D"font-family: Times New Roman,Times,serif; font-siz=
    e: 12pt; color: rgb(0, 0, 0);">=E4=BE=83=E4=BE=83=E4=B8=AD=E6=96=87</div></=
    body></html>
    ------=_Part_4_14814968.1152946304510--

    ------=_Part_3_16405758.1152946304509
    Content-Type: image/jpeg
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment; filename="‰x.jpg"

    the filename Encoding is not point . so Bug 8443 still there!!!
    Last edited by crossany; 07-05-2010 at 12:41 AM.

  10. #10
    dkarp is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    11

    Default Bugfix after beta

    The bugfix was put in after the 3.2 beta was built. It should be in the 3.2 GA release:

    Date: Sat, 15 Jul 2006 06:56:48 -0700 (PDT)
    From: Demo User One <user1@example.com>
    To: user2 <user2@example.com>
    Message-ID: <10617394.01152971808765.JavaMail.SYSTEM@EXAMPLE >
    Subject: testing attachments
    MIME-Version: 1.0
    Content-Type: multipart/mixed; boundary="----=_Part_0_18999844.1152971808671"

    ------=_Part_0_18999844.1152971808671
    Content-Type: text/plain; charset=utf-8
    Content-Transfer-Encoding: 7bit

    Testing!
    ------=_Part_0_18999844.1152971808671
    Content-Type: image/gif
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment; filename="=?utf-8?Q?=E8=AF=AD=E8=A8=80=E5=B7=A5=E5=85=B7.gif?="

    R0lGODlhEAAQAJEAAP////8AmWaZ/wBmzCH5BAAAAAAALAAAAAAQABAAAAImhI+pyzjTjngwgins
    fSJH+miYtnnWKA5mhJJMAMByTM/1Pcs5fhcAOw==
    ------=_Part_0_18999844.1152971808671--
    Bugzilla - Wiki - Downloads - Before posting... Search!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I just test the 3.2_M2 find a bug
    By crossany in forum Administrators
    Replies: 2
    Last Post: 07-25-2006, 08:07 AM
  2. Replies: 2
    Last Post: 06-20-2006, 07:14 PM
  3. what's the attachment filename charset?
    By crossany in forum Administrators
    Replies: 2
    Last Post: 06-15-2006, 11:53 PM
  4. simplified chinese Attachment name error code
    By crossany in forum I18N/L10N - Translations
    Replies: 1
    Last Post: 04-28-2006, 08:44 AM
  5. attachment with Chinese name error
    By majorcheng in forum Users
    Replies: 3
    Last Post: 04-10-2006, 12:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •