Results 1 to 5 of 5

Thread: [SOLVED] Postfix not running after power outtage

  1. #1
    mutinda is offline Intermediate Member
    Join Date
    Dec 2006
    Posts
    23
    Rep Power
    8

    Default [SOLVED] Postfix not running after power outtage

    Hi folks,

    We had a power blackout at the office recently and since then my Zimbra's mta service has been down. I've tried an upgrade using the same version (4.5.0_GA_612.FC5) but the service remains stopped:

    Code:
    [zimbra@kenyalawreports zcs]$ zmcontrol status
    Host kenyalawreports.or.ke
            antispam                Running
            antivirus               Running
            ldap                    Running
            logger                  Running
            mailbox                 Running
            mta                     Stopped
                    postfix is not running
            snmp                    Running
    In the logs, I get the following:

    Code:
    Dec 28 04:50:02 kenyalawreports zimbramon[26384]: 26384:info: 2009-12-28 04:50:01, QUEUE: 0 0
    Dec 28 04:50:08 kenyalawreports zmtomcatmgr[26587]: status requested
    Dec 28 04:50:08 kenyalawreports zmtomcatmgr[26587]: status OK
    Dec 28 01:50:09 kenyalawreports postfix/postqueue[26612]: fatal: /opt/zimbra/postfix-2.2.9/conf/main.cf, line 1: missing '=' after attribute name: "Firefox/2.0.0.20""
    Dec 28 04:50:10 kenyalawreports zimbramon[26387]: 26387:info: 2009-12-28 04:50:01, STATUS: kenyalawreports.or.ke: antispam: Running
    Dec 28 04:50:10 kenyalawreports zimbramon[26387]: 26387:info: 2009-12-28 04:50:01, STATUS: kenyalawreports.or.ke: ldap: Running
    Dec 28 04:50:10 kenyalawreports zimbramon[26387]: 26387:info: 2009-12-28 04:50:01, STATUS: kenyalawreports.or.ke: logger: Running
    Dec 28 04:50:10 kenyalawreports zimbramon[26387]: 26387:info: 2009-12-28 04:50:01, STATUS: kenyalawreports.or.ke: mailbox: Running
    Dec 28 04:50:10 kenyalawreports zimbramon[26387]: 26387:info: 2009-12-28 04:50:01, STATUS: kenyalawreports.or.ke: mta: Stopped
    Dec 28 04:50:10 kenyalawreports zimbramon[26387]: 26387:info: 2009-12-28 04:50:01, STATUS: kenyalawreports.or.ke: snmp: Running
    I've viewed the main.cf file and it has the "Firefox/2.0.0.20" in line 1 as stated in the log above. I'm not sure what should come after the "=" sign. Or can I just comment out that line?

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by mutinda View Post
    I've viewed the main.cf file and it has the "Firefox/2.0.0.20" in line 1 as stated in the log above. I'm not sure what should come after the "=" sign.
    That's not a valid entry in that file.

    Quote Originally Posted by mutinda View Post
    Or can I just comment out that line?
    Do you have a backup of your /opt/zimbra folder structure?

    Please update your forum profile with the output of the following command (do not post it in this thread):

    Code:
    zmcontrol -v
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    mutinda is offline Intermediate Member
    Join Date
    Dec 2006
    Posts
    23
    Rep Power
    8

    Default

    Bill,

    I've updated my profile with my Zimbra version as requested.

    I compared contents of the 'wierd' main.cf with those of one from a backup and there were glaring differences. After replacing my 'wierd' one with the backup, Zimbra is up and running. Oh, the wisdom of doing backups!

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by mutinda View Post
    I've updated my profile with my Zimbra version as requested.
    Thanks.

    Quote Originally Posted by mutinda View Post
    I compared contents of the 'wierd' main.cf with those of one from a backup and there were glaring differences. After replacing my 'wierd' one with the backup, Zimbra is up and running. Oh, the wisdom of doing backups!
    Absolutely, a backup (and restore) strategy shouldn't be overlooked.

    I'd also suggest you take this server offline and do a backup then a file system check to see if there are any lurking problems with the file system after the power-outage, you never know when a UPS will come in handy.

    I see you're on an older (and now unsupported) version of Zimbra, you're missing out on all the wonderful features in the new version - surely an upgrade must be in the pipeline?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    mutinda is offline Intermediate Member
    Join Date
    Dec 2006
    Posts
    23
    Rep Power
    8

    Default

    Bill,

    Sometimes I like to defer to the 'If it ain't broke don't try and fix it' philosophy, but I'm aware that no software is perfect so upgrades aren't always a bad idea. I should at least move to version 5. Seriously considering it...

    Thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] mailboxmanager does not start
    By jrefl5 in forum Administrators
    Replies: 18
    Last Post: 01-30-2012, 11:40 PM
  2. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 09:36 AM
  3. Can't seem to get global in BES
    By sdemeyer in forum Zimbra Connector for BlackBerry
    Replies: 12
    Last Post: 03-19-2008, 08:22 AM
  4. First Install on FC7: postfix is not running.
    By mauroreggio in forum Installation
    Replies: 1
    Last Post: 12-13-2007, 01:53 PM
  5. postfix is not running
    By kotogen in forum Administrators
    Replies: 2
    Last Post: 06-13-2006, 06:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •