Results 1 to 6 of 6

Thread: External GAL autocomplete issue

  1. #1
    yasanthau is offline Active Member
    Join Date
    Nov 2009
    Posts
    38
    Rep Power
    5

    Default External GAL autocomplete issue

    Zimbra is setup to query addresses from a External GAL. Settings are as follows.

    GAL Mode = External
    Most results returned by GAL search = 1000
    Server Type = LDAP
    External Server Name = ldap://192.168.xx.xx:389
    LDAP Filter = (|(cn = %s*)(sn=%s*)(gn=%s*)(mail=%s*))
    Autocomplete Filter = (|(cn = %s*)(sn=%s*)(gn=%s*)(mail=%s*))
    LDAP search base = (O=xxx)

    Some addresses in the LDAP are not coming for Autocomplete. But they can be viewed when we click on "To" button and search. What can be the reason that some addresses are not coming for Autocomplete? The Filter is same for LDAP Filter and Autocomplete filter. Thank you.

  2. #2
    ChaSer is offline Loyal Member
    Join Date
    Oct 2009
    Location
    Ukraine
    Posts
    79
    Rep Power
    5

    Default

    Quote Originally Posted by yasanthau View Post
    Some addresses in the LDAP are not coming for Autocomplete
    Provide some example please.
    Reason may be in someone similar char like ',' (comma).

  3. #3
    yasanthau is offline Active Member
    Join Date
    Nov 2009
    Posts
    38
    Rep Power
    5

    Default

    Sometimes cannot search anything from GAL


    2009-12-25 12:35:26,782 INFO [btpool0-965://192.168.10.178/service/soap/SearchGalRequest] [name=niranjiw@zim.ual.lk;mid=1334;ip=192.168.140.1 5;ua=ZimbraWebClient - IE6 (Win)/6.0.4_GA_2038.RHEL5;] SoapEngine - handler exception
    com.zimbra.common.service.ServiceException: system failure: ldap search failed
    ExceptionId:btpool0-965://192.168.10.178/service/soap/SearchGalRequest:1261724726782:dd78216739d2496b
    Code:service.FAILURE
    at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:247)
    at com.zimbra.cs.gal.GalSearchControl.ldapSearch(GalS earchControl.java:377)
    at com.zimbra.cs.gal.GalSearchControl.search(GalSearc hControl.java:113)
    at com.zimbra.cs.service.account.SearchGal.handle(Sea rchGal.java:77)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:418)
    ..........................
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:451)
    Caused by: com.zimbra.common.service.ServiceException: system failure: unable to search gal
    ExceptionId:btpool0-965://192.168.10.178/service/soap/SearchGalRequest:1261724726782:dd78216739d2496b
    Code:service.FAILURE

  4. #4
    yasanthau is offline Active Member
    Join Date
    Nov 2009
    Posts
    38
    Rep Power
    5

    Default

    Found another error on /opt/zimbra/log/mailbox.log

    Caused by: javax.naming.NamingException: LDAP response read timed out, timeout used:30000ms.; remaining name 'O=ual'

    Can we increase "LDAP response read timed out"?

    After restarting zimbra, it works for sometime and again stops

  5. #5
    yasanthau is offline Active Member
    Join Date
    Nov 2009
    Posts
    38
    Rep Power
    5

    Default

    After configuring a GAL sync account and a GAL Datasource, the addresses in the LDAP server sync with a addressbook on the specified gal sync account.

    But when autocomplete works, the addresses are shown as;

    "{\"ZMVAL\":[\"Achala Wanninayaka\",\"achalaw\"]}" <achalaw@sub.domain.lk>;

    How can I get it filtered just to get only the display name and email address?

    When I look at the address book, the entries are shown by email address. Not by display name. But when I go to edit, all details are there perfectly with display name, first name, last name, email address, and other field contains CN=Achala Wanninayaka,O=Base

  6. #6
    king0770's Avatar
    king0770 is offline Zimbra Employee
    Join Date
    Sep 2007
    Posts
    186
    Rep Power
    7

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Problem with External GAL datasource
    By emacias in forum Administrators
    Replies: 1
    Last Post: 07-10-2012, 08:52 AM
  2. External GAL & Select Addresses
    By ashm in forum Administrators
    Replies: 1
    Last Post: 07-07-2011, 02:14 AM
  3. [SOLVED] External GAL - Not working
    By yasanthau in forum Administrators
    Replies: 1
    Last Post: 12-17-2009, 10:22 PM
  4. [SOLVED] Enable GAL autocomplete!
    By zibra in forum Administrators
    Replies: 2
    Last Post: 10-05-2008, 09:23 AM
  5. GAL / External / Active Directory Setup Issue
    By dfriestedt in forum Installation
    Replies: 4
    Last Post: 06-19-2008, 03:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •