Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: zimbramon flooding /var/log/syslog

  1. #11
    maxxer's Avatar
    maxxer is offline Trained Alumni
    Join Date
    Feb 2009
    Location
    Lecco, Italy
    Posts
    552
    Rep Power
    7

    Default

    I have an ubuntu64 with z6. syslog.conf is a little different but my /var/log/messages is flooded more than on debian
    Code:
    local0.*                @srv01-yo.xxx.local
    local1.*                @srv01-yo.xxx.local
    auth.*                  @srv01-yo.xxx.local
    local0.*                -/var/log/zimbra.log
    local1.*                -/var/log/zimbra-stats.log
    auth.*                  -/var/log/zimbra.log
    mail.*                @srv01-yo.xxx.local
    mail.*                -/var/log/zimbra.log
    YetOpen S.r.l. ~ Your open source partner
    Lecco (LC) - ITALY
    http://www.yetopen.it

  2. #12
    pebcomputing is offline Active Member
    Join Date
    Sep 2008
    Posts
    46
    Rep Power
    6

    Default

    I've submitted this as Bug ID #43541. Here's the link to the buglizza entry for reference. Please vote for it! Bug 43541 – system logs flooded with zimbra logging noise

    Thanks phoenix!

  3. #13
    rfoster is offline Active Member
    Join Date
    Aug 2007
    Location
    U.S. Pacific Northwest
    Posts
    25
    Rep Power
    7

    Default

    I'm getting this and it really makes syslog difficult to monitor. Still only a handful of votes after I added mine...

  4. #14
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,488
    Rep Power
    56

    Default

    Quote Originally Posted by rfoster View Post
    I'm getting this and it really makes syslog difficult to monitor. Still only a handful of votes after I added mine...
    A fix is targeted for the next release.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #15
    mmichalik is offline Member
    Join Date
    Sep 2008
    Posts
    14
    Rep Power
    6

    Default

    Phoenix, we just installed 6.0.5_GA_2213.UBUNTU8_64.FOSS Feb 3, 2010 on a 8.04 LTS 64-bit server and this behaviour is still appearing in our syslog.

    Is there a fix or work around that can be implemented?

    Thanks,

    Mike

  6. #16
    maxxer's Avatar
    maxxer is offline Trained Alumni
    Join Date
    Feb 2009
    Location
    Lecco, Italy
    Posts
    552
    Rep Power
    7

    Default

    Quote Originally Posted by mmichalik View Post
    Phoenix, we just installed 6.0.5_GA_2213.UBUNTU8_64.FOSS Feb 3, 2010 on a 8.04 LTS 64-bit server and this behaviour is still appearing in our syslog.

    Is there a fix or work around that can be implemented?
    on te bug above you should find instructions on how to fix syslog
    YetOpen S.r.l. ~ Your open source partner
    Lecco (LC) - ITALY
    http://www.yetopen.it

  7. #17
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,367
    Rep Power
    10

    Default

    We see the same issue on SLES, and needed to modify a few lines in /etc/syslog-ng/syslog-ng.conf to fix this. There is also a bug on this in bugzilla: Bug 43541 – rsyslog: exclude local1 and local0 from logging to /var/log/messages

    To fix this problem, we first changed these lines:
    Code:
    filter f_local      { facility(local0, local1, local2, local3,
                                   local4, local5, local6, local7); };
    to this line:
    Code:
    filter f_local      { facility(local0, local1, local2, local3,
                                   local4, local5, local6, local7) and not filter(zimbra_local0) and not filter(zimbra_local1) and not filter(zimbra_auth) and not filter(zimbra_mail); };
    Next, we changed this line:
    Code:
    filter f_messages   { not facility(news, mail) and not filter(f_iptables); };
    the same way, to this line:
    Code:
    filter f_messages   { not facility(news, mail) and not filter(f_iptables) and not filter(zimbra_local0) and not filter(zimbra_local1) and not filter(zimbra_auth) and not filter(zimbra_mail); };
    The first change keeps the Zimbra bits out of /var/log/localmessages and the second change keeps /var/log/messages clean.

    Different distros and different syslog engines do things differently; it looks to me like Zimbra hasn't cataloged all the permutations just yet to incorporate in their logger setup scripts, so adding to that bug report with your own changes would be helpful to Zimbra and other users!

    Hope that helps,
    Mark

  8. #18
    mmichalik is offline Member
    Join Date
    Sep 2008
    Posts
    14
    Rep Power
    6

    Default

    Based on the bug report, I adjusted the syslog.conf file to include the local0,local1.none entries in the three places that Quanah Gibson-Mount suggested in Comment #10.

    Once I adjusted those three areas and restarted the syslog, everything is calm again.

    Thanks guys for all your help on this post.

    Yet ANOTHER reason why Zimbra just ROCKS!

    Mike

  9. #19
    mrcoffee11 is offline Senior Member
    Join Date
    Oct 2007
    Posts
    57
    Rep Power
    7

    Default

    Any solution for a Fedora 11 x64 zimbra 6.0.7 installation?
    Thnx!
    Roderick

  10. #20
    mrcoffee11 is offline Senior Member
    Join Date
    Oct 2007
    Posts
    57
    Rep Power
    7

    Default

    Not sure if I didnt mess up anything else but I think this worked:
    vi /etc/rsyslog.conf

    changed
    #*.info;mail.none;authpriv.none;cron.none /var/log/messages

    to

    *.info;mail.none;authpriv.none;cron.none;local0.no ne;local1.none /var/log/messages

    /etc/init.d/rsyslog restart

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Change frequency of zimbramon notifications?
    By nsmarler in forum Administrators
    Replies: 4
    Last Post: 02-08-2010, 03:00 PM
  2. I've been spammed by zimbramon
    By fernandoflorez in forum Administrators
    Replies: 6
    Last Post: 12-12-2009, 08:54 PM
  3. E-mail flooding ... possible Connector problem
    By ksebastiant in forum Zimbra Connector for Outlook
    Replies: 2
    Last Post: 04-08-2008, 09:13 AM
  4. [SOLVED] simple q.: how to stop zimbramon
    By maumar in forum Administrators
    Replies: 1
    Last Post: 08-28-2007, 01:20 AM
  5. Zimbramon craches every night
    By IrPr in forum Administrators
    Replies: 3
    Last Post: 12-30-2006, 11:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •