Ok, we got close to our goal setting up the Samba environment.

However, one problem is left. The zmposix user wont bind. The zimbra.log shows the following:

Code:
Dec 11 20:52:22 zimbra slapd[460]: conn=158 op=0 BIND dn="uid=zmposix,cn=appaccts,cn=zimbra" method=128
Dec 11 20:52:22 zimbra slapd[460]: conn=158 op=0 RESULT tag=97 err=49 text=
Dec 11 20:52:22 zimbra slapd[460]: conn=158 op=1 UNBIND
Dec 11 20:52:22 zimbra slapd[460]: conn=158 fd=21 closed
err=49 seems to be an authentification problem. The log also showed "invalid credentials" before, its obviously a password problem? I added the user through posixusersldif like showed in the wiki:

Code:
dn: uid=zmposix,cn=appaccts,cn=zimbra
uid: zmposix
objectClass: zimbraAccount
objectClass: organizationalPerson
cn: zmposix
sn: zmposix
zimbraAccountStatus: active
zimbraIsSystemResource: TRUE
zimbraId: 59BC2282-98CC-11DE-9492-C023E3CEB16B
description: The zimbra posix account
userPassword: {SSHA}QWkRtX5CQPDVzzhJKH9kDoLE5rP/hBu8
and replaced the SSHA with the value I got from slappasswd.

When I do "ldapsearch" and enter the password clear, the password I set is correct. Im not really sure now if the password in the ldap.conf needs to be clear or in {SSHA}. I tried both options and none works. Also, Im not really sure if it needs to be in SSHA, do I need the excact {SSHA}code that I formerly used in the posixusers.ldif, or can I use any thats output by doing "slappasswd"?

Help would be highly appreciated!