Results 1 to 3 of 3

Thread: A little script for parent-child sharing

  1. #1
    thesubmitter is offline Active Member
    Join Date
    Jun 2008
    Posts
    41
    Rep Power
    6

    Default A little script for parent-child sharing

    Hi,

    I made a little script based on : Mailboxes: Sharing vs. Relationships » Zimbra :: Blog

    Here is a simple shell script to automate the procedure just replace YOURDOMAIN with your domain.

    #!/bin/sh/
    echo "Username of the Parent Account"
    read parent
    echo "Username of the Child Account"
    read child
    childid=$(zmprov ga $child@YOURDOMAIN | grep zimbraId: | cut -d " " -f2)
    zmprov ma $parent@YOURDOMAIN +zimbraChildAccount $childid
    zmprov ma $parent@YOURDOMAIN +zimbraPrefChildVisibleAccount $childid

    Thanks,
    Amir

  2. #2
    Klug's Avatar
    Klug is online now Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,292
    Rep Power
    13

    Default

    Thanks for the script.

    For people who wants to use it, don't forget family mailboxes currently don't work in ZCS 6.0.x.
    Bug 37217 - family mailboxes - not working in GnR

  3. #3
    Hivos's Avatar
    Hivos is offline Advanced Member
    Join Date
    Aug 2009
    Location
    The Hague -- The Netherlands
    Posts
    201
    Rep Power
    5

    Default

    Here's some more scripts we cooked up a while ago to administrate family mailboxes.

    Administrate primary / secondary mail accounts

    Since 6.0.5 family mailboxes are "sortof" usable again, unless you need zimlets to function in a family mailbox.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zimbra opesource Backup Script Problem!
    By tashi in forum Administrators
    Replies: 4
    Last Post: 03-30-2009, 11:49 PM
  2. [SOLVED] Moving Zimbra to a new server
    By krolen in forum Administrators
    Replies: 109
    Last Post: 02-05-2009, 11:38 AM
  3. Zimbra Open Source Backup Help
    By ayush1440 in forum Administrators
    Replies: 8
    Last Post: 11-13-2008, 04:56 AM
  4. [SOLVED] Postfix failing to start.
    By bonoboslr in forum Administrators
    Replies: 1
    Last Post: 08-30-2008, 01:42 AM
  5. [SOLVED] Debian Etch 32 / 64: MTA not working
    By xflip in forum Installation
    Replies: 2
    Last Post: 01-18-2008, 04:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •