Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: zmtrainsa doesnt appear to work

  1. #1
    kowell is offline Special Member
    Join Date
    May 2006
    Posts
    118
    Rep Power
    9

    Default zmtrainsa doesnt appear to work

    I have move or declare many mails as junk but i still recive mail from those directions into mine inbox what can I do to resolve this or run the trainsa manuale for all inboxes, I have read the wike and the manual but for isnt clear what to do to run the zmtransa for all the accounts in the server.

    I know that I can configure a cron job for doing this bur Im not sure how to do it

    any suggestions??

  2. #2
    kowell is offline Special Member
    Join Date
    May 2006
    Posts
    118
    Rep Power
    9

    Default

    After searching and searching and more searching I figure out that when I make the install or the upgrad the install setup doesnt create the corrects spam/ham accounts, there were created with worngs domains thats why I my sapm trainer doesnt appear to work

    Any ideas of cuold be worng with this of making worng spam/ham accounts??

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,582
    Rep Power
    57

    Default

    The spam/ham accounts will be created in the domain that you originally installed zimbra, has it changed since that initial install?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    kowell is offline Special Member
    Join Date
    May 2006
    Posts
    118
    Rep Power
    9

    Default

    thats was the problem I didnt change the domain and never where created this accounts correctly eaither from the initial install. I didnt worry about spam till today.
    I just created to accounts for spam/ham using
    zmprov ca the account pass
    and modified with this to comands:
    zmprov mcf zimbraSpamIsSpamAccount "the account"
    zmprov mcf zimbraSpamIsNotSpamAccount "the account"

    when I run zmtrainsa the log is:
    [] INFO: Total messages processed: 0
    [] INFO: Total messages processed: 0
    upgrading to DB_File, please be patient: /opt/zimbra/amavisd/.spamassassin/old_bayes_seen
    DB_File: copied 451 entries
    upgrading to DB_File, please be patient: /opt/zimbra/amavisd/.spamassassin/old_bayes_toks
    DB_File: copied 25730 entries
    import successful, original files saved with "old" prefix
    archive-iterator: readdir found no mail in '/tmp/spam.6227' directory
    Learned from 0 message(s) (0 message(s) examined).
    archive-iterator: readdir found no mail in '/tmp/ham.6227' directory
    Learned from 0 message(s) (0 message(s) examined).
    dspam_clean starting
    PROCESSING USER: zimbra
    Processing sigs; age: 14
    Processing probabilities; age: 0
    Processing unused; any: 90 quota: 30 nospam: 15 onehit: 15
    zimbra@linux:~> zmtrainsa
    [] INFO: Total messages processed: 0
    [] INFO: Total messages processed: 0
    upgrading to DB_File, please be patient: /opt/zimbra/amavisd/.spamassassin/old_bayes_seen
    DB_File: copied 451 entries
    upgrading to DB_File, please be patient: /opt/zimbra/amavisd/.spamassassin/old_bayes_toks
    DB_File: copied 25730 entries
    import successful, original files saved with "old" prefix
    archive-iterator: readdir found no mail in '/tmp/spam.7657' directory
    Learned from 0 message(s) (0 message(s) examined).
    archive-iterator: readdir found no mail in '/tmp/ham.7657' directory
    Learned from 0 message(s) (0 message(s) examined).
    bayes: synced databases from journal in 0 seconds: 53 unique entries (53 total entries)
    dspam_clean starting
    PROCESSING USER: zimbra
    Processing sigs; age: 14
    Processing probabilities; age: 0
    Processing unused; any: 90 quota: 30 nospam: 15 onehit: 15

    but it seems not to be learning some mail that I have recive and use the spam buttton to send it to the junk folder

    have I make something worong when I created this acoounts??
    Last edited by kowell; 06-25-2006 at 10:35 PM.

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,582
    Rep Power
    57

    Default

    Are you seeing many spam messages in your inboxes? What are your train/kill settings for spam in the admin gui?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    kowell is offline Special Member
    Join Date
    May 2006
    Posts
    118
    Rep Power
    9

    Default

    is there a way to run zmtrainsa to all the acounts server and not just the "zimbra" user??
    I dont every pass of my clients to do it manually and honestly is litle bit tedeous to do it that way


    my train/kill es 66/25

  7. #7
    kowell is offline Special Member
    Join Date
    May 2006
    Posts
    118
    Rep Power
    9

    Default

    when I log into the sapm account it says tha a specific email was declared as spam by may account bt when the email is send it appears in the inbox folder and not into the junk folder

    i make a mistake the train/kill is 25/66

  8. #8
    last1ghost is offline Junior Member
    Join Date
    Jun 2006
    Posts
    8
    Rep Power
    9

    Default i have the same porblem

    unfortunately, when i move any message to junk folder and run zmtrainsa on junk folder of specific user, i still receive the same message in inbox.
    zmtrainsa working fine and said it update database but nothing change and i check the spam account and find all mails i marck it as junk....


    Can any one help me

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,582
    Rep Power
    57

    Default

    Quote Originally Posted by last1ghost
    unfortunately, when i move any message to junk folder and run zmtrainsa on junk folder of specific user, i still receive the same message in inbox.
    zmtrainsa working fine and said it update database but nothing change and i check the spam account and find all mails i marck it as junk....


    Can any one help me
    Welcome to the forums.

    You will continue receive the message in your inbox until your system has been trained and you change the tag/kill percentages. Have a serach through the forums (also the product documentation) and see what you can do with the anti-spam settings in the admin gui.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    last1ghost is offline Junior Member
    Join Date
    Jun 2006
    Posts
    8
    Rep Power
    9

    Default

    thanks for your fast replay, i check the all the forums and documentation but didn't find any thing related to my problem, i will tell you what i'm doing
    i send an email from hotmail
    sender: x@hotmail.com
    rcpt: y@myzimbra.com
    subject: test
    body: test

    i receive the email on zimbra web client and mark it as junk, then run
    > zmtrainsa <myzimbra.com> <y> <pass> spam junk

    Learned from 1 message(s) (1 message(s) examined).
    not flushed
    bayes: synced databases from journal in 0 seconds: 198 unique entries (198 total entries)
    Training DSPAM
    reading message y@myzimbra:1 of 1 (1806 header octets) . (2133 body octets) .. not flushed
    dspam_clean starting
    PROCESSING USER: y
    Processing sigs; age: 14
    Processing probabilities; age: 0
    Processing unused; any: 90 quota: 30 nospam: 15 onehit: 15


    then i send again from same account and it's still in inbox

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. understanding zmtrainsa
    By bowergo in forum Administrators
    Replies: 0
    Last Post: 06-18-2007, 11:25 AM
  2. spamassassin not learn, zmtrainsa ignores junked mail
    By lukefilewalker in forum Administrators
    Replies: 0
    Last Post: 11-20-2006, 09:36 AM
  3. Replies: 42
    Last Post: 08-11-2006, 09:50 AM
  4. HELP- Making Zimbra work. after installation
    By hifriend1 in forum Installation
    Replies: 7
    Last Post: 04-05-2006, 06:43 AM
  5. Rewrote zmtrainsa for DSPAM
    By unilogic in forum Developers
    Replies: 18
    Last Post: 01-12-2006, 06:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •