Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Tomcat is not running

  1. #1
    MarcTwain is offline Intermediate Member
    Join Date
    May 2006
    Posts
    16
    Rep Power
    8

    Default Solved: Tomcat is not running

    Since the last restart of our server tomcat doesn't start up again.

    All mail is inaccessible.

    zmcontrol status
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Stopped
    tomcat is not running
    mta Running
    snmp Running
    spell Running

    I have a Stacktrace attached.

    My setup is Binary Release for Debian:
    1149857250: INSTALL SESSION START
    1149857266: INSTALLED zimbra-core_3.1.2_GA_445.DEBIAN3.1_i386.deb
    1149857268: INSTALLED zimbra-ldap_3.1.2_GA_445.DEBIAN3.1_i386.deb
    1149857273: INSTALLED zimbra-logger_3.1.2_GA_445.DEBIAN3.1_i386.deb
    1149857278: INSTALLED zimbra-mta_3.1.2_GA_445.DEBIAN3.1_i386.deb
    1149857280: INSTALLED zimbra-snmp_3.1.2_GA_445.DEBIAN3.1_i386.deb
    1149857297: INSTALLED zimbra-store_3.1.2_GA_445.DEBIAN3.1_i386.deb
    1149857300: INSTALLED zimbra-apache_3.1.2_GA_445.DEBIAN3.1_i386.deb
    1149857302: INSTALLED zimbra-spell_3.1.2_GA_445.DEBIAN3.1_i386.deb
    1149857302: INSTALL SESSION COMPLETE
    Attached Files Attached Files
    Last edited by MarcTwain; 06-24-2006 at 07:38 AM. Reason: Solved

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Does rebooting your server still show Tomcat as stopped?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    MarcTwain is offline Intermediate Member
    Join Date
    May 2006
    Posts
    16
    Rep Power
    8

    Default

    I just rebooted:

    zmcontrol status
    Host vdr.conserte.intra
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Stopped
    tomcat is not running
    mta Running
    snmp Running
    spell Running

    Then I tried

    zmcontrol stop
    ...DONE
    zmcontrol start
    ..DONE
    zmcontrol status
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Stopped
    tomcat is not running
    mta Running
    snmp Running
    spell Running

    In my catalina.out I found:
    zmtomcatstart: info: stale pid 5426 in pid file: No such process
    Jun 24, 2006 4:05:37 PM org.apache.coyote.http11.Http11BaseProtocol init
    INFO: Initializing Coyote HTTP/1.1 on http-80
    Jun 24, 2006 4:05:38 PM org.apache.coyote.http11.Http11BaseProtocol init
    INFO: Initializing Coyote HTTP/1.1 on http-443
    Jun 24, 2006 4:05:38 PM org.apache.coyote.http11.Http11BaseProtocol init
    INFO: Initializing Coyote HTTP/1.1 on http-7071
    Jun 24, 2006 4:05:38 PM org.apache.catalina.startup.Catalina load
    INFO: Initialization processed in 2843 ms
    Jun 24, 2006 4:05:38 PM org.apache.catalina.core.StandardService start
    INFO: Starting service Catalina
    Jun 24, 2006 4:05:38 PM org.apache.catalina.core.StandardEngine start
    INFO: Starting Servlet Engine: Apache Tomcat/5.5.15
    Jun 24, 2006 4:05:38 PM org.apache.catalina.core.StandardHost start
    INFO: XML validation disabled
    Jun 24, 2006 4:05:40 PM org.apache.catalina.startup.HostConfig deployDescriptor
    WARNING: A docBase /opt/zimbra/apache-tomcat-5.5.15/webapps/zimbra inside the host appBase has been specified, and will be ignored
    log4j:WARN No appenders could be found for logger (org.apache.catalina.session.ManagerBase).
    log4j:WARN Please initialize the log4j system properly.
    Zimbra server reserving server socket port=110 bindaddr=null ssl=false
    Zimbra server reserving server socket port=995 bindaddr=null ssl=true
    Zimbra server reserving server socket port=143 bindaddr=null ssl=false
    Zimbra server reserving server socket port=993 bindaddr=null ssl=true
    Zimbra server process is running as root, changing to user=zimbra uid=1000 gid=105
    Zimbra server process, after change, is running with uid=1000 euid=1000 gid=105 egid=105

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Is that all that's in catalina.out? I assume you haven't tried to make any changes to Zimbra before it failed?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    MarcTwain is offline Intermediate Member
    Join Date
    May 2006
    Posts
    16
    Rep Power
    8

    Default

    I think I found the problem in zimbra.log:

    2006-06-24 16:30:34,946 INFO [IndexWritersSweeper] [] MailboxIndex - IndexWritersSweeper thread starting
    2006-06-24 16:30:34,992 INFO [main] [] RedoLogManager - Starting pre-startup crash recovery
    2006-06-24 16:30:34,994 FATAL [main] [] RedoLogManager - Exception during crash recovery
    2006-06-24 16:30:34,997 FATAL [main] [] system - Aborting process
    java.io.FileNotFoundException: /opt/zimbra/redolog/redo.log (Permission denied)
    at java.io.RandomAccessFile.open(Native Method)
    at java.io.RandomAccessFile.<init>(RandomAccessFile.j ava:212)
    at com.zimbra.cs.redolog.logger.FileLogWriter.open(Fi leLogWriter.java:188)
    at com.zimbra.cs.redolog.RedoLogManager.start(RedoLog Manager.java:223)
    at com.zimbra.cs.redolog.DefaultRedoLogProvider.start up(DefaultRedoLogProvider.java:51)
    at com.zimbra.cs.util.Zimbra.startup(Zimbra.java:101)
    at com.zimbra.soap.SoapServlet.init(SoapServlet.java: 118)
    at javax.servlet.GenericServlet.init(GenericServlet.j ava:211)
    at org.apache.catalina.core.StandardWrapper.loadServl et(StandardWrapper.java:1105)
    at org.apache.catalina.core.StandardWrapper.load(Stan dardWrapper.java:932)
    at org.apache.catalina.core.StandardContext.loadOnSta rtup(StandardContext.java:3915)
    at org.apache.catalina.core.StandardContext.start(Sta ndardContext.java:4176)
    at org.apache.catalina.core.ContainerBase.addChildInt ernal(ContainerBase.java:759)
    at org.apache.catalina.core.ContainerBase.addChild(Co ntainerBase.java:739)
    at org.apache.catalina.core.StandardHost.addChild(Sta ndardHost.java:524)
    at org.apache.catalina.startup.HostConfig.deployDirec tory(HostConfig.java:910)
    at org.apache.catalina.startup.HostConfig.deployDirec tories(HostConfig.java:873)
    at org.apache.catalina.startup.HostConfig.deployApps( HostConfig.java:474)
    at org.apache.catalina.startup.HostConfig.start(HostC onfig.java:1118)
    at org.apache.catalina.startup.HostConfig.lifecycleEv ent(HostConfig.java:310)
    at org.apache.catalina.util.LifecycleSupport.fireLife cycleEvent(LifecycleSupport.java:119)
    at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1020)
    at org.apache.catalina.core.StandardHost.start(Standa rdHost.java:718)
    at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1012)
    at org.apache.catalina.core.StandardEngine.start(Stan dardEngine.java:442)
    at org.apache.catalina.core.StandardService.start(Sta ndardService.java:450)
    at org.apache.catalina.core.StandardServer.start(Stan dardServer.java:700)
    at org.apache.catalina.startup.Catalina.start(Catalin a.java:551)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.apache.catalina.startup.Bootstrap.start(Bootst rap.java:275)
    at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:413)

    How can I fix this?

  6. #6
    MarcTwain is offline Intermediate Member
    Join Date
    May 2006
    Posts
    16
    Rep Power
    8

    Default

    Huch, the redo.log file was owned by root:root


    chown zimbra:zimbra /opt/zimbra/redolog/redo.log

    Fixed it....

  7. #7
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Yes, that's the fix. Don't happen to have a 2.6.5 kernel installed do you? There seems to be a problem with it, have a look at this in bugzilla.
    Last edited by phoenix; 06-24-2006 at 08:15 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    bryanr is offline Trained Alumni
    Join Date
    May 2007
    Posts
    23
    Rep Power
    7

    Default

    I have the same problem, but the ownership is correct. I am not sure what files must have zimbra as the owner. What else might cause this problem?

  9. #9
    bryanr is offline Trained Alumni
    Join Date
    May 2007
    Posts
    23
    Rep Power
    7

    Default

    this is from the zimbra.log:

    Jun 14 11:36:13 danger zmtomcatmgr[11967]: status requested
    Jun 14 11:36:13 danger zmtomcatmgr[11967]: stale pid 4533 found in /opt/zimbra/log/zmtomcatmgr.pid: No such process
    Jun 14 11:36:13 danger zmtomcatmgr[11967]: assuming no other instance is running
    Jun 14 11:36:13 danger zmtomcatmgr[11967]: no manager process is running


    not sure if that helps.

  10. #10
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Run zmfixperms located in the /opt/zimbra/libexec dir
    Also, remove that stale pid.

    Try again, and let us know

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tomcat, Java VM Problems - RAM related? Help
    By Mo_Hong in forum Administrators
    Replies: 3
    Last Post: 03-28-2007, 02:00 PM
  2. tomcat not running / postfix/postqueue errors
    By seravitae in forum Installation
    Replies: 7
    Last Post: 03-10-2007, 08:18 PM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  4. Why is Tomcat shuting down ever nights?
    By trapanator in forum Administrators
    Replies: 2
    Last Post: 11-30-2006, 11:57 PM
  5. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •