Results 1 to 6 of 6

Thread: Zimbra Losing Mail

  1. #1
    mutuku is offline Active Member
    Join Date
    Jun 2009
    Posts
    49
    Rep Power
    6

    Default Zimbra Losing Mail

    Hellos,

    I am having a issue where users are complaining they are losing mail from the web interface.

    I have set the email rentention policy to 30 days. This is happening before 30 days

    James

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,484
    Rep Power
    56

    Default

    Quote Originally Posted by mutuku View Post
    I am having a issue where users are complaining they are losing mail from the web interface.
    Zimbra doesn't lose mail, it's most likely the users have filters that are deleting the email or they are deleting them themselves.
    Quote Originally Posted by mutuku View Post
    I have set the email rentention policy to 30 days. This is happening before 30 days
    Why have you set a retention policy for email? The point of a mail server is that the mail remains there for the users to access.

    Do you have any backup of your server that you could restore the mail from? You post is lacking a lot of detail on what version of Zimbra you're using, mail is missing, when it goes missing etc.

    Please update your forum profile with the output of the following (do not post it in this thread):

    Code:
    zmcontrol -v
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    mutuku is offline Active Member
    Join Date
    Jun 2009
    Posts
    49
    Rep Power
    6

    Default

    I have checked some of the accounts and there are no filters set. It would be hard for users to delete emails ad then complain.

    This might have happened when all users received an email from a user "robot@<mydomain.com>". This user is not in the zimbra accounts list. The mail had an attachment prompting users to click on it.

    I don't have a backup. Users says mail is missing in a random order. I have updated my profile with the zimbra version

  4. #4
    Dirk's Avatar
    Dirk is offline Moderator
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    Looking for the cause of a missing mail is always difficult because you are looking for something that isnt there! It's hard to point at it and say, look that one is missing.

    It sounds like you are saying that a number of users clicked an email that may have been a virus?

    It's also quite normal for someone to delete an email, then empty it from the trash and then complain that the message has been lost. I have personally seen this before.

    Are messages still being lost, do you use the same system, are you losing mail too?

  5. #5
    mutuku is offline Active Member
    Join Date
    Jun 2009
    Posts
    49
    Rep Power
    6

    Default

    I was not using the mail server, but I did set a account a few days ago and so far I have not lost mail

    Just out if curiosity...I was going through zimbra.log ad the lines below drew my attention

    Nov 19 09:24:30 mail zimbramon[19160]: 19160:info: zmmtaconfig: Couldn't remove /opt/zimbra/conf/salocal.cf: Permission denied
    Nov 19 09:24:30 mail zimbramon[19160]: 19160:info: zmmtaconfig: Couldn't remove /opt/zimbra/conf/clamd.conf: Permission denied
    Nov 19 09:24:30 mail zimbramon[19160]: 19160:info: zmmtaconfig: Couldn't remove /opt/zimbra/conf/postfix_header_checks: Permission denied
    Nov 19 09:24:30 mail zimbramon[19160]: 19160:info: zmmtaconfig: Couldn't remove /opt/zimbra/conf/amavisd.conf: Permission denied
    Nov 19 09:24:30 mail zimbramon[19160]: 19160:info: zmmtaconfig: Couldn't remove /opt/zimbra/conf/freshclam.conf: Permission denied

    Is this normal?

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,484
    Rep Power
    56

    Default

    Quote Originally Posted by mutuku View Post
    I have checked some of the accounts and there are no filters set. It would be hard for users to delete emails ad then complain.
    As Dirk has already mentioned, it's impossible to prove that an email has 'disappeared' and who removed it. I can say that I've never seen and incident of 'missing' mail that hasn't been caused by a user either with a filter or deleting it themselves.

    The uid & gid on the files you mention above should be zimbra:zimbra, I'd suggest you shutdown zimbra the run the following as root:

    Code:
    /opt/zimbra/libexec/zmfixperms -extended
    Restart Zimbra and check the logs for any error messages.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 15
    Last Post: 11-19-2009, 12:16 AM
  2. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 04:42 PM
  3. Replies: 22
    Last Post: 12-02-2007, 05:05 PM
  4. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM
  5. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 01:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •