Results 1 to 8 of 8

Thread: send *all* email through relay mta ?

  1. #1
    keithop is offline Senior Member
    Join Date
    Feb 2006
    Posts
    61
    Rep Power
    9

    Default send *all* email through relay mta ?

    Hi,

    Is there anyway to tell zimbra to send all outgoing email through the relay mta without first trying to deliver to "local domains" ?

    I have the situation where someone@domain.com is on one box and someoneelse@domain.com is on zimbra.

    Emails come in to a central MTA which knows where to send each email which works very well for incoming external email but because zimbra knows that it has "domain.com" on itself, it (logically and quite understandably) doesn't send email to that domain from local users out to the relay.

    any way to make it?

    Thanks all!
    Keith

  2. #2
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Did you try to set a relay MTA in the Admin UI and disable DNS lookups?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    keithop is offline Senior Member
    Join Date
    Feb 2006
    Posts
    61
    Rep Power
    9

    Default

    Quote Originally Posted by KevinH
    Did you try to set a relay MTA in the Admin UI and disable DNS lookups?
    hi Kevin,

    I did set a relay MTA but I still have DNS lookups on.

    If I turn that off, would that force zimbra to send everything out ? even though it has domain.com in its list of domains?

  4. #4
    keithop is offline Senior Member
    Join Date
    Feb 2006
    Posts
    61
    Rep Power
    9

    Default

    Just tried turning dns lookups off as well ... but still the same problem, I guess zimbra sees that it has "domain.com" locally and then can't find someone@domain.com locally so won't let me send.

  5. #5
    skwdenyer is offline Junior Member
    Join Date
    Jan 2006
    Posts
    8
    Rep Power
    9

    Default

    Quote Originally Posted by keithop
    Just tried turning dns lookups off as well ... but still the same problem, I guess zimbra sees that it has "domain.com" locally and then can't find someone@domain.com locally so won't let me send.
    What about if you set up the Zimbra box as a "caching+" DNS with the only MX record as being the "other" MTA and force the Zimbra box (through resolv.conf) to use localhost for DNS? If Zimbra is making the determination based upon DNS records then that might work?

    The alternative way to do it might be to make your Zimbra box's FQDN something like server.zimbra.domain.com and the user's address user@zimbra.domain.com. Then set up the outgoing address for the user to in fact be user1@domain.com. Make sure that server.zimbra.domain.com is the MX record for the subdomain zimbra.domain.com but NOT for domain.com and set up the relay MTA. Now (and I haven't tried this yet) email sent for user2@domain.com from user1@zimbra.domain.com will be sent with a From header of user1@domain.com but correctly delivered to the remote MTA.

    Anyone come up with something more elegant?

    Thanks! Silas

  6. #6
    keithop is offline Senior Member
    Join Date
    Feb 2006
    Posts
    61
    Rep Power
    9

    Default

    Hi Silas!

    Thanks for the suggestions, much appreciated..

    Actually option2 is pretty much exactly how I do it with our exchange boxes... relay mta sends to userID@internaldomain.com but the account is setup to send AS userID@properdomain.com

    Works a treat but I couldn't immediately find where on zimbra to set a proper from address in that way :/

    It sounds workable though if I can discover where the setting is ;-)

    Thanks again for taking the time to think about it!
    all the best,
    Keith

  7. #7
    bobby is offline Zimbra Employee
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    10

    Default

    it sounds kinda like you're running a split domain. take a look at the split domain wiki and see if that lines up with what you've got

  8. #8
    keithop is offline Senior Member
    Join Date
    Feb 2006
    Posts
    61
    Rep Power
    9

    Default

    Hi Bobby,

    Yep that's exactly the situation! Thanks for that,

    Cheers,
    Keith

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Daily mail report always reports "No messages found"
    By McPringle in forum Installation
    Replies: 42
    Last Post: 06-13-2011, 08:57 AM
  2. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  3. upgrade to 4.0.3 antispam does'nt work
    By lucanannipieri in forum Administrators
    Replies: 14
    Last Post: 11-07-2006, 03:56 AM
  4. cannot send email to sina/yahoo
    By koolokamba in forum Administrators
    Replies: 2
    Last Post: 06-20-2006, 08:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •