Results 1 to 4 of 4

Thread: [SOLVED] Single Slow Mailbox

  1. #1
    lcxe is offline Active Member
    Join Date
    May 2008
    Posts
    34
    Rep Power
    7

    Default [SOLVED] Single Slow Mailbox

    We're currently having a large problem with one of our mailboxes that is accessed by multiple users through the web interface. The reported behavior is as follows:
    • All users are experiencing a varying degree of difficulty, and it is normal for logging in to take 15-30 minutes
    • Some users need to log in and out several times a day
    • The SFTs are slower in general, and each time the inbox is refreshed there is an additional delay
    • Some folders can be accessed only after a long wait and occasionally will completely freeze user’s inbox (need to log in again)
    • Throughout the day, messages will pop up asking user ‘Would you like to continue running this script?”

      o If user selects ‘yes’, Zimbra will continue running at a slow pace

      o If user selects ‘no’, Zimbra will run somewhat faster but for some users, filing folders will disappear (they are flagging the items and having other reps file them)


    The users accessing the mailbox are using IE, though I've tried the newest versions of the big browsers (FF, IE, Chrome), and all exhibit the same sort of behavior. My load times for the mailbox aren't nearly as bad as the described 15-30 minutes, but it's definitely taking a lot longer than it has in the past and compared to other mailboxes.

    Accessing the mailbox through IMAP yields a normal experience, so it seems to be tied specifically to the web interface. I've used both the html and ajax interfaces, and both have the same problems. The mailbox is about 40GB in size, though again in comparison we have larger mailboxes around 50GB that are behaving normally.

    I'm failing to come up with even simple ideas of what the problem could be. I've considered reindexing the mailbox, though I don't know if that will really affect anything and that I'm just grasping as straws.

    If anyone as any experience or insight into this problem it would be greatly appreciated.

  2. #2
    ArcaneMagus's Avatar
    ArcaneMagus is offline Moderator
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    What does the disk access on the server look like when the users log into the mailbox? Memory usage?

    The only thing I can really think of here is it is getting hung up on slow disk access, not sure if reindexing will help or not but it's the only thing I can really think of as well...

  3. #3
    veronica is offline Outstanding Member
    Join Date
    Jun 2008
    Posts
    594
    Rep Power
    8

    Default

    Try accessing using IP address and tell what you see

  4. #4
    lcxe is offline Active Member
    Join Date
    May 2008
    Posts
    34
    Rep Power
    7

    Default

    I've found the problem. Thanks for the replies.

    It appears to be a freak problem with our automated imapsync backup script. The script had been running fine for over a year, but I believe a user created an extra folder that matched the script's regex, and for the last couple of months it's been recursively backing up into more and more folders. They're all empty, but as we all know that the number of folders will affect the loading time of the browser.

    If anyone is really interested it was backing up in this manner:

    week 1

    week 2 > week 1

    week 3 > week 1
    > week 2 > week 1

    week 4 > week 1
    > week 2 > week 1
    > week 3 > week 1
    > week 3 > week 2 > week 1

    As you can imagine, it's been running long enough to have created a fair number of folders to get this out of hand.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 05-06-2009, 01:49 AM
  2. Single Mailbox To Multi Mailbox Migration
    By dosmage in forum Installation
    Replies: 8
    Last Post: 03-25-2009, 06:13 PM
  3. [SOLVED] Restoring a single mailbox
    By Jbrabander in forum Administrators
    Replies: 13
    Last Post: 06-19-2008, 09:07 AM
  4. [SOLVED] Recovering Single Users Mailbox
    By krolen in forum Administrators
    Replies: 3
    Last Post: 05-07-2008, 04:55 AM
  5. can't you help me
    By iwan siahaan in forum Administrators
    Replies: 6
    Last Post: 12-17-2007, 06:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •