Results 1 to 8 of 8

Thread: how to enable the mailbox service

  1. #1
    hoangnam8484 Guest

    Default how to enable the mailbox service

    you help with!!!!!

    Code:
    zimbra@server1:~$ zmcontrol -v
    
    
    Release 6.0.0_GA_1805.UBUNTU9 UBUNTU9 FOSS edition.
    
    zimbra@server1:~$ zmcontrol status
    Host domain.com.vn
            antispam                Running
            antivirus               Stopped
                    zmclamdctl is not running
            ldap                    Running
            logger                  Running
            mta                     Running
            snmp                    Running
            stats                   Stopped
    zimbra@server1:~$ zmstatctl restart
    Usage: zmstatctl start|stop|status|rotate
    Starts/stops monitoring processes, checks status, or rotates logs.
    zimbra@server1:~$ zmstatctl start
    Invoking: /opt/zimbra/libexec/zmstat-proc
    Invoking: /opt/zimbra/libexec/zmstat-cpu
    Invoking: /opt/zimbra/libexec/zmstat-vm
    Invoking: /opt/zimbra/libexec/zmstat-io -x
    Invoking: /opt/zimbra/libexec/zmstat-df
    Invoking: /opt/zimbra/libexec/zmstat-io
    Invoking: /opt/zimbra/libexec/zmstat-fd
    Invoking: /opt/zimbra/libexec/zmstat-allprocs
    Invoking: /opt/zimbra/libexec/zmstat-mysql
    Invoking: /opt/zimbra/libexec/zmstat-convertd
    Invoking: /opt/zimbra/libexec/zmstat-mtaqueue
    zimbra@server1:~$ zmstatctl status
    Running: zmstat-vm
    Running: zmstat-fd
    process 29013 in /opt/zimbra/zmstat/pid/zmstat-mysql.pid not running
    Running: zmstat-df
    Running: zmstat-io-x
    Running: zmstat-mtaqueue
    Running: zmstat-proc
    Running: zmstat-allprocs
    Running: zmstat-cpu
    Running: zmstat-io
    zimbra@server1:~$ zmstatctl stop
    Terminating process 7495
    Terminating process 7506
    Terminating process 29013
    Terminating process 7502
    Terminating process 7498
    Terminating process 7514
    Terminating process 7487
    Terminating process 7508
    Terminating process 7491
    Terminating process 7504
    zimbra@server1:~$ zmstatctl start
    Invoking: /opt/zimbra/libexec/zmstat-proc
    Invoking: /opt/zimbra/libexec/zmstat-cpu
    Invoking: /opt/zimbra/libexec/zmstat-vm
    Invoking: /opt/zimbra/libexec/zmstat-io -x
    Invoking: /opt/zimbra/libexec/zmstat-df
    Invoking: /opt/zimbra/libexec/zmstat-io
    Invoking: /opt/zimbra/libexec/zmstat-fd
    Invoking: /opt/zimbra/libexec/zmstat-allprocs
    Invoking: /opt/zimbra/libexec/zmstat-mysql
    Invoking: /opt/zimbra/libexec/zmstat-convertd
    Invoking: /opt/zimbra/libexec/zmstat-mtaqueue
    zimbra@server1:~$ zmstatctl status
    Running: zmstat-vm
    Running: zmstat-fd
    Running: zmstat-mysql
    Running: zmstat-df
    Running: zmstat-io-x
    Running: zmstat-mtaqueue
    Running: zmstat-proc
    Running: zmstat-allprocs
    Running: zmstat-cpu
    Running: zmstat-io
    zimbra@server1:~$
    Host domain.com.vn
            antispam                Running
            antivirus               Stopped
                    zmclamdctl is not running
            ldap                    Running
            logger                  Running
            mta                     Running
            snmp                    Running
            stats                   Stopped
    zimbra@server1:~$
    Last edited by hoangnam8484; 11-05-2009 at 01:33 AM.

  2. #2
    hoangnam8484 Guest

    Default

    i cant start sevice stats, everyone help me please!!

  3. #3
    hoangnam8484 Guest

    Default

    Code:
    Starting freshclam...done.
    Starting clamd...failed.
    
    
            Starting snmp...Done.
            Starting mta...Done.
            Starting stats...Done.
    zimbra@server1:~$ zmcontrol status
    Host host.com.vn
            antispam                Running
            antivirus               Stopped
                    zmclamdctl is not running
            ldap                    Running
            logger                  Running
            mailboxd                Stopped
            mta                     Running
            snmp                    Running
            stats                   Stopped
    zimbra@server1:~$ zmprov -l modifyServer host.com.vn -zimbraServiceEnabled mailboxd 
    zimbra@server1:~$ zmcontrol start
    Host host.com.vn
            Starting logger...Done.
            Starting antispam...Done.
            Starting antivirus...Failed.
    Starting zmmtaconfig...zmmtaconfig is already running.
    Starting amavisd...amavisd is already running.
    Starting freshclam...done.
    Starting clamd...failed.
    
    
            Starting snmp...Done.
            Starting mta...Done.
            Starting stats...Done.
    zimbra@server1:~$ zmprov -l modifyS
    zimbra@server1:~$ zmprov -l modifyServer host.com.vn +zimbraServiceEnabled mailboxd 
    zimbra@server1:~$ zmcontrol start
    Host host.com.vn
            Starting mailboxd...skipped.
                     missing or not executable.
            Starting logger...Done.
            Starting antispam...Done.
            Starting antivirus...Failed.
    Starting zmmtaconfig...zmmtaconfig is already running.
    Starting amavisd...amavisd is already running.
    Starting freshclam...done.
    Starting clamd...failed.
    
    
            Starting snmp...Done.
            Starting mta...Done.
            Starting stats...Done.
    zimbra@server1:~$
    Last edited by hoangnam8484; 11-05-2009 at 07:36 AM.

  4. #4
    ArcaneMagus's Avatar
    ArcaneMagus is offline Moderator
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Why in the world did you remove your mailboxd service?!?

    Anyway try stopping the server (zmcontrol stop) and then killing all processes still running under the zimbra user, then starting Zimbra back up again.

  5. #5
    hoangnam8484 Guest

    Default how to enable the mailbox service

    I need to get the user data, you can own a solution?
    Currently I can not launch the service mailbox, should not be able to get data
    is how can get the data without the user?
    Thanks you verymuch!!!


    Code:
    Nov  6 09:58:09 server1 zmmailboxdmgr[2098]: status requested
    Nov  6 09:58:09 server1 zmmailboxdmgr[2098]: stale pid 1724 found in /opt/zimbra/log/zmmailboxd_manager.pid: No such process
    Nov  6 09:58:09 server1 zmmailboxdmgr[2098]: assuming no other instance is running
    Nov  6 09:58:09 server1 zmmailboxdmgr[2098]: file /opt/zimbra/log/zmmailboxd.pid does not exist
    Nov  6 09:58:09 server1 zmmailboxdmgr[2098]: assuming no other instance is running
    Nov  6 09:58:09 server1 zmmailboxdmgr[2098]: no manager process is running
    Nov  6 09:58:12 server1 zmmailboxdmgr[2451]: status requested
    Nov  6 09:58:12 server1 zmmailboxdmgr[2451]: stale pid 1724 found in /opt/zimbra/log/zmmailboxd_manager.pid: No such process
    Nov  6 09:58:12 server1 zmmailboxdmgr[2451]: assuming no other instance is running
    Nov  6 09:58:12 server1 zmmailboxdmgr[2451]: file /opt/zimbra/log/zmmailboxd.pid does not exist
    Nov  6 09:58:12 server1 zmmailboxdmgr[2451]: assuming no other instance is running
    Nov  6 09:58:12 server1 zmmailboxdmgr[2451]: no manager process is running
    Nov  6 09:58:13 server1 amavis[22318]: (22318-17) (!)ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to 127.0.0.1:3310 (Can't connect to INET6 socket 127.0.0.1:3310: Connection refused) at (eval 96) line 373.\n
    Nov  6 09:58:13 server1 amavis[22318]: (22318-17) (!!)WARN: all primary virus scanners failed, considering backups
    Nov  6 09:58:13 server1 amavis[22318]: (22318-17) (!!)TROUBLE in check_mail: virus_scan FAILED: AV: ALL VIRUS SCANNERS FAILED
    Nov  6 09:58:13 server1 amavis[22318]: (22318-17) (!)PRESERVING EVIDENCE in /opt/zimbra/data/amavisd/tmp/amavis-20091106T095806-22318
    Code:
    zimbra@server1:~$ zmcontrol status
    Host domain.com.vn
            antispam                Running
            antivirus               Stopped
                    zmclamdctl is not running
            ldap                    Running
            logger                  Running
            mailbox                 Stopped
                    mysql.server is not running.
            mta                     Running
            snmp                    Running
            stats                   Stopped
    zimbra@server1:~$ mysql.server restart
    mysqld not running: no pid in '/opt/zimbra/db/mysql.pid'
    Starting mysqld...done.
    zimbra@server1:~$ mysql.server start
    Starting mysqld...done.
    zimbra@server1:~$ mysql.server restart
    mysqld not running: no pid in '/opt/zimbra/db/mysql.pid'
    Starting mysqld...done.
    zimbra@server1:~$ zmmysqlstatus restart
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    Error while running 'mysql --user=zimbra --password=SbVhrQLkd0x_cWWUttoe80oLhk --database=zimbra --batch --skip-column-names'. at /opt/zimbra/bin/zmmysqlstatus line 248.
    Last edited by hoangnam8484; 11-05-2009 at 08:46 PM.

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,582
    Rep Power
    57

    Default

    Quote Originally Posted by hoangnam8484 View Post
    I need to get the user data, you can own a solution?
    Currently I can not launch the service mailbox, should not be able to get data
    is how can get the data without the user?
    What, exactly, have you done to get into this situation? Is this a new server, a migration, an upgrade, move to a new server or what? Please give the exact steps you've done to this server prior to it not working. You should also look in the log files for any error messages and post some details, you should also search the forums and see what you can find about this type of problem and it's solutions.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    hoangnam8484 Guest

    Default

    1. my server is spam from the inside, there are an email sent to yahoo.com.uk
    2. I block it by uncheck the admin mailbox service Consol.
    3. then I can not start the service mailbox, nor to the web mail.
    4. I have rebuilt a new server and new server is running.
    5. and I have copied the entire source code of Zimbra old, now I need to run power to recover the old user data.

    I need a solution to recover data to the user, not necessarily to rebuild this server.

  8. #8
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,582
    Rep Power
    57

    Default

    You should have resolved the problem with your old server, that would have been easier than what you've done. I also asked you for the errors from the log files - what do you see in there? Have you also checked other threads in the forums on resolutions to this problem , have you tried any of the solutions?

    If the new server is running which server are you trying to start and why?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Free/Busy queries kill the mailbox service
    By SuperBeaker in forum Administrators
    Replies: 1
    Last Post: 09-21-2009, 01:05 PM
  2. Replies: 5
    Last Post: 05-28-2009, 12:53 AM
  3. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  4. can't you help me
    By iwan siahaan in forum Administrators
    Replies: 6
    Last Post: 12-17-2007, 06:53 PM
  5. What does the mailbox service do?
    By iain in forum Administrators
    Replies: 1
    Last Post: 06-17-2007, 04:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •