Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: force smtp auth zimbra

  1. #1
    sandeepdas is offline Junior Member
    Join Date
    Oct 2009
    Posts
    6
    Rep Power
    5

    Default force smtp auth zimbra

    Hi All,

    Please let me know how to force smtp auth in zimbra so that unauthenticated clients can not use my server for sending mails.

    Regards,
    Sandeep

  2. #2
    raj's Avatar
    raj
    raj is offline Moderator
    Join Date
    Oct 2005
    Location
    USA, Canada and India
    Posts
    777
    Rep Power
    10

    Default

    this is a Default behaviour. no user (outside your local network or whats allowed in ZimbraMtaMyNetworks ) should be able to send email without SMTP AUTH.
    if you seeing your users/email clients send email out "without" SMTP AUTH then you need to check your "ZimbraMtaMyNetworks" settings and you may edit it to restrict even the local network (make sure to allow 127.0.0.1 and Zimbra's own local ip)

    there is more info here:
    ZimbraMtaMyNetworks - Zimbra :: Wiki

    Raj
    i2k2 Networks
    Dedicated & Shared Zimbra Hosting Provider

  3. #3
    sandeepdas is offline Junior Member
    Join Date
    Oct 2009
    Posts
    6
    Rep Power
    5

    Default

    Quote Originally Posted by raj View Post
    this is a Default behaviour. no user (outside your local network or whats allowed in ZimbraMtaMyNetworks ) should be able to send email without SMTP AUTH.
    if you seeing your users/email clients send email out "without" SMTP AUTH then you need to check your "ZimbraMtaMyNetworks" settings and you may edit it to restrict even the local network (make sure to allow 127.0.0.1 and Zimbra's own local ip)

    there is more info here:
    ZimbraMtaMyNetworks - Zimbra :: Wiki

    Raj
    Hi Raj,

    Thanks for the reply. I did the same in my server but still am able to send mails without authentication

    Here are some of the outputs of my server.
    -----------------------------------------------------------------------------------------------------------------------------------
    zmprov modifyServer testmail.impxxxx.co.in zimbraMtaMyNetworks '127.0.0.0/8 192.168.103.50/32'

    [zimbra@testmail ~]$ postconf mynetworks
    mynetworks = 127.0.0.0/8 192.168.103.50/32
    [zimbra@testmail ~]$

    Here 192.168.103.50 is my zimbra serverís ip
    ------------------------------------------------------------------------------------------------------------------------------------
    [zimbra@testmail ~]$ zmprov getServer testmail. impxxxx.co.in | grep Auth
    zimbraMtaAuthEnabled: TRUE
    zimbraMtaAuthHost: testmail. impxxxx.co.in
    zimbraMtaAuthTarget: TRUE
    zimbraMtaAuthURL: http://testmail. impxxxx.co.in:80/service/soap/
    zimbraMtaSaslAuthEnable: TRUE
    zimbraMtaTlsAuthOnly: TRUE
    -------------------------------------------------------------------------------------------------------------------------------------

    [zimbra@testmail ~]$ zmprov getServer testmail.impxxxx.co.in | grep Mode
    zimbraBackupMode: Standard
    zimbraMailMode: mixed
    zimbraMailReferMode: wronghost
    zimbraReverseProxyImapStartTlsMode: only
    zimbraReverseProxyMailMode: http
    zimbraReverseProxyPop3StartTlsMode: only

    Please let me know if you need more info from my side.

  4. #4
    dalmate is offline Elite Member
    Join Date
    Jan 2009
    Posts
    359
    Rep Power
    6

    Default

    IN admin console, you must uncheck "enable TLS authenticate only" option.
    or zimbraMtaTlsAuthOnly = FALSE

  5. #5
    sandeepdas is offline Junior Member
    Join Date
    Oct 2009
    Posts
    6
    Rep Power
    5

    Default force smtp auth zimbra

    Quote Originally Posted by dalmate View Post
    IN admin console, you must uncheck "enable TLS authenticate only" option.
    or zimbraMtaTlsAuthOnly = FALSE
    Still no luck..

  6. #6
    dalmate is offline Elite Member
    Join Date
    Jan 2009
    Posts
    359
    Rep Power
    6

    Default

    after change, did you restart postfix?
    you must restart it by this command:
    su zimbra
    and
    postfix restart

  7. #7
    sandeepdas is offline Junior Member
    Join Date
    Oct 2009
    Posts
    6
    Rep Power
    5

    Default

    Quote Originally Posted by dalmate View Post
    after change, did you restart postfix?
    you must restart it by this command:
    su zimbra
    and
    postfix restart
    Yes i did that but still am able to send mails using this server without authentication.

  8. #8
    dalmate is offline Elite Member
    Join Date
    Jan 2009
    Posts
    359
    Rep Power
    6

    Default

    In global settings: you check:
    Client's IP address (reject_unknown_client)
    Hostname in greeting (reject_unknown_hostname)
    Sender's domain (reject_unknown_sender_domain)
    Hostname in greeting violates RFC (reject_invalid_hostname)
    Client must greet with a fully qualified hostname (reject_non_fqdn_hostname)
    Sender address must be fully qualified (reject_non_fqdn_sender)
    hope this help

  9. #9
    rgiapratama is offline New Member
    Join Date
    Oct 2009
    Location
    BDG, ID
    Posts
    3
    Rep Power
    5

    Default

    Hi dalmate

    I'm get same problem like sandeepdas i want my user authenticate before sent email. I follow all your instruction but user still can send email without authentication.

    Thx.

  10. #10
    dalmate is offline Elite Member
    Join Date
    Jan 2009
    Posts
    359
    Rep Power
    6

    Default

    please restart postfix after you made any changes
    In my system, I've done by doing these thing

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. postfix relay=none status=bounced for local mails
    By vdd in forum Administrators
    Replies: 1
    Last Post: 08-06-2009, 08:05 AM
  2. slapd message error
    By smoke in forum Administrators
    Replies: 7
    Last Post: 04-27-2008, 03:23 PM
  3. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  4. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 03:30 PM
  5. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 12:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •