Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Migrating ldap data...slapadd import failed.

  1. #1
    NoDoze is offline Elite Member
    Join Date
    Feb 2008
    Location
    San Francisco
    Posts
    360
    Rep Power
    7

    Default Migrating ldap data...slapadd import failed.

    Migrating ldap data...slapadd import failed.
    UPGRADE FAILED - exiting.
    When running the 6.0.1 update from 5.0.16 I'm getting this error...

    I've gone through this:
    Optimizing 50 to 60 LDAP upgrade - Zimbra :: Wiki
    ...like 6 times and STILL can't figure out what I'm doing wrong? What I'm missing? Or what the hangup is...?

    ..and yes I've also done: Installing custom ldap schema 6.0 - Zimbra :: Wiki

    ...and have read through this: Problem upgrading to 6; slapadd import failed

    I understand it's a schema thing, but it doesn't seam like the suggestions I found are making any difference...

    My 5.0.16 is running samba 3.4/posix/ldap/zimbra 5.0.16

    Can someone spell it out for me...?

    ANY help is appreciated.

    Thanks!

  2. #2
    NoDoze is offline Elite Member
    Join Date
    Feb 2008
    Location
    San Francisco
    Posts
    360
    Rep Power
    7

    Default

    btw...when I also get this:

    [zimbra@mail cn=schema]$ ldap start
    /opt/zimbra/data/ldap/config: line 1: index attribute "sambaSID" undefined
    /opt/zimbra/data/ldap/config: line 1: index attribute "sambaSID" undefined
    /opt/zimbra/data/ldap/config: line 1: index attribute "sambaSID" undefined
    /opt/zimbra/data/ldap/config: line 1: index attribute "sambaSID" undefined
    /opt/zimbra/data/ldap/config: line 1: index attribute "sambaSID" undefined
    /opt/zimbra/data/ldap/config: line 1: index attribute "sambaSID" undefined
    /opt/zimbra/data/ldap/config: line 1: index attribute "sambaSID" undefined
    Failed to start slapd. Attempting debug start to determine error.
    config error processing olcDatabase={2}hdb,cn=config: index attribute "sambaSID" undefined
    ???

  3. #3
    NoDoze is offline Elite Member
    Join Date
    Feb 2008
    Location
    San Francisco
    Posts
    360
    Rep Power
    7

    Default

    ok...I fixed the ldap failed start... by starting from scratch again with this: Converting and installing schema with the new LDIF format

    Starting the update again...

  4. #4
    NoDoze is offline Elite Member
    Join Date
    Feb 2008
    Location
    San Francisco
    Posts
    360
    Rep Power
    7

    Default

    IT WORKED!!!!

    ..too bad it was just the test zimbra server...LOL

    ...hope it goes well with the production server...yikes...

  5. #5
    johjoh2k is offline Intermediate Member
    Join Date
    Jul 2008
    Location
    Italy
    Posts
    17
    Rep Power
    7

    Default

    If I don't use Samba integration, I have followed all wiki, what I'm missing for receiving:

    Migrating ldap data...slapadd import failed.
    UPGRADE FAILED - exiting.

    Any help appreciated, this problem are make me crazy!
    CentOS 5.4 32 bit
    Zimbra 6.0.4_GA_2038.RHEL5

  6. #6
    dalmate is offline Elite Member
    Join Date
    Jan 2009
    Posts
    368
    Rep Power
    6

    Default

    I can export and import again ldap data backup but I have a problem:
    I have 2 server- one online and the other offline
    they have same domain name: such as mail.example.com
    their IPs are different
    When I export ldap data from online server to a diff file and import to offline server (backup server)-notice: I follow every step wrote on wiki- and I start backup server, its ldap server is always fail ( error message: unable to dertimate....)
    I don't know why?

  7. #7
    ArcaneMagus's Avatar
    ArcaneMagus is offline Moderator
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    johjoh2k: Is there any further information in the setup log?

    dalmate: Does the backup "offline" server have a splitdns setup so it doesn't try to conflict with the live server?

  8. #8
    dalmate is offline Elite Member
    Join Date
    Jan 2009
    Posts
    368
    Rep Power
    6

    Default

    @ArcanMagus: My offline server didn't connect to network so I can get it the same IP and domain name with online server

  9. #9
    dalmate is offline Elite Member
    Join Date
    Jan 2009
    Posts
    368
    Rep Power
    6

    Default

    when I type:
    zmcontrol start
    after ldap start, I have a report:
    Unable to determine enabled services from ldap.
    Enabled services read from cache. Service list may be inaccurate

  10. #10
    johjoh2k is offline Intermediate Member
    Join Date
    Jul 2008
    Location
    Italy
    Posts
    17
    Rep Power
    7

    Default

    No, any furter information.
    It convert MySQL schema to 63 without problem, and after when it start to migrate LDAP crash with the error:
    "Migrating ldap data...slapadd import failed.
    UPGRADE FAILED - exiting"
    I have read and re-read the 2 wiki, I don't have Samba, I don't understand what I'm missing...

    Thank you for help
    CentOS 5.4 32 bit
    Zimbra 6.0.4_GA_2038.RHEL5

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem upgrading to 6; slapadd import failed
    By gtr33m in forum Installation
    Replies: 9
    Last Post: 02-19-2010, 05:49 AM
  2. Help!!! Moving ZCS does not work!
    By ASebestian in forum Migration
    Replies: 7
    Last Post: 02-12-2009, 06:06 PM
  3. upgrading from 5.0.4 to 5.0.5 opensource
    By smoke in forum Installation
    Replies: 4
    Last Post: 10-19-2008, 10:38 AM
  4. Replies: 2
    Last Post: 02-12-2008, 11:55 AM
  5. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •