Results 1 to 10 of 10

Thread: [SOLVED] Problem displaying word document attachment

  1. #1
    gallimore is offline Active Member
    Join Date
    Jan 2009
    Posts
    47
    Rep Power
    6

    Default [SOLVED] Problem displaying word document attachment

    Zimbra 5.0.16 FOSS
    Microsoft Word 2003
    Internet Explorer

    When using the advanced web client, we have a problem when opening an attached word document. The email has the usual links for an attachment (the name of the document and the option to download).

    When the name of the document is clicked, the content is displayed in an internet explorer window (and obviously not formatted correctly).

    When the "download" option is clicked, the "Do you want to open or download this file" dialog is displayed and using "Open" correctly starts word.

    Is this a bug in Zimbra or a problem with Internet Explorer?
    Paul Gallimore

  2. #2
    dalmate is offline Elite Member
    Join Date
    Jan 2009
    Posts
    369
    Rep Power
    6

    Default

    No. Zimbra has an engine to convert the attachments into HTML format. With that, you can read your attachments in your browser, not need to have any programs (when you click to document link) and you can download your attachment when you click to download

  3. #3
    raj's Avatar
    raj
    raj is offline Moderator
    Join Date
    Oct 2005
    Location
    USA, Canada and India
    Posts
    777
    Rep Power
    10

    Default

    @dalmate: view document as HTML is NE (paid version) function.
    the orignal poster is using FOSS version.

    @gallimore: looks like file association issue for IE + windows for your. in real life when you press on the link IE should launch WORD to open the attached document.

    please check this from some other windows desktop.

    Raj
    i2k2 Networks
    Dedicated & Shared Zimbra Hosting Provider

  4. #4
    gallimore is offline Active Member
    Join Date
    Jan 2009
    Posts
    47
    Rep Power
    6

    Default

    Thanks for the suggestion. This behaviour is present on a number of systems. I have followed the microsoft support documents

    How to configure Internet Explorer to open Office documents in the appropriate Office program instead of in Internet Explorer

    A new window opens when you try to view a 2007 Microsoft Office program document in Windows Internet Explorer 7 or Internet Explorer 8

    Modifying the file associations to not allow opening in same window has no effect.

    We also use liferay but this always prompts to either open or download.

    I notice the end of the document url (shown below) has additional arguments which I presume is what is allowing direct access (as opposed to open/download dialog box.

    Code:
    ..../....).doc?auth=co&loc=en_GB&id=31317&part=2
    I will investigate other documents and in the meantime suggest users use the download link.
    Paul Gallimore

  5. #5
    raj's Avatar
    raj
    raj is offline Moderator
    Join Date
    Oct 2005
    Location
    USA, Canada and India
    Posts
    777
    Rep Power
    10

    Default

    http://mail.domain.com/service/home/...d=36631&part=2

    for me the word document has the above link..

    The behaviour i see is when i click on the attachment document link..i get "windows" dialog box to "open save or cancel" when i hit "open"..MS word is launched and the document is opned in it.

    Raj
    i2k2 Networks
    Dedicated & Shared Zimbra Hosting Provider

  6. #6
    gallimore is offline Active Member
    Join Date
    Jan 2009
    Posts
    47
    Rep Power
    6

    Default

    What version of IE are you using?
    Paul Gallimore

  7. #7
    raj's Avatar
    raj
    raj is offline Moderator
    Join Date
    Oct 2005
    Location
    USA, Canada and India
    Posts
    777
    Rep Power
    10

    Default

    IE : 7.06
    OS: Vista Home Premium
    i2k2 Networks
    Dedicated & Shared Zimbra Hosting Provider

  8. #8
    gallimore is offline Active Member
    Join Date
    Jan 2009
    Posts
    47
    Rep Power
    6

    Default Attachment filename length

    I appear to have finally resolved this issue. The problem appears to be related to the size of the attachment filename. If the name is 83 characters or less, opening the file behaves as expected (opens using word). If the file name is 84 characters or longer, the file is opened in a browser window and displayed as text.
    Paul Gallimore

  9. #9
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    Quote Originally Posted by gallimore View Post
    I appear to have finally resolved this issue. The problem appears to be related to the size of the attachment filename. If the name is 83 characters or less, opening the file behaves as expected (opens using word). If the file name is 84 characters or longer, the file is opened in a browser window and displayed as text.
    Could you please file a bug report and add the details to this thread?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    gallimore is offline Active Member
    Join Date
    Jan 2009
    Posts
    47
    Rep Power
    6

    Default Bug Filed

    OK Bug 42037 filed.

    I am unable to test this on the latest build/version. I am using 5.0.16

    I will be moving into the test upgrade phase of a move to version 6 sometime in the next month.

    PaulG
    Paul Gallimore

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Attachment problem
    By zzzzsg in forum Administrators
    Replies: 4
    Last Post: 08-28-2008, 06:35 AM
  2. Forwarding, and forwarding as Attachments
    By gfdos.sys in forum Users
    Replies: 4
    Last Post: 06-06-2007, 07:22 AM
  3. Red Hat ES4 - 64 bit - Documents Problem
    By RyanC in forum Installation
    Replies: 4
    Last Post: 09-21-2006, 11:01 AM
  4. Message forwarded as attachment problem
    By wildstyle in forum Users
    Replies: 13
    Last Post: 06-20-2006, 04:26 PM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •