Results 1 to 9 of 9

Thread: No administrator account: how to do it?

  1. #1
    GoTo is offline Intermediate Member
    Join Date
    May 2006
    Posts
    21
    Rep Power
    9

    Default No administrator account: how to do it?

    Hi!
    i installed zimbra opensource and it doesn't create the admin account (don't ask me why! ). How can i crate it from CLI?
    Thanks a lot!

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Are you sure the install worked OK? Check the logs for any problems and make sure all the services are working. The command you need is 'zmprov --help', that will give you the syntax you need.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    GoTo is offline Intermediate Member
    Join Date
    May 2006
    Posts
    21
    Rep Power
    9

    Default

    Quote Originally Posted by phoenix
    Are you sure the install worked OK? Check the logs for any problems and make sure all the services are working. The command you need is 'zmprov --help', that will give you the syntax you need.
    i've tried to install the Network edition but the installation was aborted due to MX record check. After i installed the opensource version and the the installation was fine but, catching the network's config file, doesn't create the admin account.
    I sow the zmprov command but i don't see how to create an admin account

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Well, you'll still need the MX record and the hosts file to be correct for the OSS version. Did you remove the Network Edition of Zimbra using './install.sh -u' before you installed the OSS version? As you don't have an admin account I would guess that this install hasn't gone too well, was there anything in the logs to show any problems during the install? When you say there's no admin account, what exactly are you trying to do? Did you check if all the services are running? A little bit more information would help.

    If you run the 'zmprov --help' command the first line of the help is this:
    Code:
    CreateAccount(ca) {name@domain} {password} [attr1 value1 [attr2 value2...]]
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    GoTo is offline Intermediate Member
    Join Date
    May 2006
    Posts
    21
    Rep Power
    9

    Default

    Quote Originally Posted by phoenix
    Well, you'll still need the MX record and the hosts file to be correct for the OSS version. Did you remove the Network Edition of Zimbra using './install.sh -u' before you installed the OSS version? As you don't have an admin account I would guess that this install hasn't gone too well, was there anything in the logs to show any problems during the install? When you say there's no admin account, what exactly are you trying to do? Did you check if all the services are running? A little bit more information would help.

    If you run the 'zmprov --help' command the first line of the help is this:
    Code:
    CreateAccount(ca) {name@domain} {password} [attr1 value1 [attr2 value2...]]
    i know that the installation hasn't gone well but i'd like to create the admin account instead of reinstalling Zimbra.
    The services are ok (zmcontrol status says that all services are running) and i'm able to send and recive email.
    When i say that there isn't the admin account i mean that there isn't! (the command: zmprov gaaa says nothing!)

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    I've just given you the command to create an admin user, read my last post!!
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    GoTo is offline Intermediate Member
    Join Date
    May 2006
    Posts
    21
    Rep Power
    9

    Default

    Quote Originally Posted by phoenix
    I've just given you the command to create an admin user, read my last post!!
    sorry but i don't see how to create an admin account. I've just create an acount, with "zmprov ca" command, but i dont' know how to give it administrator rights.
    Thanks for the patience!

  8. #8
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Code:
    zmprov ca testadmin@domain.com test123 zimbraIsAdminAccount TRUE
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    GoTo is offline Intermediate Member
    Join Date
    May 2006
    Posts
    21
    Rep Power
    9

    Default

    Quote Originally Posted by phoenix
    Code:
    zmprov ca testadmin@domain.com test123 zimbraIsAdminAccount TRUE
    thanks a lot!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •