Results 1 to 4 of 4

Thread: [SOLVED] still some bad domain/host name after changing the domain name of my serveur

  1. #1
    mertz is offline Senior Member
    Join Date
    Jul 2009
    Location
    Toulouse / France
    Posts
    51
    Rep Power
    6

    Default [SOLVED] still some bad domain/host name after changing the domain name of my serveur

    Hello,

    we are using zimbra for now 2 weeks and it works pretty well.

    However, as many other adminstrators I had to change the domain name just before entering in production and I still have some bad domain name in my configuration.

    I set the domain name from zimbra.mydomain.com to mydomain.com using the following command:

    zmprov -l rd zimbra.mydomain.com mydomain.com and the similair for the default domain name zmprov mcf zimbraDefaultDomainName mydomain.com

    I just upgrade form the 5.016 to the 5.0.18 (both Network Edition) and I discovered in the more recent /opt/zimbra/config.xxxx file the current configuration which still contain lots of erroneous domain name (mainly / only? on system mail adresses).

    How can i change this bad email addresses?

    the following is the contents of the config.xxxx file:


    AVDOMAIN=zimbra.mydomain.com
    AVUSER=admin@zimbra.mydomain.com
    CREATEADMIN=admin@mydomain.com
    CREATEDOMAIN=mydomain.com
    DEFAULTLICENSEFILE=/opt/zimbra/conf/ZCSLicense.xml
    DOCREATEADMIN=no
    DOCREATEDOMAIN=no
    DOTRAINSA=yes
    ENABLEDEFAULTBACKUP=yes
    EXPANDMENU=no
    HOSTNAME=zimbra.mydomain.com
    HTTPPORT=441
    HTTPPROXY=FALSE
    HTTPPROXYPORT=8080
    HTTPSPORT=442
    HTTPSPROXYPORT=8443
    IMAPPORT=143
    IMAPPROXYPORT=7143
    IMAPSSLPORT=993
    IMAPSSLPROXYPORT=7993
    JAVAHOME=/opt/zimbra/java
    LDAPHOST=zimbra.mydomain.com
    LDAPPORT=389
    LICENSEFILE=/opt/zimbra/conf/ZCSLicense.xml
    MAILBOXDMEMORYPERCENT=40
    MAILPROXY=FALSE
    MODE=redirect
    MTAAUTHHOST=zimbra.mydomain.com
    MYSQLMEMORYPERCENT=30
    NOTEBOOKACCOUNT=wiki@zimbra.mydomain.com
    POPPORT=110
    POPPROXYPORT=7110
    POPSSLPORT=995
    POPSSLPROXYPORT=7995
    PROXYMODE=http
    REMOVE=no
    RUNARCHIVING=no
    RUNAV=yes
    RUNSA=yes
    SMTPDEST=admin@zimbra.mydomain.com
    SMTPHOST=zimbra.mydomain.com
    SMTPNOTIFY=yes
    SMTPSOURCE=admin@zimbra.mydomain.com
    SNMPNOTIFY=yes
    SNMPTRAPHOST=zimbra.mydomain.com
    SPELLURL=http://zimbra.mydomain.com:7780/aspell.php
    STARTSERVERS=yes
    SYSTEMMEMORY=3.9
    TRAINSAHAM=ham.3zjhnpfxp@zimbra.mydomain.com
    TRAINSASPAM=spam.vd77ild5lu@zimbra.mydomain.com
    UPGRADE=yes
    USEKBSHORTCUTS=TRUE
    USESPELL=yes
    ZIMBRA_REQ_SECURITY=yes
    ldap_dit_base_dn_config=cn=zimbra
    ldap_nginx_password=xxxxxxxx
    ldap_url=ldap://zimbra.mydomain.com:389
    mailboxd_directory=/opt/zimbra/mailboxd
    mailboxd_keystore=/opt/zimbra/mailboxd/etc/keystore
    mailboxd_keystore_password=xxxxxxxxx
    mailboxd_server=jetty
    mailboxd_truststore=/opt/zimbra/java/jre/lib/security/cacerts
    mailboxd_truststore_password=changeit
    postfix_mail_owner=postfix
    postfix_setgid_group=postdrop
    zimbraBackupReportEmailRecipients=mertz@mydomain.c om
    zimbraBackupReportEmailSender=admin@mydomain.com
    zimbraClusterType=none
    zimbraDefaultDomainName=mydomain.com
    zimbraFeatureBriefcasesEnabled=Enabled
    zimbraFeatureIMEnabled=Disabled
    zimbraFeatureNotebookEnabled=Enabled
    zimbraFeatureTasksEnabled=Enabled
    zimbraMtaMyNetworks=127.0.0.0/8 10.0.0.0/8
    zimbraPrefTimeZoneId=(GMT+01.00) Brussels / Copenhagen / Madrid / Paris
    zimbraReverseProxyLookupTarget=TRUE
    zimbra_ldap_userdn=uid=zimbra,cn=admins,cn=zimbra
    zimbra_require_interprocess_security=1
    zimbra_server_hostname=zimbra.mydomain.com
    INSTALL_PACKAGES="zimbra-apache zimbra-archiving zimbra-convertd zimbra-core zimbra-ldap zimbra-logger zimbra-mta zimbra-snmp zimbra-spell zimbra-store "


    thx,

    christophe
    Last edited by mertz; 08-28-2009 at 04:05 AM.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

  3. #3
    mertz is offline Senior Member
    Join Date
    Jul 2009
    Location
    Toulouse / France
    Posts
    51
    Rep Power
    6

    Default the rename issue does'nt appear to be the same

    Thx for your quick reply,

    It seems however, that the mentionned bug only deals with "real" users domain name. In my case all "real" user domain name properly changed.

    Only "zimbra-system" email adresses (e.g. wiki@...) were not modified correctly. Is there a way to change them manually?


    christophe

  4. #4
    mertz is offline Senior Member
    Join Date
    Jul 2009
    Location
    Toulouse / France
    Posts
    51
    Rep Power
    6

    Default the wiki page explaining the solution

    Let's reply to myself...

    the following wiki page explains everything about this renaming pb: ZmSetServerName - Zimbra :: Wiki

    christophe

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 04-27-2009, 02:49 AM
  2. mobile calender Internal Server Error
    By padraig in forum Administrators
    Replies: 19
    Last Post: 04-24-2008, 08:04 AM
  3. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  4. Changing Domain!
    By zibra in forum Administrators
    Replies: 1
    Last Post: 06-01-2007, 05:15 AM
  5. MTA is Dying after yum update
    By tonyawbrey in forum Administrators
    Replies: 27
    Last Post: 04-02-2006, 06:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •