Results 1 to 4 of 4

Thread: Auto replay with relay (blank smtp from)

  1. #1
    brojgn is offline Starter Member
    Join Date
    Jul 2009
    Posts
    1
    Rep Power
    6

    Default Auto replay with relay (blank smtp from)

    Hi all,

    We currently have a list manager mail server that is the source of the the emails. The reply to address is set to come back into the list manager box and then gets relayed to Zimbra. The reasoning for this is optout scripts. However, we would like to have the email in a zimbra account (works) but send out an auto reply (doesn't). The reason for this looks to be ebcause the SMTP from is blank coming from the realy, however inside the email you can see the original to/from. I have set both the auto-reply and the out of office and neither work. Any ideas of how to get this going?

    Thanks!

    (Please excuse any mis-manners in regards to the forum as this is my first post )

  2. #2
    jmartinezm is offline Junior Member
    Join Date
    Jan 2008
    Location
    Barcelona (Spain)
    Posts
    5
    Rep Power
    7

    Default

    We have the same problem.
    Have you found a solution?

    Regards,

  3. #3
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Can you post the headers from one of the emails ?

  4. #4
    jmartinezm is offline Junior Member
    Join Date
    Jan 2008
    Location
    Barcelona (Spain)
    Posts
    5
    Rep Power
    7

    Default

    Incomming mail logs:

    Aug 4 12:43:18 sv811 postfix/smtpd[24334]: 2C5D037723A: client=smr.ncb1.antispamhost.com[217.23.218.266]
    Aug 4 12:43:18 sv811 postfix/cleanup[24333]: 2C5D037723A: message-id=<ce1c11cb0908040342k336c65f1r4c5d28e45a53582c@m ail.gmail.com>
    Aug 4 12:43:18 sv811 postfix/qmgr[6935]: 2C5D037723A: from=<correo@sourceaddress.es>, size=1697, nrcpt=1 (queue active)
    Aug 4 12:43:18 sv811 postfix/lmtp[23880]: 2C5D037723A: to=<jmartinezm@destination.es>, relay=sv809.ourdomain.com[10.192.65.20]:7025, delay=0.27, delays=0.04/0/0.03/0.2, dsn=2.1.5, status=sent (250 2.1.5 OK)
    Aug 4 12:43:18 sv811 postfix/qmgr[6935]: 2C5D037723A: removed

    Message returned by our external AntiSpam platform (Relay host):

    Aug 4 12:43:18 sv811 postfix/smtpd[26363]: 6DF9537723A: client=sv807.ourdomain.com[10.192.65.16]
    Aug 4 12:43:18 sv811 postfix/cleanup[26367]: 6DF9537723A: message-id=<195765708.31391249382598365.JavaMail.root@sv80 9.ourdomain.com>
    Aug 4 12:43:18 sv811 postfix/qmgr[6935]: 6DF9537723A: from=<>, size=1465, nrcpt=1 (queue active)
    Aug 4 12:43:18 sv811 postfix/smtp[27141]: 6DF9537723A: to=<correo@sourceaddress.es>, relay=217.23.218.266[217.23.218.266]:25, delay=0.1, delays=0.03/0/0.04/0.02, dsn=5.0.0, status=bounced (host 217.23.218.266[217.23.218.266] said: 550 Invalid IP (293.216.123.278) for this domain (6) (in reply to MAIL FROM command))
    Aug 4 12:43:18 sv811 postfix/qmgr[6935]: 6DF9537723A: removed


    Our scenario:

    Our company servers <---> Internet <---> AntiSpam Provider (RelayHost)

    We are authenticating with our AntiSpam Provider to be able to send messages to the Internet.
    Our external AntiSpam provider detects that the from=<> is empty and denies to send messages.

    When we send the message from an internal account, it works and the from is empty also: from=<>

    Header from internal network auto-reply received email (internal user to internal user):

    Received: from ourdomain.es (LHLO sv807.ourdomain.com) (10.192.65.16) by
    sv810.ourdomain.com with LMTP; Tue, 4 Aug 2009 11:25:57 +0200 (CEST)
    Received: from sv809.ourdomain.es (ourdomain.com [10.192.65.20])
    by sv807.ourdomain.com (Postfix) with ESMTP id 0F9573871EF
    for <fjcatala@ourdomain.es>; Tue, 4 Aug 2009 11:25:57 +0200 (CEST)
    Date: Tue, 4 Aug 2009 11:25:56 +0200 (CEST)
    From: =?utf-8?Q?Javier_Mart=C3=ADnez_Mart=C3=AD?= <jmartinezm@ourdomain.es>
    To: fjcatala@ourdomain.es
    Message-ID: <2096718820.21451249377956958.JavaMail.root@sv809. ourdomain.com>
    In-Reply-To: <1701760427.50731249377956665.JavaMail.root@sv810. ourdomain.com>
    Subject: Re: estos mac...
    MIME-Version: 1.0
    Content-Type: text/plain; charset=utf-8
    Content-Transfer-Encoding: quoted-printable
    Auto-Submitted: auto-replied (zimbra; vacation)
    Precedence: bulk
    ---- END ---

    Thanks
    Javier
    Last edited by jmartinezm; 08-04-2009 at 09:01 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SMTP Relay
    By adarsh in forum Administrators
    Replies: 4
    Last Post: 11-11-2010, 04:36 AM
  2. Exchange Server 2003 SMTP
    By jschwartz73 in forum General Questions
    Replies: 8
    Last Post: 04-07-2008, 01:56 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. Open Relay Help & Telnet Security Issue
    By OfMacAndMen in forum Installation
    Replies: 17
    Last Post: 07-10-2007, 07:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •