Results 1 to 5 of 5

Thread: [SOLVED] HTML Attachment Rendering from Mac OS X Server

  1. #1
    dpmchris is offline Special Member
    Join Date
    Nov 2007
    Location
    Chicago
    Posts
    105
    Rep Power
    7

    Question [SOLVED] HTML Attachment Rendering from Mac OS X Server

    I am having a hard time finding the answer in the forums or the wiki, so I will just ask it here:

    Every once in a while my boss comes back to me and asks me if "Attachment Previews" are available. Since our server platform is Mac OS X Server, this feature has not been available. It is hard to test compare or evaluate, since the only thing that will render is bitmap graphics.

    1) How accurate are these previews and what documents are supported?

    2) What is the technical limitation that keeps Mac OS X Server from generating these previews?

    3) What settings are there for turning it off so it doesn't look broken?

    Keep in mind, we are almost exclusively using the web client, so cheating in Outlook or Mail.app is not applicable.


    Thanks,
    Chris at PN
    Version 6.0.16_GA_2998.NETWORK Apr 4, 2012 MACOSXx86
    Xserve 2x Dual Core Xeons 10GB with Xserve RAID

  2. #2
    putt1ck is offline Active Member
    Join Date
    Jul 2007
    Location
    UK
    Posts
    29
    Rep Power
    8

    Default Well...

    I'll answer what I can

    1) The previews seem pretty accurate for the files I view. Not print perfect and not a substitute for opening the doc properly - but for reading for content e.g. checking a quote the previews are great. Not sure of the restrictions, but for the common attachments I get it works fine. Legacy doc and xls, PDF, ISO26300 (ODF). Even that MS failed attempt at an XML format (did I say that out loud ) renders fine.

    2) I would surmise that the inclusion of the feature only in the closed source version of the product is because it is a third-party app that does not support that most rare of server platforms, Mac OSX. Considered changing to a cheaper and better server platform? Shouldn't be a particular challenge or break anything unless you're using the server for other special Mac roles like looking good

    3) Login to the admin console, goto your COS, in Advanced and change the settings to "Attachments can be viewed in their original format only" or "Disable attachment viewing from web mail UI".

    Hope that helps.

    Chris

  3. #3
    dpmchris is offline Special Member
    Join Date
    Nov 2007
    Location
    Chicago
    Posts
    105
    Rep Power
    7

    Default

    Yes I get it, OS X Server has no value, and I got ripped off by standardizing on Xserves. Never mind that they perform flawlessly so I can support EVERYTHING here alone with barely any outside support. And they weren't that expensive. Apple sucks. Fine. At least they are pretty.

    I did get the feeling that the rendering pieces were from a third party, but Zimbra only has a grid that says 'feature not available' which is not enough information to explain it to my boss. Do you know what 3rd paerty it is?

    Thanks for tip #3, by the way. Don't think I noticed that before.
    Version 6.0.16_GA_2998.NETWORK Apr 4, 2012 MACOSXx86
    Xserve 2x Dual Core Xeons 10GB with Xserve RAID

  4. #4
    rharms is offline Junior Member
    Join Date
    Aug 2007
    Posts
    6
    Rep Power
    8

  5. #5
    dpmchris is offline Special Member
    Join Date
    Nov 2007
    Location
    Chicago
    Posts
    105
    Rep Power
    7

    Default

    Interesting. Thanks all, I got what I need, and moreso.
    Version 6.0.16_GA_2998.NETWORK Apr 4, 2012 MACOSXx86
    Xserve 2x Dual Core Xeons 10GB with Xserve RAID

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to: cold standby server (no cluster)
    By fisch09 in forum Installation
    Replies: 50
    Last Post: 02-18-2014, 10:51 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. Error after installation
    By robsontuxlinux in forum Installation
    Replies: 13
    Last Post: 09-11-2008, 09:48 PM
  4. Uninstall on Mac OS X Server 10.4.4
    By kalixia in forum Installation
    Replies: 15
    Last Post: 04-02-2006, 05:56 PM
  5. Zimbra on Mac OS X Powerbook (Server and Client)
    By robjsewell in forum Installation
    Replies: 3
    Last Post: 01-29-2006, 07:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •