Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 52

Thread: [SOLVED] Cant send mail-Pls help

  1. #21
    ask2me007 is offline Special Member
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    Let's check that everything is working correctly. I don't know if Ubuntu installs another MTA but do you have any other mailserver running on your system? Run the following commands on your server:

    Code:
    su - zimbra
    zmcontrol status
    That should show all the services running, if the MTA isn't running then do this:

    Code:
    telnet localhost 25
    If you get a valid response from that then you have another MTA running and it needs to be stopped and disabled. If you need to stop it then restart Zimbra again and see if you can send email. If there's still the same problem then run these commands again and post the output:

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes
    Ubuntu also has Apparmor but I don't know if it's enabled by default, can you check and disable it if it's running and you should also make sure there's no firewall running on that server.


    zimbra@pop:/root$ zmcontrol status
    Host pop.ksfe.com
    antispam Running
    antivirus Running
    ldap Running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running



    Then I stopped Zimbra and executed the command


    zimbra@pop:/root$ telnet localhost 25
    Trying 127.0.0.1...
    telnet: Unable to connect to remote host: Connection refused

    I have already recorded the details in my previous post.
    for host and mx records,


    Any way thanks a lot for getting support from all of you.:

  2. #22
    ask2me007 is offline Special Member
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    6

    Default

    Quote Originally Posted by ask2me007 View Post
    zimbra@pop:/root$ zmcontrol status
    Host pop.ksfe.com
    antispam Running
    antivirus Running
    ldap Running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running



    Then I stopped Zimbra and executed the command


    zimbra@pop:/root$ telnet localhost 25
    Trying 127.0.0.1...
    telnet: Unable to connect to remote host: Connection refused

    I have already recorded the details in my previous post.
    for host and mx records,


    Any way thanks a lot for getting support from all of you.:

    Sorry to say again.


    Jun 19 14:26:45 pop amavis[8208]: (08208-01) extra modules loaded: /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/Net/SSLeay/autosplit.ix, /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/Net/SSLeay/randomize.al, IO/Socket/SSL.pm, Net/LDAP/Extension.pm, Net/SSLeay.pm
    Jun 19 14:26:45 pop postfix/smtp[11758]: 9A71B802312: to=<ebas@gmail.com>, relay=none, delay=0.09, delays=0.09/0/0/0, dsn=4.4.1, status=deferred (connect to 59.93.43.183[59.93.43.183]: Connection refused)

  3. #23
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Post post the zone information I have asked for

  4. #24
    ask2me007 is offline Special Member
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    6

    Default

    Quote Originally Posted by uxbod View Post
    Post post the zone information I have asked for


    //
    // Do any local configuration here
    //

    // Consider adding the 1918 zones here, if they are not used in your
    // organization
    //include "/etc/bind/zones.rfc1918";
    #####added ask
    options {
    directory "/var/cache/bind";

    query-source address * port 53;

    forwarders {
    218.248.240.208; 218.248.240.135;
    };

    auth-nxdomain no; # conform to RFC1035

    };
    //forwarders { ip_addr [port ip_port] ; [ ip_addr [port ip_port] ; ... ] };

  5. #25
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    So where have you specified your domain zone file ? All I can see in that file is two forwarders. This means all your DNS queries are being sent upstream so it will always resolve to your external IP and not the internal one.

  6. #26
    ask2me007 is offline Special Member
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    6

    Default

    Quote Originally Posted by uxbod View Post
    So where have you specified your domain zone file ? All I can see in that file is two forwarders. This means all your DNS queries are being sent upstream so it will always resolve to your external IP and not the internal one.

    I have included the followin in named.conf

    zone "domain.com" {
    type master;
    file "/etc/bind/db.domain.com";
    };

    Now the


    zimbra@pop:/root$ dig domain.com mx

    ; <<>> DiG 9.4.2 <<>> domain.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 568
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;domain.com. IN MX

    ;; ANSWER SECTION:
    domain.com. 604800 IN MX 10 pop.domain.com.

    ;; AUTHORITY SECTION:
    domain.com. 604800 IN NS pop.domain.com.

    ;; ADDITIONAL SECTION:
    pop.domain.com. 604800 IN A 192.168.10.5

    ;; Query time: 0 msec
    ;; SERVER: 192.168.10.5#53(192.168.10.5)
    ;; WHEN: Fri Jun 19 16:19:41 2009
    ;; MSG SIZE rcvd: 76

    Again when sending mail it says the following error



    Jun 19 16:29:48 pop postfix/smtp[32579]: C1E68802329: to=<ask2me007@gmail.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=12, delays=0.09/0.01/0/12, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 5D7AD80232A)
    Jun 19 16:29:48 pop postfix/qmgr[20509]: C1E68802329: removed
    Jun 19 16:29:48 pop postfix/smtp[32750]: 5D7AD80232A: to=<ask2me007@gmail.com>, relay=none, delay=0.09, delays=0.08/0.01/0/0, dsn=4.4.1, status=deferred (connect to 59.93.43.183[59.93.43.183]: Connection refused)

  7. #27
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    Quote Originally Posted by ask2me007 View Post
    zimbra@pop:/root$ telnet localhost 25
    Trying 127.0.0.1...
    telnet: Unable to connect to remote host: Connection refused
    That would indicate to me that you have a firewall of AppArmor blocking the connection. Check this article and disable AppAromor: https://help.ubuntu.com/community/Ap...or%20framework and also disable your firewall: https://help.ubuntu.com/8.04/serverg.../firewall.html
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #28
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    Quote Originally Posted by ask2me007 View Post
    Jun 19 14:26:45 pop postfix/smtp[11758]: 9A71B802312: to=<ebas@gmail.com>, relay=none, delay=0.09, delays=0.09/0/0/0, dsn=4.4.1, status=deferred (connect to 59.93.43.183[59.93.43.183]: Connection refused)
    In addition, this would also indicate that you're still picking up your external IP address rather than your LAN IP address.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #29
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    Can you also post the output of the following command:

    Code:
    cat /etc/nsswitch.conf
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #30
    ask2me007 is offline Special Member
    Join Date
    Dec 2008
    Location
    India
    Posts
    110
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    That would indicate to me that you have a firewall of AppArmor blocking the connection. Check this article and disable AppAromor: https://help.ubuntu.com/community/Ap...or%20framework and also disable your firewall: https://help.ubuntu.com/8.04/serverg.../firewall.html


    Dear Phoenix

    As you said i checked firewall ,and there is no firewall loaded here.

    root@pop:~# sudo ufw status
    Firewall not loaded
    And the apparmor disabled by using the following commands

    sudo /etc/init.d/apparmor stop
    sudo update-rc.d -f apparmor remove

    Any way the problem i still there

    Jun 19 19:05:04 pop postfix/smtp[11562]: EAD18802336: to=<ask2me007@gmail.com>, relay=none, delay=0.08, delays=0.08/0.01/0/0, dsn=4.4.1, status=deferred (connect to 59.93.43.183[59.93.43.183]: Connection refused)

Page 3 of 6 FirstFirst 12345 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] mailbox and apache not running
    By rtwick in forum Administrators
    Replies: 4
    Last Post: 11-15-2008, 08:21 AM
  2. zmamavisdctl stopped and won't restart
    By alto in forum Installation
    Replies: 2
    Last Post: 04-18-2008, 12:41 AM
  3. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  4. Tomcat broken after upgrade to 4
    By dotslashroot in forum Migration
    Replies: 13
    Last Post: 01-31-2007, 06:05 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •