Here is the error we get on the server, on the command-line:

[zimbra@mail root]$ zmprov sg more.net paul
ERROR: service.FAILURE (system failure: unable to search GAL)
[zimbra@mail root]$

The above works fine on another mail server we have that runs zimbra.

Here's the result from the zimbra desktop client when hitting the "To:" button for a new email:

2009-06-10 09:49:58,228 DEBUG [btpool0-16] [mid=9;] offline - ============================== SYNC DEBUG TRACE START ==============================
2009-06-10 09:49:58,229 INFO [btpool0-16] [mid=9;] offline - >>>>>>>> name=paul@more.net;version=1.0;build=1593;release= R;os=Mac OS X i386 10.5.7;server=5.0.6
2009-06-10 09:49:58,230 DEBUG [btpool0-16] [mid=9;] request - <SyncRequest typed="1" token="3411" xmlns="urn:zimbraMail"/>
2009-06-10 09:49:58,406 DEBUG [btpool0-16] [mid=9;] response - <SyncResponse md="1244641656" token="3411" xmlns="urn:zimbraMail"/>
2009-06-10 09:49:58,406 DEBUG [btpool0-16] [mid=9;] offline - starting delta sync [token 3411]
2009-06-10 09:49:58,406 DEBUG [btpool0-16] [mid=9;] offline - ending delta sync [token 3411]
2009-06-10 09:49:58,425 DEBUG [btpool0-16] [mid=9;] offline - starting change push
2009-06-10 09:49:58,426 DEBUG [btpool0-16] [mid=9;] request - <ItemActionRequest xmlns="urn:zimbraMail"><action op="read" id="1940"/></ItemActionRequest>
2009-06-10 09:49:58,625 DEBUG [btpool0-16] [mid=9;] response - <ItemActionResponse xmlns="urn:zimbraMail"><action op="read" id="1940"/></ItemActionResponse>
2009-06-10 09:49:58,625 INFO [btpool0-16] [mid=9;] offline - push: batch updated 1940
2009-06-10 09:49:58,632 DEBUG [btpool0-16] [mid=9;] offline - ending change push
2009-06-10 09:49:58,633 DEBUG [btpool0-16] [mid=9;] request - <SyncRequest typed="1" token="3411" xmlns="urn:zimbraMail"/>
2009-06-10 09:49:58,821 DEBUG [btpool0-16] [mid=9;] response - <SyncResponse md="1244641656" token="3412" xmlns="urn:zimbraMail"><m d="1244601392000" ms="3412" md="1244641656" f="" t="" l="2" cid="-1940" id="1940" rev="3408"/></SyncResponse>
2009-06-10 09:49:58,821 DEBUG [btpool0-16] [mid=9;] offline - starting delta sync [token 3411]
2009-06-10 09:49:58,839 DEBUG [btpool0-16] [mid=9;] offline - delta: updated message (1940): Re: SF: Case 00039612: msg: systemFAILURE: unable to reach GAL
2009-06-10 09:49:58,843 DEBUG [btpool0-16] [mid=9;] offline - ending delta sync [token 3412]
2009-06-10 09:49:58,879 DEBUG [btpool0-16] [mid=9;] offline - Offline GAL sync is disabled: paul@more.net
2009-06-10 09:49:59,170 DEBUG [btpool0-16] [mid=9;] offline - ============================== SYNC DEBUG TRACE END ================================