Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Reverse proxy change stopped outgoing mails

  1. #1
    marku is offline Junior Member
    Join Date
    May 2009
    Posts
    8
    Rep Power
    6

    Default Reverse proxy change stopped outgoing mails

    I have recently had my ISP update their nameserver so that reverse proxy will resolve to the mailserver. However, after the change I cannot seem to be able to send emails outside. All the emails are sitting on the deferred Queue with "Delivery temporary suspended". I have tried postqueue -f without any success and checked without anti spam/ virus - but it's the same. Anti spam/ Anti virus / Permissions are looking good.

    Any suggestions on how I can resolve this? I can seem to be able to receive emails fine..

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Welcome to the forums

    Code:
    su - zimbra
    zmcontrol -v
    zmcontrol status
    Are you able to resolve the remote domains okay ? Now they have put in the rDNS then lets check your own DNS
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig -x {IP address of your server}
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not singles quotes

  3. #3
    marku is offline Junior Member
    Join Date
    May 2009
    Posts
    8
    Rep Power
    6

    Default

    I am attaching those here. none seems out of ordinary. ( domain name/IP is replaced with x to protect identity)

    [root@mantis log]#
    [root@mantis log]# cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    [root@mantis log]# cat /etc/resolv.conf
    nameserver 173.x.x.1
    search hfc.comcastbusiness.net

    [root@mantis log]# dig -x 173.x.x.2

    ; <<>> DiG 9.2.4 <<>> -x 173.x.x.2
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 27475
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;2.x.x.173.in-addr.arpa. IN PTR

    ;; ANSWER SECTION:
    2.x.x.173.in-addr.arpa. 1941 IN PTR mantis.x.com.
    2.x.x.173.in-addr.arpa. 1941 IN PTR mail.x.com.

    ;; Query time: 6 msec
    ;; SERVER: 173.x.x.1#53(173.x.x.1)
    ;; WHEN: Mon May 25 23:54:32 2009
    ;; MSG SIZE rcvd: 110

    [root@mantis log]# dig x.com mx

    ; <<>> DiG 9.2.4 <<>> x.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11732
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;;x.com. IN MX

    ;; ANSWER SECTION:
    x.com. 14400 IN MX 10 mail.x.com.

    ;; Query time: 95 msec
    ;; SERVER: 173.x.x.1#53(173.x.x.1)
    ;; WHEN: Mon May 25 23:55:00 2009
    ;; MSG SIZE rcvd: 53

    [root@mantis log]# host `hostname`
    mantis.x.com has address 173.x.x.2

    ### Just updated to the most latest release ###
    [zimbra@mantis ~]$ zmcontrol -v


    Release 5.0.16_GA_2921.RHEL4_20090429033149 CentOS4 FOSS edition


    [zimbra@mantis ~]$ zmcontrol status
    Host mantis.x.com
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    spell Running
    stats Running

  4. #4
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Quote Originally Posted by marku View Post
    [root@mantis log]# cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    Well your /etc/hosts file is incorrect as it should be
    Code:
    127.0.0.1           localhost.localdomain localhost
    your.ip.address         FQDN yourhostname

  5. #5
    marku is offline Junior Member
    Join Date
    May 2009
    Posts
    8
    Rep Power
    6

    Default

    Tried it, but mail still sits there with connection timing out. Should I do something like re installing the zimbra with install.sh or somthing else after this change is put in?

    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    173.x.x.2 mantis.x.com mantis

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,567
    Rep Power
    57

    Default

    If 173.x.x.2 is the IP address of your mail server then the DNS information above does not show a valid A & MX record for your server. You mention the 'proxy', is this a single server install? Is you Zimbra server behind a NAT router or firewall?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    marku is offline Junior Member
    Join Date
    May 2009
    Posts
    8
    Rep Power
    6

    Default

    It is behind a firewall, but in a bridged setup where all mail traffic is ported over without restriction. It had been working until the rDNS was added by my ISP. Sorry about the confusion, no mail proxy is running anywhere - it's a single server.
    The DNS info from a seperate machine gives out the following (looks ok to me.) BTW, mail.x.com and mantis.x.com both points to the same IP.

    $ dig x.com mx

    ; <<>> DiG 9.3.4-P1 <<>> x.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 44980
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;x.com. IN MX

    ;; ANSWER SECTION:
    x.com. 14400 IN MX 10 mail.x.com.

    ;; AUTHORITY SECTION:
    x.com. 86400 IN NS ns2.fastnext.com.
    x.com. 86400 IN NS ns1.fastnext.com.

    ;; ADDITIONAL SECTION:
    mail.x.com. 14400 IN A 173.x.x.2

    ;; Query time: 341 msec
    ;; SERVER: 168.215.210.50#53(168.215.210.50)
    ;; WHEN: Wed May 27 07:32:55 2009
    ;; MSG SIZE rcvd: 114

  8. #8
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,567
    Rep Power
    57

    Default

    Adding a reverse DNS record (I assume that's what you mean by rDNS?) should not make any difference to you zimbra server. DO you get the same results when you run the dig commands from your Zimbra serve (that's where you should always do the tests)?

    Just for confirmation, let's have the output of the following command again (run on your zimbra server):

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig -x {IP address of your server}
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not singles quotes
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    marku is offline Junior Member
    Join Date
    May 2009
    Posts
    8
    Rep Power
    6

    Default

    Ah. great. Now none of the services are coming up starting with LDAP. ldap is failing with exit code 256 claiming address in use, ( I look at netstat and the port 389 is free). All other services are down as well. What should I do now ? I am out of ideas.

    this is a part from the error

    Setting defaults from ldap...ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException mantis.x.com:389)
    ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException mantis.x.com:389)
    ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException mantis.x.com:389)
    ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException mantis.x.com:389)
    ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException mantis.x.com:389)
    ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException mantis.x.com:389)
    ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException mantis.x.com:389)
    ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException mantis.x.com:389)
    ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException mantis.x.com:389)

  10. #10
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Please post the information Phoenix has asked for.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Turn off reverse proxy?
    By paulgear in forum Installation
    Replies: 1
    Last Post: 05-26-2009, 04:09 AM
  2. Bug with reverse proxy and wiki
    By FFL in forum Developers
    Replies: 2
    Last Post: 08-01-2008, 04:40 AM
  3. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 08:59 AM
  4. How to make Zimbra use HTTP Proxy on outgoing requests?
    By martinm_76 in forum Installation
    Replies: 2
    Last Post: 09-03-2006, 09:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •