Page 3 of 7 FirstFirst 12345 ... LastLast
Results 21 to 30 of 65

Thread: Help dealing with spam

  1. #21
    cutigersfan is offline Active Member
    Join Date
    Apr 2006
    Posts
    49
    Rep Power
    9

    Default

    No Kevin, I didn't. I used the options in the zimbra install script to change the names. Ok, 2 questions:

    1) Does that need an entry in bugzilla?
    2) How do I fix it?

  2. #22
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Quote Originally Posted by cutigersfan
    No Kevin, I didn't. I used the options in the zimbra install script to change the names. Ok, 2 questions:

    1) Does that need an entry in bugzilla?
    2) How do I fix it?
    1) Nope; - but a reminder that we need a STRONGER warning in the docs/notes not to delete/change them unless you know what your doing.

    2) Use zmprov to set these LDAP attrs to the new account names.

    zimbraSpamIsSpamAccount
    zimbraSpamIsNotSpamAccount
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #23
    cutigersfan is offline Active Member
    Join Date
    Apr 2006
    Posts
    49
    Rep Power
    9

    Default LDAP Attrs already there?

    I used zimprov to query those values and they were indeed both set correctly. 'zmprov gcf zimbraSpamIsNotSpamAccount' returned the "correct" account name.

    I think this means it was set up as you expected. No? Other ideas?

  4. #24
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Check the logs in /opt/zimbra/log There should be a satrain (or something like that log) which has training log details.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #25
    cutigersfan is offline Active Member
    Join Date
    Apr 2006
    Posts
    49
    Rep Power
    9

    Default

    I greped the logs and couldn't find anything about satrain. I do see that when the junk button is hit, the message is copied to the trainspam account.

    Is satrain supposed to be running?

  6. #26
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    I think KevinH means "/opt/zimbra/log/spamtrain.log" and there's a cron job called zmtrainsa that's run daily to train Zimbra.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #27
    tbullock is offline Advanced Member
    Join Date
    Oct 2005
    Location
    Calgary, AB
    Posts
    232
    Rep Power
    9

    Default

    Here is an excerpt from my /opt/zimbra/log/spamtrain.log file:

    PROCESSING USER: zimbra
    Processing sigs; age: 14
    Processing probabilities; age: 0
    Processing unused; any: 90 quota: 30 nospam: 15 onehit: 15
    [] ERROR: no account configured for spam
    [] ERROR: no account configured for ham
    [] ERROR: no account configured for spam
    [] ERROR: no account configured for ham
    upgrading to DB_File, please be patient: /opt/zimbra/amavisd/.spamassassin/old_bayes_seen
    DB_File: copied 10047 entries
    upgrading to DB_File, please be patient: /opt/zimbra/amavisd/.spamassassin/old_bayes_toks
    DB_File: copied 142026 entries
    import successful, original files saved with "old" prefix
    archive-iterator: readdir found no mail in '/tmp/spam.23921' directory
    Learned from 0 message(s) (0 message(s) examined).
    archive-iterator: readdir found no mail in '/tmp/ham.23921' directory
    Learned from 0 message(s) (0 message(s) examined).
    bayes: synced databases from journal in 1 seconds: 989 unique entries (1951 total entries)
    dspam_clean starting

    It appears as though I am having an issue? I do not have the spam/ham accounts created?

    I am running: Release 3.1.1_GA_394.FC3_20060505121237 FC3 FOSS edition
    but it has been upgraded several times going back to a release sometime in October of 2005.

    How do I make the accounts it is failing to find?

    Cheers,

    Travis

  8. #28
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    When you initially install Zimbra it creates those accounts with random names, it will tell you in the install log what they were or you can just create new ones using zmprov. Have a look at the post from cutigersfan about querying for those accounts and create them if they don't exist, you also need to create the LDAP attributes (to point to these accounts) see the post from KevinH further up this page and use zmprov to create the new attributes.
    Last edited by phoenix; 05-30-2006 at 11:38 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #29
    tbullock is offline Advanced Member
    Join Date
    Oct 2005
    Location
    Calgary, AB
    Posts
    232
    Rep Power
    9

    Default

    Hi Bill,

    When I run 'zmprov gcf zimbraSpamIsNotSpamAccount' I get nothing back.

    So what is that telling me?

    Thanks,

    Travis

  10. #30
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    It's telling you those entries don't exist. First have a look in the admin ui and see if there's a couple of accounts that have random names such as 'nskdlamn' with your domain name. If they exist then all you need to do is use 'zmprov mcf zimbraSpamIsSpamAccount spam_account' and add the spam account and obviously the same for the ham account. If those entries don't exist then just create two new accounts and add them using zmprov. That should fix the problem.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Page 3 of 7 FirstFirst 12345 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trying to understand Zimbra's anti-spam system
    By TaskMaster in forum Users
    Replies: 11
    Last Post: 01-25-2008, 09:59 AM
  2. [SOLVED] Reject SPAM
    By s0undt3ch in forum Users
    Replies: 9
    Last Post: 08-22-2007, 03:07 AM
  3. Spam being scored with BAYES_00
    By flyerguybham in forum Administrators
    Replies: 6
    Last Post: 04-24-2007, 12:07 PM
  4. Training spam and ham
    By Justin in forum Developers
    Replies: 2
    Last Post: 10-31-2006, 03:39 PM
  5. Spam questions 3.11
    By cdyer in forum Administrators
    Replies: 10
    Last Post: 05-22-2006, 10:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •