Results 1 to 3 of 3

Thread: Problems with upgrading

  1. #1
    jeg1972 is offline Active Member
    Join Date
    Jan 2006
    Location
    UK
    Posts
    37
    Rep Power
    9

    Default Problems with upgrading

    I'm running CentOS 4.3 and Zimbra 3.1. Everything was working well, and we were on the brink of going live, so I thought I would upgrade to 3.1.1... big mistake.

    The upgrade was going as expected until:

    Installing:
    zimbra-core
    zimbra-ldap
    zimbra-logger
    zimbra-mta
    zimbra-snmp
    zimbra-store
    zimbra-apache
    zimbra-spell

    The system will be modified. Continue? [N] y

    Shutting down zimbra mail

    Removing existing packages

    zimbra-mta...done
    zimbra-core...done

    Removing deployed webapp directories
    Installing packages

    zimbra-core......zimbra-core-3.1.1_GA_394.RHEL4-20060505121349.i386.rpm...FAILED
    ###ERROR###

    zimbra-core-3.1.1_GA_394.RHEL4-20060505121349.i386.rpm installation failed

    Installation cancelled

    I tried ./install.sh -u and tried a complete re-install but when I start again I get:

    Operations logged to /tmp/install.log.5914
    Checking for existing installation...
    zimbra-ldap...NOT FOUND
    zimbra-logger...NOT FOUND
    zimbra-mta...FOUND zimbra-mta-3.1.1_GA_394
    zimbra-snmp...NOT FOUND
    zimbra-store...NOT FOUND
    zimbra-apache...NOT FOUND
    zimbra-spell...NOT FOUND
    zimbra-core...FOUND zimbra-core-3.1.1_GA_394

    Saving existing configuration file to /opt/zimbra/.saveconfig
    cp: cannot stat `/opt/zimbra/java/jre/lib/security/cacerts': No such file or directory

    But zimbra-core and zimbra-mta are not installed, so I don't know how to get back to a working system without re-building the box?

    I'm a bit desperate as the live date is looming and I'm worried that i'm going have problems when I come to upgrade the next time.

    Thanks in advance

    John

  2. #2
    jeg1972 is offline Active Member
    Join Date
    Jan 2006
    Location
    UK
    Posts
    37
    Rep Power
    9

    Default

    Well, I sort of answered this myself... actually found that zimbra-core and zimbra-mta rpm's weren't uninstalling themselves... (used rpm -qa | grep zimbra)
    and then un-installed the packages and started again and that worked.

    Has anybody had problems with rpm's not uninstalling when using the install script?

    John

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    I've never had any problems with upgrades but some people have, in the past, had services not stop and then the install fails.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Restarting and german 'umlaut' problems
    By Oswald-Kolle in forum Installation
    Replies: 3
    Last Post: 05-29-2007, 02:09 AM
  2. iSync Connector / Apple Address Book Problems
    By jrosen in forum CalDAV / CardDAV / iSync
    Replies: 11
    Last Post: 04-16-2007, 03:40 PM
  3. Replies: 3
    Last Post: 12-06-2006, 11:31 AM
  4. Error when upgrading from 3.1 -> 3.1.1
    By jeg1972 in forum Installation
    Replies: 2
    Last Post: 05-10-2006, 06:10 AM
  5. Replies: 4
    Last Post: 04-26-2006, 10:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •