Results 1 to 5 of 5

Thread: Reindexing

  1. #1
    bellzerr is offline Senior Member
    Join Date
    May 2006
    Location
    Pennsylvania
    Posts
    70
    Rep Power
    8

    Default Reindexing

    From Zimbra help:
    "Each mailbox has an index file associated with it. If a mailbox's index file becomes corrupt or is accidentally deleted, you can re-index the messages in the mailbox."

    I would like to purposely delete a (test) users mailbox index file so I can rebuild it to verify that document indexes are included in the rebuild. Can anyone tell me how to find a given user's mailbox index file?

    Thanks.

  2. #2
    bellzerr is offline Senior Member
    Join Date
    May 2006
    Location
    Pennsylvania
    Posts
    70
    Rep Power
    8

    Default

    I discovered a way to test. Again from the help screen:
    "Caution: When you click Start Reindexing, the first action is to delete the existing index file. If re-indexing is cancelled before the re-index process is complete, the user's mailbox is partially indexed and searches may not return the right results."

    So I started and immediately stopped a reindex, checked a document search - nothing! Even the document names are not listed as if the docs themselves had been deleted (that will make you lose some sleep!). Then, reindex again and allow it to complete. Docs are back and doc searches work. So tonight I'm going to try it against my own, rather huge mailbox and see if it fixes the docs searches that are currently failing for me. I'll let you know how it works out.

  3. #3
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    If you do find a issue then please check and file a RFE at Bugzilla Main Page. Thank you

  4. #4
    bellzerr is offline Senior Member
    Join Date
    May 2006
    Location
    Pennsylvania
    Posts
    70
    Rep Power
    8

    Default

    The reindex process seems to work - I just performed a fresh reindex on my mailbox - but I must be missing something in my understanding of how documents are indexed.
    • I created a new page called: Speedy vixen
    • It contains one line: The quick brown fox jumped over the lazy dog.

    The only words that return this page from the search box are: quick, brown, jumped, lazy and "dog." (note inclusion of the period). Searching for dog without the period fails as does do* even the the help screens for searching use do* as a mask example for searching the word dog.
    I'm not surprised that searching for "the" fails, but what happened to "fox" and "over?"
    I don't believe this issue exists with mail messages searches. Is the indexing process different for documents?
    Thanks for any help.

  5. #5
    bellzerr is offline Senior Member
    Join Date
    May 2006
    Location
    Pennsylvania
    Posts
    70
    Rep Power
    8

    Default

    More info on this. While Firefox just sits and seems to do nothing on this erroroneous "missed" searches, IE7 displays a runtime error (see attached).
    Attached Images Attached Images

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Issues Reindexing Mail Accounts
    By Lynner in forum Installation
    Replies: 5
    Last Post: 01-17-2011, 02:10 AM
  2. Reindexing from the command line
    By plan9 in forum Administrators
    Replies: 5
    Last Post: 08-14-2008, 10:14 AM
  3. Problem Reindexing Mailbox?
    By LMStone in forum Administrators
    Replies: 0
    Last Post: 05-09-2008, 10:42 AM
  4. Start reindexing for all accounts?
    By McPringle in forum Administrators
    Replies: 1
    Last Post: 10-23-2006, 07:35 AM
  5. Reindexing messages from store
    By gutzeit in forum Installation
    Replies: 1
    Last Post: 11-15-2005, 03:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •