Results 1 to 3 of 3

Thread: OmniFocus Support (user+omnifocus@domain.com)

  1. #1
    f0rd42 is offline Active Member
    Join Date
    Aug 2008
    Posts
    32
    Rep Power
    7

    Default OmniFocus Support (user+omnifocus@domain.com)

    Hi

    I'm using omnifocus as my GTD Manager and it supports creating tasks out of emails.
    Is does this in the way of listening for emails which contain a +omnifocus in front of the @ sign, e.g. john+omnifocus@acme.com.

    Is there any way I can configure Zimbra to allow such email addresses and basically ignore the "+omnifocus" completely?

    Thanks

    Andre

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Code:
    su zimbra 
    zmprov mcf zimbraMtaRecipientDelimiter + 
    zmcontrol stop
    zmcontrol start
    If you forward from Zimbra please be aware of Bug 10012 - Address Delimiter Breaks Forwarding (but there is a possible solution in that bug, which is to remove virtual from propagate_unmatched_extensions). We plan to adjust the default setting in GnR.

    Remove from main.cf.in or:
    Code:
    su - zimbra
    postconf -e propagate_unmatched_extensions=canonical
    postfix reload

  3. #3
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Should note that won't automatically create tasks, see if there's an RFE open in bugzilla on it.

    Was simply addressing your question:
    Quote Originally Posted by f0rd42 View Post
    Is there any way I can configure Zimbra to allow such email addresses and basically ignore the "+omnifocus" completely?
    That will also allow you to recive as user+whatever@domain.com - the user will see it in the msg header area, but for all intensive purposes is unaffected.

    If it's just +omnifocus that you want to allow and no others, might read through: Postfix Address Rewriting
    Last edited by mmorse; 04-08-2009 at 02:08 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 04:42 PM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  4. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 09:19 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •