Results 1 to 10 of 10

Thread: deferred mail and spam

  1. #1
    dotslashroot is offline Intermediate Member
    Join Date
    Apr 2006
    Posts
    23
    Rep Power
    9

    Default deferred mail and spam

    Hello, I just upgraded from 3.0 to 3.1 on FC4 with no errors or problems. The only thing I see is I had to run the ssh key commands to get the queue monitor to work. My question is this. I see email being deferred. It is all mail I sent to the same person outside the network. It gives no reason in the gui why it is defered. I tried to flush them and it still is deferred. I used to be able to send him mail. His mail server is up and functioning properly. The reverse lookup using 'host <ip>' resolves properly to my mail server. Any ideas?

    Also, is there a way to view the messages that are being filtered out as spam as the admin? I want to be able to see the messages and keep track of how it's working etc. How can I view them without logging in as each individual user?

    Thanks for your help!

  2. #2
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Check /var/log/zimbra.log
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    dotslashroot is offline Intermediate Member
    Join Date
    Apr 2006
    Posts
    23
    Rep Power
    9

    Default

    I don't see anything that looks like an error sending the mail. The only weird thing I see is this:


    May 4 04:02:31 dotslashroot postfix/smtpd[22653]: initializing the server-side TLS engine
    May 4 04:02:31 dotslashroot postfix/smtpd[22653]: connect from localhost.localdomain[127.0.0.1]
    May 4 04:02:32 dotslashroot postfix/trivial-rewrite[22543]: warning: do not list domain dotslashroot.net in BOTH mydestination and virtual_mailbox_domains
    May 4 04:02:32 dotslashroot postfix/trivial-rewrite[22543]: warning: do not list domain dotslashroot.net in BOTH mydestination and virtual_mailbox_domains


    Still no answer as to why it is deferred. Thanks for your help.

  4. #4
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Did you edit any of the postfix config manually? If not post the entire log of your test. Might be something missing that you trimmed out.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #5
    dotslashroot is offline Intermediate Member
    Join Date
    Apr 2006
    Posts
    23
    Rep Power
    9

    Default

    I didn't edit anything manually. I found the deferred problem. My server got put on CBL because of the localhost.localdomain header we were talking about in my other post. I delisted the IP on their web site. How do I get rid of that part of the header so we do not get listed again? Also, what does the error message I posted above mean? Do I need to change something? Thanks!

  6. #6
    dotslashroot is offline Intermediate Member
    Join Date
    Apr 2006
    Posts
    23
    Rep Power
    9

    Default

    I edited the header_checks file and added:

    #Dropping private headers
    #/^Header: IfContains/ IGNORE
    /^Received: from localhost/ IGNORE
    /^Received: 127.0.0.1 .*/ IGNORE
    /^User-Agent:/ IGNORE
    /^X-Mailer:/ IGNORE
    /^X-Originating-IP:/ IGNORE

    Nothing changed. It isn't using this file the way it looks. I changed main.cf and pointed it to this file and when I restarted Zimbra is changed it back to the original line:

    header_checks = pcre:/opt/zimbra/conf/postfix_header_checks

    There is no postfix_header_checks file. There is a header_checks file so I changed main.cf to pont to that file and zimbra changed it back when I started it. How can I get this to work so I can clean up our headers? Thanks!

  7. #7
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Still not sure you need this but there should be a template file that is generated for main.cf. Just having localhost in your header should trigger a listing unless your a source of spam etc.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  8. #8
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Or even easier just create this file:

    /opt/zimbra/conf/postfix_header_checks
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  9. #9
    dotslashroot is offline Intermediate Member
    Join Date
    Apr 2006
    Posts
    23
    Rep Power
    9

    Default

    ok when I used vi for that file it was there...must have been hidden. It has an if statement for blocking exe and mp3 attachments. The commands I have do not work. Is there a sample file I can use somewhere?

  10. #10
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Quote Originally Posted by dotslashroot
    ok when I used vi for that file it was there...must have been hidden. It has an if statement for blocking exe and mp3 attachments. The commands I have do not work. Is there a sample file I can use somewhere?

    Not that I know of. It's not something we've need to do before.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Howto setup TLS usage with upstream MTA
    By markymarknz in forum Installation
    Replies: 3
    Last Post: 10-21-2008, 11:49 AM
  2. Forward mail & spam question
    By pfschmidt in forum Users
    Replies: 2
    Last Post: 04-10-2007, 05:53 PM
  3. Gotta figure out how to deliver mail without spam scan
    By alimovz in forum Administrators
    Replies: 2
    Last Post: 02-20-2007, 11:27 PM
  4. All mail from Yahoo marked as spam and bounced
    By greywolf in forum Administrators
    Replies: 3
    Last Post: 02-18-2007, 02:30 PM
  5. Help needed to setup up third party Antivirus scanning
    By curious_guy in forum Installation
    Replies: 1
    Last Post: 10-01-2006, 06:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •