Results 1 to 2 of 2

Thread: Remote IMAP create MYSQL Error

  1. #1
    bens750 is offline Trained Alumni
    Join Date
    May 2006
    New York, NY
    Rep Power

    Default Remote IMAP create MYSQL Error


    I'm currently running a split-server setup (smtp, mailbox, ldap) on
    Release 5.0.13_GA_2792.RHEL4_20090206100559 RHEL4 NETWORK edition

    There is a user that is experiencing an issue when adding a Remote IMAP Server, nothing too special about it -
    No TLS
    No Changed Port
    Username: domain\user
    Folder Redirected to: RPD Warehouse

    But when attempting to "Get External Mail" Zimbra is dumping an unhandled Exception.

    The account is at ~50% quote use

    Any Ideas?



    2009-03-26 13:21:24,576 INFO [btpool0-4431] [;mid=231;ip=72.48.XXX.XXX; ds=RPD Warehouse;ua=ZimbraWebClient - FF3.0 (Win)/5.0.13_GA_2792.RHEL4;] datasource - Found new remote folder Public Folders/Human Resources/Merchandising Mgr.. Creating local folder /RPD Warehouse/Public Folders/Human Resources/Merchandising Mgr..
    2009-03-26 13:21:24,630 INFO [btpool0-4431] [;mid=231;ip=72.48.XXX.XXX; ds=RPD Warehouse;ua=ZimbraWebClient - FF3.0 (Win)/5.0.13_GA_2792.RHEL4;] datasource - Import completed for data source 'RPD Warehouse'
    2009-03-26 13:21:24,630 INFO [btpool0-4431] [;mid=231;ip=72.48.XXX.XXX; ds=RPD Warehouse;ua=ZimbraWebClient - FF3.0 (Win)/5.0.13_GA_2792.RHEL4;] SoapEngine - handler exception
    com.zimbra.common.service.ServiceException: system failure: Unable to store IMAP message data
    at com.zimbra.common.service.ServiceException.FAILURE (
    at com.zimbra.cs.db.DbImapFolder.createImapFolder(DbI
    at com.zimbra.cs.account.DataSource.createImapFolder(
    at com.zimbra.cs.datasource.ImapImport.importData(Ima
    at com.zimbra.cs.datasource.DataSourceManager.importD ata(
    at com.zimbra.cs.datasource.DataSourceManager.importD ata(
    at com.zimbra.cs.service.mail.ImportData.handle(Impor
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:286)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:160)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:269)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se
    at org.mortbay.jetty.handler.ContextHandler.handle(Co
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(
    at org.mortbay.jetty.handler.HandlerCollection.handle (
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.Server.handle(
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt
    at org.mortbay.jetty.HttpConnection$ ntent(
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:644)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec
    at org.mortbay.thread.BoundedThreadPool$ n(
    Caused by: com.mysql.jdbc.exceptions.MySQLIntegrityConstraint ViolationException: Duplicate entry '231-67967' for key 1

    Query being executed when exception was thrown:

    com.mysql.jdbc.ServerPreparedStatement[16594] - INSERT INTO mboxgroup31.imap_folder (mailbox_id, item_id, data_source_id, local_path, remote_path, uid_validity) VALUES (231, 67967, '51800357-9a9f-481a-a15c-6b48d39a5099', '/RPD Warehouse/Public Folders/Human Resources/Merchandising Mgr.', 'Public Folders/Human Resources/Merchandising Mgr.', 81)
    at com.mysql.jdbc.SQLError.createSQLException(SQLErro
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.ja va:2870)
    at com.mysql.jdbc.MysqlIO.sendCommand( 73)
    at com.mysql.jdbc.ServerPreparedStatement.serverExecu te(
    at com.mysql.jdbc.ServerPreparedStatement.executeInte rnal(
    at com.mysql.jdbc.PreparedStatement.executeUpdate(Pre
    at com.mysql.jdbc.PreparedStatement.executeUpdate(Pre
    at com.mysql.jdbc.PreparedStatement.executeUpdate(Pre
    at org.apache.commons.dbcp.DelegatingPreparedStatemen t.executeUpdate( 33)
    at com.zimbra.cs.db.DbImapFolder.createImapFolder(DbI
    ... 35 more

  2. #2
    bens750 is offline Trained Alumni
    Join Date
    May 2006
    New York, NY
    Rep Power


    Bumpity Bump, Any ideas?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Moving Zimbra to a new server
    By krolen in forum Administrators
    Replies: 109
    Last Post: 02-05-2009, 11:38 AM
  2. [SOLVED] Debian Etch 32 / 64: MTA not working
    By xflip in forum Installation
    Replies: 2
    Last Post: 01-18-2008, 04:58 AM
  3. Postfix problem
    By jimbo in forum Administrators
    Replies: 46
    Last Post: 07-23-2007, 05:24 AM
  4. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 09:19 AM
  5. Cannot determine services - exiting
    By tawas in forum Installation
    Replies: 7
    Last Post: 04-25-2006, 02:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts