Results 1 to 8 of 8

Thread: zimbra open source 5.0.14 and java?

  1. #1
    aurfalien is offline Senior Member
    Join Date
    Jan 2009
    Posts
    65
    Rep Power
    6

    Default zimbra open source 5.0.14 and java?

    Hi all,

    I upgraded from 5.0.12 to 5.0.14 and am now seeing that my box takes twice as long to finish booting.

    Java now seems to take up 100% of my cpu for 2-3 minutes and then all is well.

    What I run;

    RHEL 5.3 (2.6.18-128.1.1)
    Zimbra open source 5.0.14
    Java 1.4.2

    Zimbra seems to be working normally but I just find the new behavior odd.

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    How much memory does your server have ? Could you post the following to help us understand your environment
    Code:
    top
    freemem
    cat /proc/meminfo

  3. #3
    aurfalien is offline Senior Member
    Join Date
    Jan 2009
    Posts
    65
    Rep Power
    6

    Default

    hi uxbod,

    4GB mem
    Dual proc 64 bit at 3GHz

    /proc/meminfo;

    MemTotal: 4194304 kB
    MemFree: 2799508 kB
    Buffers: 29368 kB
    Cached: 580332 kB
    SwapCached: 0 kB
    Active: 912948 kB
    Inactive: 323972 kB
    HighTotal: 0 kB
    HighFree: 0 kB
    LowTotal: 4194304 kB
    LowFree: 2799508 kB
    SwapTotal: 2048276 kB
    SwapFree: 2048276 kB
    Dirty: 364 kB
    Writeback: 0 kB
    AnonPages: 627216 kB
    Mapped: 69096 kB
    Slab: 25048 kB
    PageTables: 14872 kB
    NFS_Unstable: 0 kB
    Bounce: 0 kB
    CommitLimit: 4145428 kB
    Committed_AS: 3524896 kB
    VmallocTotal: 34359738367 kB
    VmallocUsed: 3140 kB
    VmallocChunk: 34359735227 kB

  4. #4
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Out of curiosity what do you have running Java 1.4.2?
    (ZCS 5.0.14 includes JDK 1.5.0_17-b04)

  5. #5
    aurfalien is offline Senior Member
    Join Date
    Jan 2009
    Posts
    65
    Rep Power
    6

    Default

    Thats a good question.

    Nothing really, it only appeared after the 5.0.14 install so I assumed that it was part of some Zimbra need.

    ps output, filtered for java.

    /opt/zimbra/libexec/zmmailboxdmgr start -Xms1638m -Xmx1638m -client -XX:NewRatio=2 -Djava.awt.headless=true -XX:MaxPermSize=128m -XX:SoftRefLRUPolicyMSPerMB=1 -Xss256k


    /opt/zimbra/java/bin/java -Xms1638m -Xmx1638m -client -XX:NewRatio=2 -Djava.awt.headless=true -XX:MaxPermSize=128m -XX:SoftRefLRUPolicyMSPerMB=1 -Xss256k -Djava.io.tmpdir=/opt/zimbra/mailboxd/work -Djava.library.path=/opt/zimbra/lib -Djava.endorsed.dirs=/opt/zimbra/mailboxd/common/endorsed -Dzimbra.config=/opt/zimbra/conf/localconfig.xml -Djetty.home=/opt/zimbra/mailboxd -DSTART=/opt/zimbra/mailboxd/etc/start.config -jar /opt/zimbra/mailboxd/start.jar /opt/zimbra/mailboxd/etc/jetty.properties /opt/zimbra/mailboxd/etc/jetty-setuid.xml /opt/zimbra/mailboxd/etc/jetty.xml
    Last edited by aurfalien; 03-23-2009 at 01:05 PM.

  6. #6
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Is that a java installed elsewhere? ZCS uses: /opt/zimbra/ls -la | grep java
    (Should point to /opt/zimbra/jdk1.5.0_17)

  7. #7
    aurfalien is offline Senior Member
    Join Date
    Jan 2009
    Posts
    65
    Rep Power
    6

    Default

    You are right, I just did a java --version as root.

    The java that is causing serious cpu usage upon boot is the Zimbra java.

    I appended my earlier post with some ps info.

  8. #8
    aurfalien is offline Senior Member
    Join Date
    Jan 2009
    Posts
    65
    Rep Power
    6

    Default

    Any updates on this?

    Zimbra now takes 3 times as long to start due to Zimbra Java.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 01-20-2009, 01:06 PM
  2. zmperditionctl start asking for password
    By k7sle in forum Administrators
    Replies: 32
    Last Post: 02-20-2008, 11:13 AM
  3. Cleanup after many upgrades
    By tobru in forum Installation
    Replies: 1
    Last Post: 12-23-2007, 09:21 AM
  4. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 11:16 AM
  5. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 01:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •