Results 1 to 9 of 9

Thread: forward submain

  1. #1
    sperkins is offline Senior Member
    Join Date
    Apr 2006
    Location
    France
    Posts
    56
    Rep Power
    9

    Default forward submain

    Hello,

    A small problem since migration : we have a domain (foo.com) and the account support@foo.com is redirected to another server (helpdesk software) on a subdomain : @support.foo.com.

    Redirection is done using dns/mx (on the zimbra server).

    Now if I use classic linux mail on the zimbra server (support@foo.com) it get's there ! But if I add the entry support@support.foo.com to the forward element of the Zimbra account, it's my ISP smtp that tells me it's unknown.. considering that this is internal I quite agree It seems that Zimbra sends it out into the wild

    What am I doing wrong ?

    Many thanks

    Sebastian

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    Try adding the domain 'support.foo.com' in the admin console and then add an alias to one of the user accounts or a new account - that should do it.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    sperkins is offline Senior Member
    Join Date
    Apr 2006
    Location
    France
    Posts
    56
    Rep Power
    9

    Default forward subdomain

    I've tried but to no avail, If I use the alias, nothing happens. If I use the forward (.forward was used in the old postfix server) we get a "undeliverable" mail from the zimbra postfix bit.

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    Oops, sorry I misread your post. I thought you were accepting the subdomain on the Zimbra server not forwarding it.

    In that case, do you have a DNS record pointing to the subdomain on another server? I would guess that you're having a problem because zimbra can't resolve the subdomain name.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    sperkins is offline Senior Member
    Join Date
    Apr 2006
    Location
    France
    Posts
    56
    Rep Power
    9

    Default

    Yep, no problem there, dig and nslookup are pointing MX and A pointers to the correct internal server.

    If I use mail from shell on the zimbra... it arrives just fine.

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    In the admin panel, do you have 'use DNS lookup' enabled (I guess you do)? Is all your other mail being delivered correctly from/to the zimbra server?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    sperkins is offline Senior Member
    Join Date
    Apr 2006
    Location
    France
    Posts
    56
    Rep Power
    9

    Default

    DNS lookup is checked. Mail is being sent/received no problem... it's just this tiny little subdomain redirect which doesn't work.

    Am I right in using the forward ?

  8. #8
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    I see no reason why you shouldn't use the forward. I can only suggest that as it's not getting to it's destination then you have a DNS problem. Have a look at this page for the correct settings for a subbdomain.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    sperkins is offline Senior Member
    Join Date
    Apr 2006
    Location
    France
    Posts
    56
    Rep Power
    9

    Default

    OK sorry for the delay, but DNS is fine, but adding this worked

    /opt/zimbra/bin/zmprov ma maintenance zimbraMailTransport smtp:mail.mysubdomain.com

    thanks !

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Forward mail & spam question
    By pfschmidt in forum Users
    Replies: 2
    Last Post: 04-10-2007, 05:53 PM
  2. Order of precedence between Forward & Filter
    By Crexis in forum Installation
    Replies: 2
    Last Post: 06-19-2006, 11:07 PM
  3. Replies: 3
    Last Post: 05-12-2006, 04:19 PM
  4. Forward multiple emails
    By daniellawson in forum Users
    Replies: 1
    Last Post: 04-26-2006, 09:39 PM
  5. Forward | bounce message as a filter action
    By dfaulkner in forum Developers
    Replies: 3
    Last Post: 02-23-2006, 11:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •