Hello,
I managed to migrate my Zimbra server with all userdata from Fedora Core 7 to Debian 4.0.
The main procedure is documented very well (for example here), but there appeared two problems:
I had to install "file" manually ("apt-get install file", already documented in other threads). This was easily done
The bigger problem where I found no documentation about: The Zimbra FC7 build wants to use glibc 2.4 which is on Debian not available.
So when I deleted the "dummy" install on the new server, moved the old /opt/zimbra directory in place and tried to reinstall i got errors like this one:
Code:
/opt/zimbra/openldap/sbin/slapcat: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /opt/zimbra/openldap/sbin/slapcat)
... to fix this, i replaced all files placed in /opt/zimbra/*/bin, /opt/zimbra/*/sbin, /opt/zimbra/*/lib with files from the Debian package, then the reinstall worked.
So here comes my question: Would there have been an easier way to make this ?