Results 1 to 8 of 8

Thread: Stats problems!!

  1. #1
    mmike is offline Active Member
    Join Date
    Feb 2006
    Posts
    36
    Rep Power
    9

    Default Stats problems!!

    On my server, the stats seems to be corrupt or something like that.
    For the "Message Volume" tab, the "Last 48 hours" and "Last 30 days" graph shows 400 mails but "Last 60 days" and "Last 365 days" show only 3 messages.

    For the "Message Count" tab, the "Last 48 hours" and "Last 30 days" graph shows 80M but "Last 60 days" and "Last 365 days" show only 28K.

    For the "Disk" tab, disk total is set to 15K (and I have more than 70GB).

    Well How to reset stats and run them correctly?

    For internal mails, should I have Mail Queues refreshed? Because since two weeks that my ZIMBRA server is running, the mail queue list are all to 0! It is normal?

    Thanks

    Mike

    NOTE: I'm running ZIMBRA under RHES4, no local DNS is installed but a valid DNS is used by ZIMBRA server.
    Last edited by mmike; 04-28-2006 at 05:15 AM.

  2. #2
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Does the server name match the real host name? ie the name you see when your in the admin ui vs the one returned from `hostname`.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    mmike is offline Active Member
    Join Date
    Feb 2006
    Posts
    36
    Rep Power
    9

    Default

    Yes it matches!
    the hostname command: svr.dmz.example.com
    and the admin console : svr.dmz.example.com

    I don't understand where is the problem...

    Mike

  4. #4
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    The disk problem may be thie bug:

    http://bugzilla.zimbra.com/show_bug.cgi?id=7072

    Not sure on the other two.. Maybe you'll want to look at zmgengraph which is the tool that makes them.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #5
    mmike is offline Active Member
    Join Date
    Feb 2006
    Posts
    36
    Rep Power
    9

    Default

    in the zimbra.log, I found this:

    2006-05-02 13:41:24,271 ERROR [{RemoteManager: svr6.dmz.hotel.ch->zimbra@svr.dmz.example.com:22}-zmqstat corrupt] [] rmgmt - error scanning com.zimbra.cs.rmgmt.RemoteMailQueue$QueueHandler@7 7d7ba: ERROR: Unknown command: zmqstat

    And "zmqstat" command doesn't exist as "zmgengraph"!!

  6. #6
    mmike is offline Active Member
    Join Date
    Feb 2006
    Posts
    36
    Rep Power
    9

    Default

    oups, I made a mistake:
    zmqstat and zmgengraphs are under /opt/zimbra/libexec.
    Is there manual pages about zmgengraphs?

  7. #7
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Quote Originally Posted by mmike
    Is there manual pages about zmgengraphs?
    Nope.. just the code. You could try running it with sh -X just to see if it gets any errors.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  8. #8
    mstreet is offline Active Member
    Join Date
    Sep 2007
    Posts
    25
    Rep Power
    7

    Default Message Count for server - last 365 days

    The last graph in message count for 365 days still does not display any stats on the specific mail server stats section, it does display for the system wide however. This really hasn't bothered me since I went to 5.0.* but I thought I would bring it up again.

    If I run zmgengraphs it runs through without error.

    Generating hour graph for mta on mail.
    Generating hour graph for mta on mail.
    Generating day graph for mta on mail.
    Generating day graph for mta on mail.
    Generating month graph for mta on mail.
    Generating month graph for mta on mail.
    Generating year graph for mta on mail.
    Generating year graph for mta on mail.
    Generating hour graph for mta on penguin
    Generating hour graph for mta on penguin
    Generating day graph for mta on penguin
    Generating day graph for mta on penguin
    Generating month graph for mta on penguin
    Generating month graph for mta on penguin
    Generating year graph for mta on penguin
    Generating year graph for mta on penguin
    Generating hour graph for mta on ALL
    Generating hour graph for mta on ALL
    Generating day graph for mta on ALL
    Generating day graph for mta on ALL
    Generating month graph for mta on ALL
    Generating month graph for mta on ALL
    Generating year graph for mta on ALL
    Generating year graph for mta on ALL
    Generating hour graph for amavis on
    Generating day graph for amavis on
    Generating month graph for amavis on
    Generating year graph for amavis on
    Generating hour graph for amavis on penguin
    Generating day graph for amavis on penguin
    Generating month graph for amavis on penguin
    Generating year graph for amavis on penguin
    Generating hour graph for amavis on ALL
    Generating day graph for amavis on ALL
    Generating month graph for amavis on ALL
    Generating year graph for amavis on ALL
    Generating hour graph for disk on mail.
    Generating hour graph for disk on mail.
    Generating day graph for disk on mail.
    Generating day graph for disk on mail.
    Generating month graph for disk on mail.
    Generating month graph for disk on mail.
    Generating year graph for disk on mail.
    Generating year graph for disk on mail.
    Last edited by mstreet; 03-26-2008 at 04:48 PM.
    Mark Street, D.C., RHCE
    Chief Technology Officer
    Alliance Medical Center

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stats don't update
    By Doug_M in forum Administrators
    Replies: 33
    Last Post: 05-05-2007, 08:17 PM
  2. iSync Connector / Apple Address Book Problems
    By jrosen in forum CalDAV / CardDAV / iSync
    Replies: 11
    Last Post: 04-16-2007, 03:40 PM
  3. Mails accumulating in deferred queue
    By NIRMESH KUMAR in forum Administrators
    Replies: 10
    Last Post: 03-19-2007, 12:17 AM
  4. Web client logon fails (INVALID_PDU)
    By jermxx in forum Installation
    Replies: 8
    Last Post: 02-20-2007, 02:20 PM
  5. Tomcat broken after upgrade to 4
    By dotslashroot in forum Migration
    Replies: 13
    Last Post: 01-31-2007, 06:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •