Results 1 to 6 of 6

Thread: 5.0.13 breaks external IMAP SSL account

  1. #1
    Mike Scholes is offline Advanced Member
    Join Date
    Dec 2007
    Posts
    238
    Rep Power
    7

    Default 5.0.13 breaks external IMAP SSL account

    The upgrade from 5.0.10 seemed to go OK but my external account is broken, Even if I delete and recreate the account when I click Test I get the following error;

    Error: d2:CN21:mail.theraileng.co.uk1:O35:The Railway Engineering Company Ltd2:OU35:The Railway Engineering Company Ltd6:accept4:true5:alias38:mail.theraileng.co.uk:C D1FEDC255CFE8094:fromi1178723472000e4:host21:mail. theraileng.co.uk3:icn21:mail.theraileng.co.uk2:io3 5:The Railway Engineering Company Ltd3:iou35:The Railway Engineering Company Ltd3:md532:41D35AB432CCC8AF39FFD8C20FE597E78:misma tch5:false1:s16:CD1FEDC255CFE8094:sha140:788C8DCAC E5789376F1D895DA23450CF3FC531A72:toi1494083472000e e

    The external account runs Dovecot IMAP server and has been running fine until the upgrade.

  2. #2
    dweate is offline New Member
    Join Date
    Mar 2008
    Posts
    3
    Rep Power
    7

    Default

    I'm seeing the same thing since I upgraded to 5.0.13 under similar circumstances (external server is running Dovecot).

    Has anyone else seen this? Any ideas on a solution?

    Thanks.

  3. #3
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    zmlocalconfig -e data_source_trust_self_signed_certs = true

    (Or import into the keystore if it's a one time thing.)

    Bug 35441 - external data sources with self-signed/expired certs no longer work requesting a bypass prompt / data_source_trust_self_signed_certs_override_ allowed attribute (or we could re-use ssl_allow_accept_untrusted_certs) was closed as wontfix (I tried - your welcome to comment / vote for it) in favor of Bug 35892 - clean up error dialog for external data sources (just cleanup to fit / making that a better error message such as: "Self-signed or mismatched certs are currently not allowed - please contact your admin for further options").
    Last edited by mmorse; 03-06-2009 at 03:34 PM.

  4. #4
    dweate is offline New Member
    Join Date
    Mar 2008
    Posts
    3
    Rep Power
    7

    Default

    That did the trick.

    Thanks, Mike.

  5. #5
    Mike Scholes is offline Advanced Member
    Join Date
    Dec 2007
    Posts
    238
    Rep Power
    7

    Default

    Didn't fix it here...

    "Error: argument 'data_source_trust_self_signed_certs' not in key=value form"

  6. #6
    Mike Scholes is offline Advanced Member
    Join Date
    Dec 2007
    Posts
    238
    Rep Power
    7

    Default

    It's OK just removed the spaces either side of the "=" and restarted, load remote email now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Sudden problem synching with gmail
    By bouchardpie in forum Error Reports
    Replies: 8
    Last Post: 09-09-2010, 09:50 AM
  2. Error using Zimbra Desktop with all folders
    By randhirv in forum Error Reports
    Replies: 3
    Last Post: 01-24-2009, 01:01 AM
  3. E61i IMAP sync - old bug back again?
    By matt_b in forum Zimbra Mobile
    Replies: 7
    Last Post: 08-10-2008, 02:38 PM
  4. problem importing external IMAP account
    By eleith in forum Administrators
    Replies: 0
    Last Post: 08-05-2008, 01:11 PM
  5. IMAP problem after added external account
    By Thanakorn in forum Administrators
    Replies: 5
    Last Post: 02-21-2008, 10:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •