Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Still Cannot Send Emails to Yahoo

  1. #11
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    I use my upstream ISP as a smarthost so have never had a issue.

  2. #12
    dfriestedt is offline Senior Member
    Join Date
    Jul 2007
    Posts
    72
    Rep Power
    7

    Default

    Still trying to resolve this....

    I did the following:

    Open /opt/zimbra/amavisd/sbin/amavisd

    Find:
    $append_header_fields_to_bottom
    $prepend_header_fields_hdridx
    $remove_existing_x_scanned_headers
    $remove_existing_spam_headers

    Make sure they are all set to 0 [zero] and the Amavis headers should be gone after you restart the MTA.

    (this mod did nothing... Everything was already set to 0 except $remove_existing_spam_headers)
    and

    In "/opt/zimbra/conf/postfix_header_checks.in" I added:

    Code:

    /^Received: from .+\..+\.domain\.com .+(by zimbra\.domain\.com .+) / REPLACE Received: $1

    This mod produced the following error when I stopped and started the MTA

    PHP Code:
    Stopping zmmtaconfig...done.
    postfix/postfix-scriptstopping the Postfix mail system
    Stopping saslauthd
    ...^[[Adone.
    zimbra@mail:/rootzmmtactl start
    Rewriting configuration files
    ...done.
    Starting zmmtaconfig...done.
    postmapwarning: /opt/zimbra/conf/postfix_header_checks.9GdvcRline 5record is in "key: value" formatis this an alias file?
    postfix/postfix-scriptwarningnot owned by root: /opt/zimbra/postfix-2.4.7.5z/conf/main.cf
    postfix
    /postfix-scriptstarting the Postfix mail system
    Starting saslauthd
    ...done
    And the last mod did not strip out the headers. thoughts???
    Last edited by dfriestedt; 01-30-2009 at 06:52 PM.

  3. #13
    dfriestedt is offline Senior Member
    Join Date
    Jul 2007
    Posts
    72
    Rep Power
    7

    Default

    Just reviewed this post which is on the same topic - looks like they never resolved the problem.

    Changing localhost (localhost.localdomain [127.0.0.1]) in message headers

    I'm surprised more people are not concerned w/ this issue. I can't figure out how other zimbra admins are getting email through to yahoo.com w/out fixing this header issue.

  4. #14
    dfriestedt is offline Senior Member
    Join Date
    Jul 2007
    Posts
    72
    Rep Power
    7

    Default

    just wanted to close this loop on this... my inability to send email to yahoo had nothing to do with zimbra, or my setup. Both were fine. My colo gave me an IP that was simply black listed by yahoo (but it was not on any other public black list). So, I moved the server to a new IP and I can email yahoo no problem.

  5. #15
    dfriestedt is offline Senior Member
    Join Date
    Jul 2007
    Posts
    72
    Rep Power
    7

    Default

    We'll - turns out I was not able to solve this issue... I just moved Zimbra to a dedicated server and new IP. I thought the new IP resolved the issue, but I'm still having problems. mxlogic, hotmail, and yahoo all deliver my email to spam.

    RDNS is setup properly, I tried the header strip solution (which never acutally worked), SPF is setup and works properly...

    When I relay my mail through a DKIM signature box (iredmail) everything delivers fine to yahoo, hotmail, mylogic, etc.... I really think Zimbra should look into why this problem persists. From reading the forums lots of people are having this problem and they capitulate and "live with it" which is not an acceptable solution, in my mind.

    I guess I'll file a bug on this one.
    Last edited by dfriestedt; 03-25-2009 at 03:20 PM.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem with Sync of Send Email with yahoo
    By dragon74 in forum Error Reports
    Replies: 1
    Last Post: 01-08-2009, 11:06 PM
  2. Won't download Yahoo Premium emails
    By senyahel in forum General Questions
    Replies: 8
    Last Post: 08-28-2008, 03:52 PM
  3. yahoo cant send email to zimbra account.. Why ???
    By bageur in forum Administrators
    Replies: 7
    Last Post: 05-08-2008, 04:50 AM
  4. can't send email to yahoo
    By bageur in forum Installation
    Replies: 3
    Last Post: 11-23-2007, 01:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •