Results 1 to 8 of 8

Thread: Help Postfix ?????

  1. #1
    leandrochacha is offline Junior Member
    Join Date
    Jan 2008
    Posts
    9
    Rep Power
    7

    Default Help Postfix ?????

    Help....?????

    A little hand with postfix and zcs single mode

    I would like to know if is possible use postfix separeted of zcs, I've a single zcs server, how can I make that postfix transport my emails to the rigth mailbox in zimbra.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Default

    Quote Originally Posted by leandrochacha View Post
    I would like to know if is possible use postfix separeted of zcs, I've a single zcs server,
    What do you mean by that?

    Quote Originally Posted by leandrochacha View Post
    how can I make that postfix transport my emails to the rigth mailbox in zimbra.
    It will send the email to the correct mailbox.

    What is it you're trying to achieve and what problem are you having?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    leandrochacha is offline Junior Member
    Join Date
    Jan 2008
    Posts
    9
    Rep Power
    7

    Thumbs up Postfix + postfix_transport_maps

    I have a server postfix and a zimbra server in separated machines, I'm trying to make the integration of zimbra server with my postfix to send and recive emails at my zimbra server, I already tried to set "postfix_transport_maps" with this tutorial of zimbra giving this error "file /opt/zimbra/log/zmmailboxd.pid does not exist"

    can you help me ?

    Thanks

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Default

    Why don't you just migrate the postfix server to Zimbra and just use one mail server? If you have both servers on the same domain then this may help.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    leandrochacha is offline Junior Member
    Join Date
    Jan 2008
    Posts
    9
    Rep Power
    7

    Default error

    Was done as the tutorial, but presented the following errors.

    tail -f /var/log/zimbra-log

    postfix/proxymap[18609]: fatal: open /conf/ldap-transport.cf: No such file or directory

    send message ZCS.

    msg: system failure: MessagingException
    code: service.FAILURE
    method: SendMsgRequest
    detail: soap:Receiver
    trace: btpool0-12:1232997060613:6dae0262979f4411


    Thanks!

  6. #6
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Zimbra has not installed correctly. Please check /tmp for setup logs and post them. This maybe because Postfix is already running and your DNS may not be correct so aswell please post
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes

  7. #7
    leandrochacha is offline Junior Member
    Join Date
    Jan 2008
    Posts
    9
    Rep Power
    7

    Default Commands

    In the machine that the Zimbra is installed I have:

    # cat /etc/hosts
    127.0.0.1 localhost
    192.168.100.113 plutao01.com.br.intra.plutao.com.br plutao01.com.br
    192.168.100.106 plutao.com.br.intra.plutao.com.br plutao.com.br


    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts

    The other one:

    # cat /etc/resolv.conf
    nameserver 192.168.100.108

    (This IP is about our internal Firewall with OpenBSD.)

    # dig plutao.com.br mx

    ; <<>> DiG 9.4.2 <<>> plutao.com.br mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 65487
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;plutao.com.br. IN MX

    ;; AUTHORITY SECTION:
    plutao.com.br. 259200 IN SOA plutao.intra.plutao.com.br.plutao.com.br. plutao.intra.plutao.com.br. 20081128 10800 3600 3600000 259200

    ;; Query time: 9 msec
    ;; SERVER: 192.168.100.108#53(192.168.100.108)
    ;; WHEN: Mon Jan 26 17:41:21 2009
    ;; MSG SIZE rcvd: 107


    # dig plutao.com.br any

    ; <<>> DiG 9.4.2 <<>> plutao.com.br any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 55738
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;plutao.com.br. IN ANY

    ;; ANSWER SECTION:
    plutao.com.br. 604800 IN SOA plutao.intra.plutao.com.br.plutao.com.br. plutao.intra.plutao.com.br. 20081128 10800 3600 3600000 259200
    plutao.com.br. 604800 IN NS ns1.plutao.com.br.

    ;; ADDITIONAL SECTION:
    ns1.plutao.com.br. 604800 IN A 192.168.100.108

    ;; Query time: 0 msec
    ;; SERVER: 192.168.100.108#53(192.168.100.108)
    ;; WHEN: Mon Jan 26 17:43:29 2009
    ;; MSG SIZE rcvd: 141


    # host `hostname`
    Host plutao01.com.br not found: 3(NXDOMAIN)

    These are all the commands.

    Thanks a lot for the help.

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Default

    You need to fix your hosts file, check the Quick Start Installation Guide for details then fix your DNS with the Split DNS article.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. postdrop fail to create file after upgrade to 5.0.3
    By echoadisan in forum Installation
    Replies: 23
    Last Post: 07-15-2013, 03:02 PM
  2. Correct Postfix Startup Info
    By mlissner in forum Installation Help
    Replies: 5
    Last Post: 10-31-2008, 01:08 PM
  3. [SOLVED] CentOS 5 zcs-NETWORK-5.0.8_GA_2462.RHEL5_64
    By dazedandconfused in forum Administrators
    Replies: 7
    Last Post: 07-28-2008, 12:15 PM
  4. 5.0 RC1: admin interface: no statistics, no mail queue
    By christian.kieft in forum Administrators
    Replies: 1
    Last Post: 11-13-2007, 09:22 AM
  5. Replies: 3
    Last Post: 11-03-2007, 10:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •