Results 1 to 3 of 3

Thread: SMTP auth for relay

  1. #1
    garyo is offline Active Member
    Join Date
    Sep 2008
    Location
    Cambridge, MA
    Posts
    41
    Rep Power
    6

    Default SMTP auth for relay

    I'm running Zimbra 5.0.11 on Ubuntu, Network Edition. I have mobile users who want to use our Zimbra MTA to relay mail to 3rd party destinations using SMTP auth. I believe I have it set up right per the various forum postings:

    zimbra@mail:~$ zmprov getServer mail.example.com|grep Auth
    zimbraMtaAuthEnabled: TRUE
    zimbraMtaAuthHost: mail.example.com
    zimbraMtaAuthTarget: TRUE
    zimbraMtaAuthURL: https://mail.example.com:443/service/soap/
    zimbraMtaTlsAuthOnly: TRUE

    When I try to use it though, as soon as I specify the mail recipient I get RENEGOTIATING from the smtp server, and no error. (I typically do this using openssl s_client -connect mail.example.com:465 so I can see the details of the SMTP conversation.)

    Here's what I see:

    220 mail.example.com ESMTP Postfix
    EHLO garyo
    250-mail.example.com
    250-PIPELINING
    250-SIZE 30720000
    250-VRFY
    250-ETRN
    250-AUTH PLAIN LOGIN
    250-AUTH=PLAIN LOGIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    AUTH LOGIN
    334 ......
    .....
    334 .....
    .....
    235 2.0.0 Authentication successful
    MAIL FROM: garyo@somewhere.example.com
    250 2.1.0 Ok
    RCPT TO: someone@thirdparty.example.com
    RENEGOTIATING
    depth=3 /L=ValiCert Validation Network/O=ValiCert, Inc./OU=ValiCert Class 2 Policy Validation Authority/CN=http://www.valicert.com//emailAddress=info@valicert.com
    verify error:num=19:self signed certificate in certificate chain
    verify return:0


    This is weird because first, why does it say RENEGOTIATING when I've authenticated properly? And second, why does it say there is a self-signed cert in the chain? That's not true, it's a bog-standard GoDaddy cert.

    Any help?

    -- Gary

  2. #2
    ProTip is offline Junior Member
    Join Date
    Sep 2009
    Posts
    6
    Rep Power
    5

    Default

    After a recent Zimbra upgrade from 6.0.9 to 6.0.10, I'm now in the same boat. How did you get this issue resolved?

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by ProTip View Post
    After a recent Zimbra upgrade from 6.0.9 to 6.0.10, I'm now in the same boat. How did you get this issue resolved?
    Well, as the o/p has NE and is authenticating mobile users against his server and this thread is two years old olus you're on a different rlease of Zimbra - how is your issue the same?

    If your users want to relay through your server then they must use port 587 as the Submission port and that will require authentication. If you still get problems there are threads all over the forums that cover thos topic and you will need to give more information than 'it doesn't work', start with the log files for any errors.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Disable SMTP AUTH
    By arvind510 in forum Administrators
    Replies: 1
    Last Post: 09-29-2008, 07:49 AM
  2. [SOLVED] Force AUTH SMTP For Local/External Networks
    By the_griz in forum Administrators
    Replies: 1
    Last Post: 09-19-2008, 01:40 PM
  3. [SOLVED] NE Migration: SMTP AUTH Failure
    By markpr in forum Installation
    Replies: 14
    Last Post: 10-03-2007, 12:51 PM
  4. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  5. SMTP Auth error 535
    By FloydWilliams in forum Administrators
    Replies: 0
    Last Post: 01-04-2007, 02:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •