Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: cron witch user Zimbra not run

  1. #11
    davidpepe is offline Junior Member
    Join Date
    Jan 2009
    Posts
    9
    Rep Power
    6

    Default zimbra cron

    Ok! again can you see the script?

    #!/bin/bash

    FECHA=`date -d "a day ago" +%Y-%m-%d`
    mkdir -p /opt/zimbra/zmstat/$FECHA/chart
    opt/zimbra/bin/zmstat-chart -s /opt/zimbra/zmstat/$FECHA/ -d /opt/zimbra/zmstat/$FECHA/chart/

    I will probe the script modifing the owner on zimbra-chart...

  2. #12
    davidpepe is offline Junior Member
    Join Date
    Jan 2009
    Posts
    9
    Rep Power
    6

    Default zimbra cron

    Guys... he doesn't nothing... I change te permissions on zmstat-chart but it's equal...
    Only he create the directory "chart" but he is not run the command... I'm go back crazyyy now...je

  3. #13
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Check the cron log for a exit code or error.

  4. #14
    davidpepe is offline Junior Member
    Join Date
    Jan 2009
    Posts
    9
    Rep Power
    6

    Default zimbra cron

    In the cron log:
    Jan 15 11:57:01 server crond[7478]: (zimbra) CMD (/opt/zimbra/zmstat/repor-zimbra.sh)

    I have problem to resolve this...
    I will search others option to run the command...
    Thank you very much!!!!!

  5. #15
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Change the top of the script to be
    Code:
    #!/bin/bash -x
    that will show you what it happening as each command is executed.

  6. #16
    davidpepe is offline Junior Member
    Join Date
    Jan 2009
    Posts
    9
    Rep Power
    6

    Default

    Quote Originally Posted by uxbod View Post
    Change the top of the script to be
    Code:
    #!/bin/bash -x
    that will show you what it happening as each command is executed.
    change to #!/bin/bash -x...nothing...

  7. #17
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Code:
    opt/zimbra/bin/zmstat-chart -s /opt/zimbra/zmstat/$FECHA/ -d /opt/zimbra/zmstat/$FECHA/chart/
    Your missing a / at the start of the command

  8. #18
    davidpepe is offline Junior Member
    Join Date
    Jan 2009
    Posts
    9
    Rep Power
    6

    Default

    Quote Originally Posted by uxbod View Post
    Code:
    opt/zimbra/bin/zmstat-chart -s /opt/zimbra/zmstat/$FECHA/ -d /opt/zimbra/zmstat/$FECHA/chart/
    Your missing a / at the start of the command
    Sorry, the line in the script it's:
    /opt/zimbra/bin/zmstat-chart -s /opt/zimbra/zmstat/$FECHA/ -d /opt/zimbra/zmstat/$FECHA/chart/
    Thank you!!

  9. #19
    fab
    fab is offline Active Member
    Join Date
    Oct 2008
    Posts
    38
    Rep Power
    6

    Default

    Same problem here, I have put in the zimbra user's crontab
    0/30 * * * * /opt/zimbra/bin/zmstat-chart -s /opt/zimbra/zmstat -d /var/log/zimbra/zmstat-charts
    but it does nothing.
    The destination dir has the proper owner and permissions.

  10. #20
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    It would help if you updated your profile with the following output so we know which version of ZCS you are running
    Code:
    su - zimbra
    zmcontrol -v
    And for reference if you are on ZCS V6 have you read the release note ?

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 22
    Last Post: 12-02-2007, 05:05 PM
  2. Error loading on Mac OS X 10.4.10 server PPC
    By qprcanada in forum Installation
    Replies: 7
    Last Post: 10-26-2007, 06:25 AM
  3. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  4. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 10:39 AM
  5. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 11:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •