Results 1 to 7 of 7

Thread: zmmailboxdctl is not running

  1. #1
    yoom@hostwebase.com is offline Active Member
    Join Date
    Jan 2008
    Posts
    26
    Rep Power
    7

    Wink URGENT NEED - zmmailboxdctl is not running

    Update:
    I found the errors in the zmmailboxd.out but do not know how to fix it.

    It said:
    Zimbra server reserving server socket port=7110 bindadd=192.17.230.196 ssl=false
    Fatal error. exception while binding to ports.

    Java.net.BindException: cannot assign requested adddress

    It sounds like I have to remove the above entries that had written into the LDAP or mysql database.


    Thanks in advance for helping.

    Y.









    I really need help to fix this "zmmailboxdctl is not running" problem.
    I am running Redhat and Zimbra 5.0.45.


    I did two thing last night that contribute to the problem I having now.

    First thing 1.
    While I was making a change to the pop3 section for server name and IP address, as I make the change via the Zimbra GUI (console) the Zimbra
    cronjob was stop and restart via zmcrontrol stop and zmcontrol start.

    Since then I get this error "zmmailboxdctl is not running" and am not able to
    figure out how to fix this problem.

    ***Here is the error log under /opt/zimbra/db/data/server-name.err
    InnoDB: Database was not shutdown normally:
    starting crash recovery
    reading tablespace information from the .idb files
    restoring pissible half-written data pages from the doublewrite

    InnoDB: starting log scan based on checkpoint at
    log sequence number 0 1580809818
    doing revovery: scanned up to log sequence number 0 1580809818
    5.0.45
    *********

    Second thing 2.
    I did add a second IP address to the /etc/hosts file
    but I have remove it and copy the orginal file to /etc/hosts


    How am I going about fixing this problem.
    I did try to disable the imapproxy and pop3proxy with this syntax
    zmprov ms localhost -zimbraServiceDisable imapproxy
    zmprov ms server.domain.com -zimbraServiceDisable imapproxy
    zmprov ms localhost -zimbraServiceDisable popproxy

    but getting this error: zclient,IO_error (ivoke connection refused, server: localhost) (cause: java.net.connectionException connection refused)

    Sounds like a mysql access problem??



    I have spend many hours on this issues and still not able to find a solution yet. Can any of you help please.


    Thank you in advance.

    Y
    Last edited by yoom@hostwebase.com; 01-07-2009 at 07:41 AM. Reason: additional informaton

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    I gather there were no further mysql errors/it recovered nicely, I assume your a single server/don't need the proxy.
    Also the command isn't zimbraServiceDisable it's zimbraServiceEnabled with a minus sign on the front, and you can provision via mailboxd as it's down so run it via ldap (-l), the port setting command is all on one line.
    zmprov -l ms server.domain.com -zimbraServiceEnabled imapproxy

    zmprov -l ms server.domain.com zimbraPop3BindPort 110 zimbraPop3SSLBindPort 995 zimbraPop3ProxyBindPort 7110 zimbraPop3SSLProxyBindPort 7995 zimbraImapBindPort 143 zimbraImapSSLBindPort 993 zimbraImapProxyBindPort 7143 zimbraImapSSLProxyBindPort 7993

    zmcontrol stop
    zmcontrol start

  3. #3
    yoom@hostwebase.com is offline Active Member
    Join Date
    Jan 2008
    Posts
    26
    Rep Power
    7

    Default still not work

    Mike,

    First of all, thank you so much replying to my questions/issues.

    I have tried what you had sugguested and it still said:
    zmmailboxdctl is not running and this time the clamd will not able
    to start as well.

    My server IP address is 192.168.0.100
    and the bind error with IP address 192.17.230.196 below is not exit on my server. How can I modify that IP address to point to my actual IP address
    192.168.0.100? Is this entry written to LDAP or Tomcat's .xml configuration somewhere?


    It said:
    Zimbra server reserving server socket port=7110 bindaddr=192.17.230.196 ssl=false
    Fatal error. exception while binding to ports.


    Thanks,
    Y

  4. #4
    yoom@hostwebase.com is offline Active Member
    Join Date
    Jan 2008
    Posts
    26
    Rep Power
    7

    Default



    How can I modify a bindaddr attribute? IP address to point to my actual IP address 192.168.0.100 instead of the wrong one?


    It said:
    Zimbra server reserving server socket port=7110 bindaddr=192.17.230.196 ssl=false
    Fatal error. exception while binding to ports.


    Thanks,
    Y

  5. #5
    yoom@hostwebase.com is offline Active Member
    Join Date
    Jan 2008
    Posts
    26
    Rep Power
    7

    Default Help

    Would someone able to tell me what is the syntax to add and remove
    an attribute for POP entry under the Network Section of the GUI
    with the Attribute: Advertise name:
    Address:
    via command line?


    I need to modify a bindaddr attribute? IP address to point to my actual IP address 192.168.0.100 instead of the 192.17.230.196?


    It said:
    Zimbra server reserving server socket port=7110 bindaddr=192.17.230.196 ssl=false
    Fatal error. exception while binding to ports.


    Thanks,
    Y

  6. #6
    yoom@hostwebase.com is offline Active Member
    Join Date
    Jan 2008
    Posts
    26
    Rep Power
    7

    Default will pay to Fix - zmmailboxdctl is not running

    1.
    Yes, after many months
    I am still need to get my old email off the old server.
    I do no have the time and do not know how to fix it.
    Would you someone want to fix the zmmailboxdctl problem for a fee?
    Please see all of my trailing posted messages.

    2.
    I also need a document on howto backup and restore Zimbra 6.0
    on a Linux RedHat AS 4.X as well.

    Please email me direct if you can help for a fees yoom@hostewebase.com

    Thank you.
    Y

  7. #7
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,492
    Rep Power
    56

    Default

    What does the output of the following command show:

    Code:
    zmprov gs `zmhostname` | grep BindAddress
    You can find details on backup scripts in the wiki: Backup and Restore Articles - Zimbra :: Wiki - there's also further details in the forums.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Outlook no longer updating
    By jeremy.pratt in forum Zimbra Connector for BlackBerry
    Replies: 10
    Last Post: 05-30-2008, 03:22 PM
  2. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 08:59 AM
  3. Can't seem to get global in BES
    By sdemeyer in forum Zimbra Connector for BlackBerry
    Replies: 12
    Last Post: 03-19-2008, 08:22 AM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  5. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •