Results 1 to 10 of 10

Thread: [SOLVED] Mail Transport Unavailable - Ubuntu 8.04

  1. #1
    Mccreations is offline Active Member
    Join Date
    Mar 2008
    Location
    Chicago, IL
    Posts
    49
    Rep Power
    7

    Default [SOLVED] Mail Transport Unavailable - Ubuntu 8.04

    Hey,

    Thanks for reading this, I need a little help.

    I have one main server and a firewall/modem. My firewall has always been setup to assign the server the public IP address and redirect all traffic to the server. For security reasons I wanted to change that, so I re-configured my firewall to assign the server a private IP address and block all traffic. I then created a rule for all zimbra ports, so all of the mail ports are open.

    But after the change to a private IP address I can no longer receive any mail. It all appears in the mail queue under deferred. The error is "mail transport unavailable"

    I can send mail no problem but cannot receive mail.
    Any help would be greatly appreciated!!

    My server is the latest zimbra open source on Ubuntu server 8.04.

  2. #2
    iway is offline Partner (VAR/HSP)
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default

    Have you set the corresponding IP entry in the admin console?

  3. #3
    Mccreations is offline Active Member
    Join Date
    Mar 2008
    Location
    Chicago, IL
    Posts
    49
    Rep Power
    7

    Default

    Quote Originally Posted by interways View Post
    Have you set the corresponding IP entry in the admin console?
    Are you talking about the "MTA Trusted Networks"?

    I believe I have this setup correctly, here's what I have now:
    127.0.0.0/8 192.168.1.14/32

    192.168.1.14 is my server's private IP address.

  4. #4
    santini is offline Starter Member
    Join Date
    Dec 2008
    Posts
    2
    Rep Power
    6

    Default

    I think I'm getting the same error on a similar setup. Smoothwall firewall, with port forwarding setup, to a zimbra server running on ubuntu 8.04.

    I don't know much about how Zimbra/mail works. What it looks like is happening is mail comes into the MTA, and then the local delivery agent is trying to deliver the mail to the local users mail queue/account via the global IP address.

    whatever ports that happens on are most likely blocked and causing the error/non-delivery.

  5. #5
    santini is offline Starter Member
    Join Date
    Dec 2008
    Posts
    2
    Rep Power
    6

    Default

    not sure what the negative side effects of this will be, but I got it working.

    Servers > MTA
    - uncheck 'enable DNS lookup'

    then reboot.

  6. #6
    Mccreations is offline Active Member
    Join Date
    Mar 2008
    Location
    Chicago, IL
    Posts
    49
    Rep Power
    7

    Default

    Quote Originally Posted by santini View Post
    not sure what the negative side effects of this will be, but I got it working.

    Servers > MTA
    - uncheck 'enable DNS lookup'

    then reboot.
    Thanks! That worked, and now I'm receiving mail again.

    I wonder too about negative side effects. If someone could fill us in please...

  7. #7
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,485
    Rep Power
    56

    Default

    The answer for both of you would be a Split DNS set-up.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Mccreations is offline Active Member
    Join Date
    Mar 2008
    Location
    Chicago, IL
    Posts
    49
    Rep Power
    7

    Default

    Quote Originally Posted by phoenix View Post
    The answer for both of you would be a Split DNS set-up.
    Thanks for responding!
    Would you recommend setting up a Split DNS, or should I just leave DNS checks off?
    And one more thing, if I also have a webserver on the same server would a Split DNS cause any troubles with it? Since they're both on the same machine there's no subdomain like mail.mydomain.tld just mydomain.tld, and since the A records are also changed to local IPs in the split DNS would that cause problems with the web server?

    Sorry for the trouble.

  9. #9
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,485
    Rep Power
    56

    Default

    It shouldn't cause you any problems and mail.mydomain.tld isn't a subdomain it would be the FQDN of your mailserver and only show in the A and MX records. As far as the web server is concerned (if you have local DNS records) the a cname record pointing to the server should suffice.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    Mccreations is offline Active Member
    Join Date
    Mar 2008
    Location
    Chicago, IL
    Posts
    49
    Rep Power
    7

    Default

    Quote Originally Posted by phoenix View Post
    It shouldn't cause you any problems and mail.mydomain.tld isn't a subdomain it would be the FQDN of your mailserver and only show in the A and MX records. As far as the web server is concerned (if you have local DNS records) the a cname record pointing to the server should suffice.
    Alright, thanks for all the help!

    You guys are the best!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. Migration Assistance
    By dwill in forum Administrators
    Replies: 10
    Last Post: 12-02-2008, 08:20 AM
  3. Get emails out of zimbra or get it working again?
    By kingfeanor in forum Migration
    Replies: 9
    Last Post: 11-25-2008, 01:02 AM
  4. Problem with Postfix and MTA
    By ZMilton in forum Administrators
    Replies: 16
    Last Post: 04-16-2008, 06:47 AM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •