Results 1 to 8 of 8

Thread: Memory problems with zimbra

  1. #1
    rajeshkodali is offline Loyal Member
    Join Date
    Aug 2007
    Location
    Hyderabad, India
    Posts
    96
    Rep Power
    7

    Default Memory problems with zimbra

    Hi,

    I am facing a big problem with Zimbra's memory handling capabilities. The problem is that my server has been upgraded from 2GB RAM to 8 GB and I see the RAM utilization is around 3 GB-4GB and suddenly the Free memory gets down to 50MB. I am here by attaching chart from hyperic, which shows the same. I have same problem at one other installation. I have made changes to mailboxd_java_heap_memory_percent = 20 and mysql_memory_percent = 25 but still this sudden unavailability is free memory is a puzzle.

    I had to restart the machine and the free memory is back to normal. I have tried restarting zimbra services but it did not help. I think there is some problem with zimbra's memory handling.

    My version is: Release 5.0.10_GA_2638.RHEL4_20081003035619 RHEL4 FOSS edition
    Attached Images Attached Images

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Just because it is taking all the memory does not mean that there is a memory issue. Linux will eat all the memory but also free it up when other applications require the use. Is your server swapping ? perhaps show us a top and freemem from the ZCS server.

  3. #3
    rajeshkodali is offline Loyal Member
    Join Date
    Aug 2007
    Location
    Hyderabad, India
    Posts
    96
    Rep Power
    7

    Default memory issue

    I could bee most of the memory utilized by cache and the swap is not used. I have swapped 16 GB of space. And I could see the swap usage 200KB at the point of less free memory. As I have alerts configured at memory less than 100 MB to the network it causes a huge problem as I have to explain why this happens.

  4. #4
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

  5. #5
    Jbrabander's Avatar
    Jbrabander is offline Elite Member
    Join Date
    May 2008
    Location
    Park City, KS
    Posts
    342
    Rep Power
    6

    Default

    Good article, easy to understand for those of us that don't know much about Linux!

  6. #6
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,366
    Rep Power
    10

    Default

    Quote Originally Posted by rajeshkodali View Post
    I could bee most of the memory utilized by cache and the swap is not used. I have swapped 16 GB of space. And I could see the swap usage 200KB at the point of less free memory. As I have alerts configured at memory less than 100 MB to the network it causes a huge problem as I have to explain why this happens.
    Later Linux kernels seem to be pretty aggressive at moving things out to the swap file. Adding RAM to a Zimbra box after Zimbra has already been installed seems to exacerbate this tendency in our experience. I don't know why; it just happens.

    Consequently, we now as a routine matter add to /etc/sysctl.conf:

    Code:
    vm.swappiness=0
    as described in the Performance Tuning Guidelines for Large Deployments
    wiki article. Swap file usage then goes down to next to nothing.

    Hope that helps,
    Mark

  7. #7
    Viking0 is offline Active Member
    Join Date
    Jun 2008
    Location
    Chile
    Posts
    39
    Rep Power
    6

    Default

    I was worried for the same thing.
    I had a zimbra installation on a 4 GB server and upgraded it up to 8.
    Only problem I had was that maiboxd would not start so I had to set
    mailboxd_java_heap_memory_percent = 18
    Zimbra used all my ram as cache after this change, but after a cuple of days it relased it and now I have 2-3 gb of free ram. I't newer swapped or crashed in my case so don't worry.

  8. #8
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,366
    Rep Power
    10

    Default

    Quote Originally Posted by Viking0 View Post
    I was worried for the same thing.
    I had a zimbra installation on a 4 GB server and upgraded it up to 8.
    Only problem I had was that maiboxd would not start so I had to set
    mailboxd_java_heap_memory_percent = 18
    Zimbra used all my ram as cache after this change, but after a cuple of days it relased it and now I have 2-3 gb of free ram. I't newer swapped or crashed in my case so don't worry.
    Yes, we've also reduced the Java memory footprint to a very small percentage to reduce swap file usage. It works until a full backup runs (300+ mailboxes) and then we would see swap file usage of 100MB or more.

    After a lot of internal testing, we've settled on keeping the Java memory percentages at their default and setting vm.swappiness to zero as our standard build policy.

    As a sidebar, on servers with 12GB or more we've been able to reduce the MySQL memory percentage (you have to change the innodb buffer size manually in my.cnf as well to fully implement) with no reduction in the innodb buffer pool cache hit rates.

    Hope that helps,
    Mark

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zimbra install with perpetually broken logger/stats
    By jptech in forum Installation
    Replies: 8
    Last Post: 09-29-2008, 02:33 PM
  2. Zimbra spam system
    By rajahd in forum Administrators
    Replies: 9
    Last Post: 04-16-2008, 07:25 PM
  3. Replies: 9
    Last Post: 03-01-2008, 08:21 PM
  4. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 02:00 AM
  5. Replies: 22
    Last Post: 12-02-2007, 05:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •