Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: Tomcat personnal php webapp

  1. #11
    dzed is offline Intermediate Member
    Join Date
    Mar 2006
    Posts
    19
    Rep Power
    9

    Default [Solved]

    Everything is working

    Thanks a lot Phoenix, to point me in the right/easyest direction.
    Thanks also goes to Amitbapat.

    If anyone need it, I past the way to do what i have done here :

    I am using a Debian Sarge.


    First of all, change zimbraMailPort and restart zimbra so our apache can listen on 80, do it like this :

    zmprov ms zimbra.mydom.com zimbraMailPort 81
    /etc/init.d/zimbra restart


    Then, install your prefered apache version (1.3 / 2) and add the proxy module :

    for apache 1.3 :
    echo "LoadModule proxy_module /usr/lib/apache/1.3/libproxy.so" >> /etc/apache/modules.conf
    apachectl restart


    for apache 2 :
    ln -s /etc/apache2/mods-available/proxy.load /etc/apache2/mods-enabled/proxy.load
    ln -s /etc/apache2/mods-available/proxy.conf /etc/apache2/mods-enabled/proxy.conf
    /etc/init.d/apache2 restart


    Now we can add our virtualhosts.

    for apache 1.3, go into /etc/apache/conf.d/ and create/edit vhosts.conf :
    [for apache 2 go into /etc/apache2/conf.d/]
    NameVirtualHost *:80

    <VirtualHost *:80>
    ServerAdmin dz@mydom.com
    DocumentRoot /var/www/myweb
    ServerName myweb.mydom.com
    ErrorLog /var/log/apache/myweb-error.log
    CustomLog /var/log/apache/myweb-access.log common
    </VirtualHost>

    <VirtualHost *:80>
    ServerName zimbra.mydom.com
    ServerAdmin dz@mydom.com
    ProxyPass / http://zimbra.mydom.com:81/
    ProxyPassReverse / http://zimbra.mydom.com:81/
    ErrorLog /var/log/apache/zimbra-error.log
    CustomLog /var/log/apache/zimbra-access.log common
    </VirtualHost>


    Almost done.
    Restart everythings.
    Test your new hosts.
    Enjoy ZIMBRA

  2. #12
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Default

    Glad you've got it working, don't forget that you could enter this in the wiki.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #13
    dzed is offline Intermediate Member
    Join Date
    Mar 2006
    Posts
    19
    Rep Power
    9

    Default

    I have added it to the wiki in the 'Advanced Hacking' section (page named 'Running Zimbra and another Apache on the same host')

    Hope it will help someone

  4. #14
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Cool

    Thanks for doing that.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #15
    manimaul is offline Starter Member
    Join Date
    Oct 2006
    Posts
    1
    Rep Power
    8

    Default Addition

    Great guide, thank you. I had one hangup I'd like to point out to help others:

    The default debian /etc/apache2/mods-available/proxy.conf needs to be changed. Of course make sure "ProxyRequests" is Off is you are going to allow from all.

    Code:
    ProxyRequests Off
    <Proxy *>
        Order deny,allow
        Deny from all
        Allow from all
    </Proxy>
    Will Kamp

  6. #16
    prescor is offline Junior Member
    Join Date
    Nov 2006
    Posts
    8
    Rep Power
    8

    Default About the host name...

    I'm writing for some fine-tuning to this idea.

    I have a server in my office that for years has been both my "junk mail" server (Listserv subscriptions and whatnot) as well as my private web server. I have previously run only pop (qmail) but love Zimbra and am moving toward it and IMAP. Here are my needs in this regard. Please tell me if it's feasible using this tip and how best to go about setting up Zimbra to accomplish it:

    1) host.myplace.edu has to be a web server/domain. I've posted lots of junk over the years and don't want to invalidate a whole ton of links by changing it!

    2) host.myplace.edu has to be my smtp server. That doesn't seem to be a problem.

    3) mail.host.myplace.edu has never existed, but seems like it has to. I have set up a CNAME in the myplace.edu DNS tables for this that resolves to host.myplace.edu.

    I appear to have royally screwed up my Zimbra installation (latest beta on Ubuntu 6.10) and am about to 'install -u' and start over. Is there some particular place I should declare "mail.host.myplace.edu" instead of just host.myplace.edu?

    Thanks a lot.

  7. #17
    prescor is offline Junior Member
    Join Date
    Nov 2006
    Posts
    8
    Rep Power
    8

    Default Progress...

    OK, when I set everything up, I just told Zimbra to use port 81. That works fine. Everything about Zimbra is working fine.

    I'm running Ubuntu 6.10 (Edgy) and used apt to install apache2. I modified the apache2.conf file with the virtual hosts. But now when I try to start apache I get:
    ----------
    * Starting apache 2.0 web server...
    /usr/sbin/apache2: /opt/zimbra/cyrus-sasl/lib/libsasl2.so.2: no version information available (required by /usr/lib/libldap_r.so.2)
    ...fail!
    ----------

    For the life of me, I can't figure out why! How can I fix this?

  8. #18
    bunam is offline Intermediate Member
    Join Date
    Oct 2006
    Posts
    21
    Rep Power
    8

    Default

    Code:
     * Forcing reload of apache 2.0 web server...
    /usr/sbin/apache2: /opt/zimbra/cyrus-sasl/lib/libsasl2.so.2: no version information available (required by /usr/lib/libldap_r.so.2)
       ...done.
    same trouble there

  9. #19
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    comment out zimbra entries in /etc/ld.so.conf. run 'ldconfig'. start apache. uncomment zimbra entries in ld.so.conf. run zimbra. you can do this in the apache init script. fwiw I haven't seemed to have to do this with recent zimbra releases, sure you've got latest release?

  10. #20
    bunam is offline Intermediate Member
    Join Date
    Oct 2006
    Posts
    21
    Rep Power
    8

    Default

    ok that work

    many thank's

    i have installed :
    zcs-4.5.4-20070418.UBUNTU6.tgz

    i have find it there :
    http://sourceforge.net/project/showf...kage_id=218409

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Running tomcat after installation(solved)
    By mildred in forum Installation
    Replies: 0
    Last Post: 04-23-2007, 08:26 AM
  2. tomcat not running / postfix/postqueue errors
    By seravitae in forum Installation
    Replies: 7
    Last Post: 03-10-2007, 08:18 PM
  3. tomcat - macosx install - please help
    By gmsmith in forum Installation
    Replies: 3
    Last Post: 04-19-2006, 12:30 PM
  4. Replies: 2
    Last Post: 03-10-2006, 03:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •