Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: www Port Conflict/Changing Zimbra Apache Setting

  1. #1
    macguru is offline Intermediate Member
    Join Date
    Apr 2006
    Posts
    17
    Rep Power
    9

    Default www Port Conflict/Changing Zimbra Apache Setting

    Hi,

    I have encountered a nasty problem which still keeps out my Zimbra installation out of net stream. Zimbra launches its own copy of Apache which takes ports 80 (http) and 443 (http SSL). However, I cannot move our company web scripts into Zimbra's Apache because we have our own custom installation on the same SuSE 10 box.

    So, I took the shortest route and tried to change Zimbra's Apache ports 80 to 81 and 443 to 444 respectively using this script:

    /opt/zimbra/libexec/zmsetup.pl

    After applying configuration and starting services again Zimbra's Apache still listening port 80. I have manually edited httpd.cong, no effect anyway.

    So I digged forums and found this:

    For anyone else who runs into this, what I did was edit:
    /opt/zimbra/jakarta-tomcat-5.5.7/webapps/service/WEB-INF/web.xml
    <param-value>80, 443, 7070, 7443</param-value>
    To read:
    HTML Code:
    <param-value>80, 443, 7070, 7443, 8888</param-value>


    As a followup, it seems this is no longer true.
    Well, it is, but it no longer works this way :-)
    Any changes you make to web.xml are now overwritten when Zimbra starts up. You can make those same changes in this file:
    /opt/zimbra/jakarta-tomcat-5.5.7/conf/service.web.xml.in
    And that will solve this problem.


    So, what is the proper way to instruct Zimbra's Apache to run for example on port 8080 for http and port 8081 for http SSL?

    Of course, I can edit my firewall rules to swap ports, but this is rather awkward solution. I think, it would be better to change Zimbra's Apache behaviour.

    Thanks in advance for any help.

    PS. Please add this topic to the admin manual, or at least, wiki/faq site.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Zimbra install should find the port conflicts and you have the option to change them at that time. My advice, FWIW, is to run the install script again and make the changes when you do that. BTW, Zimbra doesn't use Apache it uses Tomcat.

    You can always add the information to the wiki yourself.
    Last edited by phoenix; 04-10-2006 at 03:25 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    macguru is offline Intermediate Member
    Join Date
    Apr 2006
    Posts
    17
    Rep Power
    9

    Default Changing www port #

    Hi, Bill,

    Thanks a lot for reply.

    As I wrote in my previous post, I did changed the port # with:

    /opt/zimbra/libexec/zmsetup.pl

    However, it had no effect whatsoever (at least, in my case, I have even rebooted system).

    What could be another solution?

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    That wasn't what I meant, I was suggesting you run install.sh again and go through the install process and change the ports at the end, before you commit the upgrade.

    When you ran zmsetup.pl were you doing at as 'su - zimbra'?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    macguru is offline Intermediate Member
    Join Date
    Apr 2006
    Posts
    17
    Rep Power
    9

    Default Re: Changing www port #

    Hi, Bill,

    No, I have run it as root.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    All zimbra commands are run as 'su - zimbra' otherwise you'll get problems.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    bobby is offline Zimbra Employee
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    10

    Default

    there are a few things that should be run as root . you'll notice for some that it prompts for a password or states "Warning: libexec/zmsetup.pl must be run as root!".

    you can change the webmail access ports like this (with the appropriate SERVERNAME):

    su - zimbra
    zmprov ms SERVERNAME zimbraMailPort 81
    zmprov ms SERVERNAME zimbraMailSSLPort 444
    tomcat restart

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by bobby
    there are a few things that should be run as root .
    I'm having a bad day today, I'll go back to sleep for a while and see if that helps.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    macguru is offline Intermediate Member
    Join Date
    Apr 2006
    Posts
    17
    Rep Power
    9

    Default Re: www Port Conflict/Changing Zimbra Apache Setting

    Thanks! Its worked finally :-))

  10. #10
    raph is offline Junior Member
    Join Date
    Dec 2005
    Posts
    6
    Rep Power
    9

    Default

    where can i find more info about the zmprov command seems quite usefull but when i run it with -h argument it doesnt seems to give me all the options

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 26
    Last Post: 04-19-2011, 09:24 AM
  2. Replies: 31
    Last Post: 12-15-2007, 09:05 PM
  3. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 10:39 AM
  4. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 01:00 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •