Results 1 to 3 of 3

Thread: barracuda spam firewall corrupting messages from zimbra

  1. #1
    jdell is offline Project Contributor
    Join Date
    Jul 2006
    Location
    Reno, NV, USA
    Posts
    203
    Rep Power
    9

    Default barracuda spam firewall corrupting messages from zimbra

    Hi,

    Just an FYI...

    We are running ZCS 5.0.10 and recently started getting email bouncing back from certain domains saying the email was corrupted. This only occurred for emails with attachments, plain text emails were fine.

    Basically, email *from* zimbra 5.0.10 with attachments going to a domain that is fronted by a barracuda spam firewall with firmware version 3.5.11.020 (released in April 2008) was somehow corrupting the emails.

    Sending the same email (w/attachments) from a gmail account to the same domain was going through fine, so there was something specific about the way zimbra constructed the headers or mime stuff that choked barracuda spam firewall.

    After the admin at the remote domain upgraded to the latest firmware version for barracuda spam firewall (3.5.12.007 released in November), emails from our zimbra server are now being delivered properly. There was another version from May that is probably also ok (3.5.11.025)

    The admin said that in the barracuda firmware release notes, there are no specific notes about issues with attachments but there were a few changes to the way attachments are handled. The admin only found anecdotal evidence about corruption problems with 3.5.11.020 in the Barracuda Support forum.

    John
    Last edited by jdell; 11-17-2008 at 04:42 PM.

  2. #2
    Rich Graves is offline Outstanding Member
    Join Date
    Jan 2007
    Location
    Minnesota
    Posts
    718
    Rep Power
    9

    Default

    I'm certainly no fan of Barracuda, but this could be Zimbra's fault.

    Were the attachments tagged with the wrong MIME type? See Bug 32536 - Zimbra too trusting of MIME-type sent by client

  3. #3
    jdell is offline Project Contributor
    Join Date
    Jul 2006
    Location
    Reno, NV, USA
    Posts
    203
    Rep Power
    9

    Default

    Quote Originally Posted by Rich Graves View Post
    I'm certainly no fan of Barracuda, but this could be Zimbra's fault.

    Were the attachments tagged with the wrong MIME type? See Bug 32536 - Zimbra too trusting of MIME-type sent by client
    Ahh, I didn't think about that. Sure enough...Looking at the corrupted emails, the mime type for word docs were application/applefile.

    This happened for a Windows XP client running FF3 and the web client as well as a Windows XP user running Thunderbird (smtp through zimbra).

    So, presumably, this word doc was created on a Mac somewhere, and the mime type carried over somehow. Any idea how that works? Does the mime type get embedded in the file? The files did have a .doc file extension.

    Thanks,
    John

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. slapd message error
    By smoke in forum Administrators
    Replies: 7
    Last Post: 04-27-2008, 03:23 PM
  2. Replies: 9
    Last Post: 03-01-2008, 08:21 PM
  3. Replies: 31
    Last Post: 12-15-2007, 09:05 PM
  4. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 12:45 PM
  5. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 06:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •