Results 1 to 6 of 6

Thread: ClamAV Failing

  1. #1
    dorgan1983 is offline Active Member
    Join Date
    May 2008
    Location
    Cocoa, FL
    Posts
    32
    Rep Power
    7

    Default ClamAV Failing

    seems like every morning lately I am seeing this error in the log and then i have to restart zimbra to get everything back up and working again.

    ClamAV-clamd: Can't connect to INET socket 127.0.0.1:3310: Connection refused, retrying (1)

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    Some idea of Zimbra version/release would help (update your forum profile with the output from 'zmcontrol -v') plus what errors do you see in the log files?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    dorgan1983 is offline Active Member
    Join Date
    May 2008
    Location
    Cocoa, FL
    Posts
    32
    Rep Power
    7

    Default

    Sorry about that. I am running version: zcs-5.0.10_GA_2638.UBUNTU6.20081003054415

    Here is a larger section of /var/log/zimbra.log

    Nov 14 10:15:50 twoguyshosting amavis[3205]: (03205-09) (!!)ClamAV-clamd av-scanner FAILED: CODE(0x8178a80) Too many retries to talk to 127.0.0.1:3310 (Can't
    connect to INET socket 127.0.0.1:3310: Connection refused) at (eval 74) line 310. at (eval 74) line 511.
    Nov 14 10:15:50 twoguyshosting amavis[3205]: (03205-09) (!!)WARN: all primary virus scanners failed, considering backups
    Nov 14 10:15:50 twoguyshosting amavis[3205]: (03205-09) (!!)TROUBLE in check_mail: virus_scan FAILED: virus_scan: ALL VIRUS SCANNERS FAILED: ClamAV-clamd av-s
    canner FAILED: CODE(0x8178a80) Too many retries to talk to 127.0.0.1:3310 (Can't connect to INET socket 127.0.0.1:3310: Connection refused) at (eval 74) line
    310. at (eval 74) line 511.
    Nov 14 10:15:50 twoguyshosting amavis[3205]: (03205-09) (!)PRESERVING EVIDENCE in /opt/zimbra/data/amavisd/tmp/amavis-20081114T101543-03205
    Nov 14 10:15:50 twoguyshosting postfix/smtp[24767]: 59BAE790029: to=<dorgan@donaldorgan.com>, orig_to=<donald@donaldorgan.com>, relay=127.0.0.1[127.0.0.1]:100
    24, delay=8932, delays=8916/8/0.09/7.2, dsn=4.5.0, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 Error in processing, id=03205-09, virus_scan FAI
    LED: virus_scan: ALL VIRUS SCANNERS FAILED: ClamAV-clamd av-scanner FAILED: CODE(0x8178a80) Too many retries to talk to 127.0.0.1:3310 (Can't connect to INET
    socket 127.0.0.1:3310: Connection refused) at (eval 74) line 310. at (eval 74) line 511. (in reply to end of DATA command))
    Nov 14 10:15:50 twoguyshosting amavis[30483]: (30483-14) (!)run_av (ClamAV-clamd, built-in i/f): Too many retries to talk to 127.0.0.1:3310 (Can't connect to
    INET socket 127.0.0.1:3310: Connection refused) at (eval 74) line 310.
    Nov 14 10:15:50 twoguyshosting amavis[30483]: (30483-14) (!!)ClamAV-clamd av-scanner FAILED: CODE(0x8178a80) Too many retries to talk to 127.0.0.1:3310 (Can't
    connect to INET socket 127.0.0.1:3310: Connection refused) at (eval 74) line 310. at (eval 74) line 511.
    Nov 14 10:15:50 twoguyshosting amavis[30483]: (30483-14) (!!)WARN: all primary virus scanners failed, considering backups
    Nov 14 10:15:50 twoguyshosting amavis[30483]: (30483-14) (!!)TROUBLE in check_mail: virus_scan FAILED: virus_scan: ALL VIRUS SCANNERS FAILED: ClamAV-clamd av-
    scanner FAILED: CODE(0x8178a80) Too many retries to talk to 127.0.0.1:3310 (Can't connect to INET socket 127.0.0.1:3310: Connection refused) at (eval 74) line
    310. at (eval 74) line 511.
    Nov 14 10:15:50 twoguyshosting amavis[30483]: (30483-14) (!)PRESERVING EVIDENCE in /opt/zimbra/data/amavisd/tmp/amavis-20081114T101543-30483

  4. #4
    dorgan1983 is offline Active Member
    Join Date
    May 2008
    Location
    Cocoa, FL
    Posts
    32
    Rep Power
    7

    Default

    Anyone have any ideas??

  5. #5
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    Quote Originally Posted by dorgan1983 View Post
    Anyone have any ideas??
    Try being a bit more patient, you'll get an answer when people have the time. You coild also have searched the forums for the answer.

    Try the following:

    Code:
    su - zimbra
    mkdir /tmp/clamdb
    mv /opt/zimbra/clamav/db/* /tmp/clamdb
    /opt/zimbra/clamav/bin/freshclam --config-file=/opt/zimbra/conf/freshclam.conf
    zmamavisdctl stop
    zmamavisdctl start
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    dorgan1983 is offline Active Member
    Join Date
    May 2008
    Location
    Cocoa, FL
    Posts
    32
    Rep Power
    7

    Default Sorry

    Yes, sorry, you are correct. I have to be more patient.

    I will try what you suggested and see what happens the next couple of days.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Howto: Update ClamAV
    By unilogic in forum Administrators
    Replies: 9
    Last Post: 12-12-2007, 05:28 AM
  2. [SOLVED] Clamav expiration notification
    By artimus in forum Administrators
    Replies: 8
    Last Post: 11-19-2007, 10:34 AM
  3. Outdated ClamAV warning in log
    By emx in forum Installation
    Replies: 1
    Last Post: 07-16-2007, 11:07 AM
  4. help for clamav outdated
    By newvision in forum Administrators
    Replies: 3
    Last Post: 02-16-2007, 09:14 PM
  5. Replies: 2
    Last Post: 03-15-2006, 09:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •