Results 1 to 4 of 4

Thread: [SOLVED] CA Cert Question.

  1. #1
    Nitecon is offline Junior Member
    Join Date
    Sep 2008
    Posts
    6
    Rep Power
    6

    Default [SOLVED] CA Cert Question.

    Good morning ladies and gents.

    I recently installed a CA cert from cacert.org, since I didn't feel like paying for one. The installation went fine...

    Generated the csr downloaded the ca root and intermediate. Received my cert back and all is fine so far.

    Here is the only problem I have.

    The certificate is for mydomain.com

    I access the server by going to subdomain.mydomain.com

    By doing this I am notified that the cert is for the wrong site. It is only valid for mydomain.com.

    Since I can't change the email domain to subdomain.mydomain.com for the reason that all email will then be user@subdomain.mydomain.com instead of user@mydomain.com. How do I fix this issue?

    It's rather an important issue that needs to be fixed asap, so all information would be appreciated.

    Thank you,
    Will.

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    So create the cert for subdomain.mydomain.com as that is the distinguished name of your server. It does not effect anything else and your emails will still be marked as domain.com.

  3. #3
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,292
    Rep Power
    13

    Default

    You can create a new CSR for subdomain.mydomain.com and use this one.

    Or get a wildcard certificate.

  4. #4
    Nitecon is offline Junior Member
    Join Date
    Sep 2008
    Posts
    6
    Rep Power
    6

    Default

    Thanks guys,

    Now I seem to have a new issue that popped up, just for some background info I am running 5.0.10 on ubuntu 8.

    I generated a wildcard cert got it signed etc.

    After I generated the csr I restarted zimbra with zmcontrol stop && zmcontrol start...

    Then I logged in again and used the root.crt and intermediate.crt from ca cert with my new wildcard.crt from ca cert. Like before I just did it through the admin control panel. Although this time it through an error at me saying...

    ...............

    I just redid the same steps and now it is working... Does zimbra cache the certs for a specified time before it updates? To the new key pairs etc?

    Find it rather odd that that happened.

    Problem is solved now just curious as to why it did that.

    Hopefully soon I can buy a proper ca cert, for now this should do fine

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Upgrade Self Signed Cert to Commercial Cert (godaddy)
    By lareck in forum Administrators
    Replies: 1
    Last Post: 01-04-2010, 02:51 AM
  2. Replies: 2
    Last Post: 03-25-2007, 09:40 PM
  3. Multi Name SSL Cert Question
    By kirme3 in forum Administrators
    Replies: 1
    Last Post: 09-20-2006, 03:15 PM
  4. Question installing commercial SSL cert
    By jigi in forum Administrators
    Replies: 0
    Last Post: 02-13-2006, 12:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •